summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2006-01-18 07:17:19 +0000
committerSteve Arnold <nerdboy@gentoo.org>2006-01-18 07:17:19 +0000
commit7d02cff96868109c3d7693b7313a0c40290fcf24 (patch)
treec5fb545020f0a6ed0f3f645bdd477bf8957be54e /app-doc/doxygen/doxygen-1.4.2.ebuild
parentVersion bump. Allows compilation under Java 1.5 (bug #97722). (diff)
downloadgentoo-2-7d02cff96868109c3d7693b7313a0c40290fcf24.tar.gz
gentoo-2-7d02cff96868109c3d7693b7313a0c40290fcf24.tar.bz2
gentoo-2-7d02cff96868109c3d7693b7313a0c40290fcf24.zip
added workaround for bug 118580, and new version for bugs 117613 and 110615
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'app-doc/doxygen/doxygen-1.4.2.ebuild')
-rw-r--r--app-doc/doxygen/doxygen-1.4.2.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/app-doc/doxygen/doxygen-1.4.2.ebuild b/app-doc/doxygen/doxygen-1.4.2.ebuild
index c15d577c16a7..02569316f961 100644
--- a/app-doc/doxygen/doxygen-1.4.2.ebuild
+++ b/app-doc/doxygen/doxygen-1.4.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.4.2.ebuild,v 1.13 2005/12/21 03:30:53 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.4.2.ebuild,v 1.14 2006/01/18 07:17:19 nerdboy Exp $
inherit eutils toolchain-funcs
@@ -44,11 +44,15 @@ src_unpack() {
src_compile() {
# set ./configure options (prefix, Qt based wizard, docdir)
- local confopts="--prefix ${D}usr"
- use qt && confopts="${confopts} --with-doxywizard"
+ local my_conf="--prefix ${D}usr"
+ if use qt; then
+ export LD_LIBRARY_PATH=$QTDIR/$(get_libdir):$LD_LIBRARY_PATH \
+ export LIBRARY_PATH=$QTDIR/$(get_libdir):$LIBRARY_PATH \
+ my_conf="${my_conf} $(use_with qt doxywizard)"
+ fi
# ./configure and compile
- ./configure ${confopts} || die '"./configure" failed.'
+ ./configure ${my_conf} || die '"./configure" failed.'
make DESTDIR="${D}" all || die '"make all" failed.'
# generate html and pdf (if tetex in use) documents.