summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-05-29 20:17:08 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-05-29 20:17:08 +0000
commit13a74c7b6dcc3f9933606ee27d6152aecaeec32b (patch)
treea4f74e013909c3953792cda9dc90917c7a965900 /app-doc/doxygen
parentMarking grip-3.3.1-r3 ppc for bug 414825 (diff)
downloadgentoo-2-13a74c7b6dcc3f9933606ee27d6152aecaeec32b.tar.gz
gentoo-2-13a74c7b6dcc3f9933606ee27d6152aecaeec32b.tar.bz2
gentoo-2-13a74c7b6dcc3f9933606ee27d6152aecaeec32b.zip
Version bump
(Portage version: 2.2.0_alpha108/cvs/Linux x86_64)
Diffstat (limited to 'app-doc/doxygen')
-rw-r--r--app-doc/doxygen/ChangeLog8
-rw-r--r--app-doc/doxygen/doxygen-1.8.1.ebuild234
-rw-r--r--app-doc/doxygen/files/doxygen-1.8.1-prefix-misc-alt.patch82
3 files changed, 323 insertions, 1 deletions
diff --git a/app-doc/doxygen/ChangeLog b/app-doc/doxygen/ChangeLog
index b65418a22426..9c95c5f26525 100644
--- a/app-doc/doxygen/ChangeLog
+++ b/app-doc/doxygen/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-doc/doxygen
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/ChangeLog,v 1.223 2012/05/08 10:27:47 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/ChangeLog,v 1.224 2012/05/29 20:17:08 xarthisius Exp $
+
+*doxygen-1.8.1 (29 May 2012)
+
+ 29 May 2012; Kacper Kowalik <xarthisius@gentoo.org> +doxygen-1.8.1.ebuild,
+ +files/doxygen-1.8.1-prefix-misc-alt.patch:
+ Version bump
08 May 2012; Kacper Kowalik <xarthisius@gentoo.org> doxygen-1.4.7.ebuild,
doxygen-1.5.4.ebuild, doxygen-1.5.8-r1.ebuild, doxygen-1.6.3.ebuild,
diff --git a/app-doc/doxygen/doxygen-1.8.1.ebuild b/app-doc/doxygen/doxygen-1.8.1.ebuild
new file mode 100644
index 000000000000..082a6ce47f6d
--- /dev/null
+++ b/app-doc/doxygen/doxygen-1.8.1.ebuild
@@ -0,0 +1,234 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.8.1.ebuild,v 1.1 2012/05/29 20:17:08 xarthisius Exp $
+
+EAPI=4
+
+inherit eutils fdo-mime flag-o-matic python qt4-r2 toolchain-funcs
+
+DESCRIPTION="Documentation system for most programming languages"
+HOMEPAGE="http://www.doxygen.org/"
+SRC_URI="http://ftp.stack.nl/pub/users/dimitri/${P}.src.tar.gz
+ http://dev.gentoo.org/~xarthisius/distfiles/doxywizard.png"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="debug doc dot qt4 latex elibc_FreeBSD userland_GNU"
+
+#missing SerbianCyrilic, JapaneseEn, KoreanEn, Chinesetraditional
+
+LANGS=(hy ar pt_BR ca zh cs de da eo es fa fi fr el hr hu id it ja ko lt mk
+nl nb pl pt ro ru sl sk sr sv tr uk vi af)
+for X in "${LANGS[@]}" ; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+RDEPEND="qt4? ( x11-libs/qt-gui:4 )
+ latex? ( app-text/texlive[extra] )
+ dev-lang/perl
+ virtual/libiconv
+ media-libs/libpng
+ app-text/ghostscript-gpl
+ dot? (
+ media-gfx/graphviz
+ media-libs/freetype
+ )"
+
+DEPEND="sys-apps/sed
+ sys-devel/flex
+ sys-devel/bison
+ doc? ( =dev-lang/python-2* )
+ ${RDEPEND}"
+
+RESTRICT="mirror"
+EPATCH_SUFFIX="patch"
+
+get_langs() {
+ # using only user set linguas also fixes #263641
+ my_linguas=()
+ for lingua in ${LINGUAS}; do
+ if has ${lingua} "${LANGS[@]}"; then
+ case ${lingua} in
+ hy) lingua=am ;;
+ pt_BR) lingua=br ;;
+ zh*) lingua=cn ;;
+ cs) lingua=cz ;;
+ da) lingua=dk ;;
+ el*) lingua=gr ;;
+ ja*) lingua=jp ;;
+ ko) lingua=kr ;;
+ nb) lingua=no ;;
+ sl) lingua=si ;;
+ tr*) lingua=tr ;;
+ uk) lingua=ua ;;
+ af) lingua=za ;;
+ esac
+ has ${lingua} "${my_linguas[@]}" ||
+ my_linguas+=(${lingua})
+ fi
+ done
+ f_langs="${my_linguas[@]}"
+ echo ${f_langs// /,}
+}
+
+pkg_setup() {
+ tc-export CC CXX
+ if use doc; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ # use CFLAGS, CXXFLAGS, LDFLAGS
+ export ECFLAGS="${CFLAGS}" ECXXFLAGS="${CXXFLAGS}" ELDFLAGS="${LDFLAGS}"
+
+ sed -i.orig -e 's:^\(TMAKE_CFLAGS_RELEASE\t*\)= .*$:\1= $(ECFLAGS):' \
+ -e 's:^\(TMAKE_CXXFLAGS_RELEASE\t*\)= .*$:\1= $(ECXXFLAGS):' \
+ -e 's:^\(TMAKE_LFLAGS_RELEASE\s*\)=.*$:\1= $(ELDFLAGS):' \
+ -e "s:^\(TMAKE_CXX\s*\)=.*$:\1= $(tc-getCXX):" \
+ -e "s:^\(TMAKE_LINK\s*\)=.*$:\1= $(tc-getCXX):" \
+ -e "s:^\(TMAKE_LINK_SHLIB\s*\)=.*$:\1= $(tc-getCXX):" \
+ -e "s:^\(TMAKE_CXX\s*\)=.*$:\1= $(tc-getCC):" \
+ tmake/lib/{{linux,gnu,freebsd,netbsd,openbsd,solaris}-g++,macosx-c++,linux-64}/tmake.conf \
+ || die
+
+ # Ensure we link to -liconv
+ if use elibc_FreeBSD; then
+ for pro in */*.pro.in */*/*.pro.in; do
+ echo "unix:LIBS += -liconv" >> "${pro}"
+ done
+ fi
+
+ # Call dot with -Teps instead of -Tps for EPS generation - bug #282150
+ sed -i -e '/addJob("ps"/ s/"ps"/"eps"/g' src/dot.cpp || die
+
+ # prefix search tools patch, plus OSX fixes
+ epatch "${FILESDIR}"/${P}-prefix-misc-alt.patch
+
+ # fix final DESTDIR issue
+ sed -i.orig -e "s:\$(INSTALL):\$(DESTDIR)/\$(INSTALL):g" \
+ -e "s/all: Makefile.doxywizard/all:/g" \
+ addon/doxywizard/Makefile.in || die
+
+ # fix pdf doc
+ sed -i.orig -e "s:g_kowal:g kowal:" \
+ doc/maintainers.txt || die
+
+ if is-flagq "-O3" ; then
+ echo
+ ewarn "Compiling with -O3 is known to produce incorrectly"
+ ewarn "optimized code which breaks doxygen."
+ echo
+ elog "Continuing with -O2 instead ..."
+ echo
+ replace-flags "-O3" "-O2"
+ fi
+}
+
+src_configure() {
+ # set ./configure options (prefix, Qt based wizard, docdir)
+
+ local my_conf="--shared --enable-langs $(get_langs)"
+
+ if use debug ; then
+ my_conf="${my_conf} --debug"
+ else
+ my_conf="${my_conf} --release "
+ fi
+
+ use ppc64 && my_conf="${my_conf} --english-only" #263641
+
+ use qt4 && my_conf="${my_conf} --with-doxywizard"
+
+ # On non GNU userland (e.g. BSD), configure script picks up make and bails
+ # out because it is not GNU make, so we force the right value.
+ use userland_GNU || my_conf="${my_conf} --make ${MAKE} --install install"
+
+ export LINK="${QMAKE_LINK}"
+ export LINK_SHLIB="${QMAKE_CXX}"
+
+ if use qt4 ; then
+ pushd addon/doxywizard &> /dev/null
+ eqmake4 doxywizard.pro -o Makefile.doxywizard
+ popd &> /dev/null
+ fi
+
+ ./configure --prefix "${EPREFIX}/usr" ${my_conf} \
+ || die
+}
+
+src_compile() {
+
+ emake CFLAGS+="${ECFLAGS}" CXXFLAGS+="${ECXXFLAGS}" \
+ LFLAGS+="${ELDFLAGS}" all
+
+ # generate html and pdf (if tetex in use) documents.
+ # errors here are not considered fatal, hence the ewarn message
+ # TeX's font caching in /var/cache/fonts causes sandbox warnings,
+ # so we allow it.
+ if use doc; then
+ if ! use dot; then
+ sed -i -e "s/HAVE_DOT = YES/HAVE_DOT = NO/" \
+ {Doxyfile,doc/Doxyfile} \
+ || ewarn "disabling dot failed"
+ fi
+ if use latex; then
+ addwrite /var/cache/fonts
+ addwrite /var/cache/fontconfig
+ addwrite /usr/share/texmf/fonts/pk
+ addwrite /usr/share/texmf/ls-R
+ make pdf || ewarn '"make pdf docs" failed.'
+ else
+ cp doc/Doxyfile doc/Doxyfile.orig
+ cp doc/Makefile doc/Makefile.orig
+ sed -i.orig -e "s/GENERATE_LATEX = YES/GENERATE_LATEX = NO/" \
+ doc/Doxyfile
+ sed -i.orig -e "s/@epstopdf/# @epstopdf/" \
+ -e "s/@cp Makefile.latex/# @cp Makefile.latex/" \
+ -e "s/@sed/# @sed/" doc/Makefile
+ make docs || ewarn '"make docs" failed.'
+ fi
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" MAN1DIR=share/man/man1 install
+
+ if use qt4; then
+ doicon "${DISTDIR}/doxywizard.png"
+ make_desktop_entry doxywizard "DoxyWizard ${PV}" \
+ "/usr/share/pixmaps/doxywizard.png" \
+ "Application;Development"
+ fi
+
+ dodoc INSTALL LANGUAGE.HOWTO README
+
+ # pdf and html manuals
+ if use doc; then
+ dohtml -r html/*
+ use latex && dodoc latex/doxygen_manual.pdf
+ fi
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+
+ elog
+ elog "The USE flags qt4, doc, and latex will enable doxywizard, or"
+ elog "the html and pdf documentation, respectively. For examples"
+ elog "and other goodies, see the source tarball. For some example"
+ elog "output, run doxygen on the doxygen source using the Doxyfile"
+ elog "provided in the top-level source dir."
+ elog
+ elog "Disabling the dot USE flag will remove the GraphViz dependency,"
+ elog "along with Doxygen's ability to generate diagrams in the docs."
+ elog "See the Doxygen homepage for additional helper tools to parse"
+ elog "more languages."
+ elog
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}
diff --git a/app-doc/doxygen/files/doxygen-1.8.1-prefix-misc-alt.patch b/app-doc/doxygen/files/doxygen-1.8.1-prefix-misc-alt.patch
new file mode 100644
index 000000000000..0ecaf4db37b4
--- /dev/null
+++ b/app-doc/doxygen/files/doxygen-1.8.1-prefix-misc-alt.patch
@@ -0,0 +1,82 @@
+* make sure we always look for tools in the path, no "do it yourself paths"
+
+--- a/configure
++++ b/configure
+@@ -170,27 +170,15 @@
+ ;;
+ Darwin:*)
+ f_platform=macosx-c++
+- if test "$f_insttool" = NO; then
+- f_insttool=/usr/bin/install
+- fi
+ ;;
+ FreeBSD:*)
+ f_platform=freebsd-g++
+- if test "$f_insttool" = NO; then
+- f_insttool=/usr/bin/install
+- fi
+ ;;
+ NetBSD:*)
+ f_platform=netbsd-g++
+- if test "$f_insttool" = NO; then
+- f_insttool=/usr/bin/install
+- fi
+ ;;
+ HP-UX:*)
+ f_platform=hpux-g++
+- if test "$f_insttool" = NO; then
+- f_insttool=/usr/bin/install
+- fi
+ ;;
+ IRIX64:*)
+ f_platform=irix-64
+@@ -221,9 +209,6 @@
+ ;;
+ SunOS:5*)
+ f_platform=solaris-g++
+- if test "$f_insttool" = NO; then
+- f_insttool=/usr/bin/install
+- fi
+ ;;
+ ULTRIX:*)
+ f_platform=ultrix-g++
+@@ -323,8 +308,8 @@
+
+ echo -n " Checking for GNU install tool... "
+ if test "$f_insttool" = NO; then
+- install_names="ginstall install"
+- install_dirs="$bin_dirs /usr/bin /usr/local/bin /bin /sbin /usr/ucb"
++ install_names="install"
++ install_dirs="$bin_dirs"
+ install_prog=NO
+ install_found=NO
+ for i in $install_names; do
+@@ -360,7 +345,7 @@
+
+ echo -n " Checking for dot (part of GraphViz)... "
+ if test "$f_dot" = NO; then
+- dot_dirs="$bin_dirs /usr/bin /usr/local/bin /bin /sbin"
++ dot_dirs="$bin_dirs"
+ dot_prog=NO
+ for j in $dot_dirs; do
+ if test -x "$j/dot"; then
+@@ -382,7 +367,7 @@
+ echo -n " Checking for perl... "
+ if test "$f_perl" = NO; then
+ perl_names="perl perl5"
+- perl_dirs="$bin_dirs /usr/bin /usr/local/bin /bin /sbin"
++ perl_dirs="$bin_dirs"
+ perl_prog=NO
+ perl_found=NO
+ for i in $perl_names; do
+@@ -546,10 +531,6 @@
+ cat >> .tmakeconfig <<EOF
+ TMAKE_LFLAGS += -non_shared
+ EOF
+- elif test "$f_platform" = "solaris-cc"; then
+- cat >> .tmakeconfig <<EOF
+- TMAKE_LFLAGS += -Bstatic
+-EOF
+ elif test "$f_platform" = "hpux-cc"; then
+ cat >> .tmakeconfig <<EOF
+ TMAKE_LFLAGS += -noshared