summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-07-09 19:48:39 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-07-09 19:48:39 +0000
commit9c4fdae3b9cec4a2ca1c0e41f16daf835966d314 (patch)
tree8473672bcf1aeafe85389f8561e4795abf6f6c6f /app-doc/quanta-docs/quanta-docs-20041123.ebuild
parent- amd64 profile updates for building with catalyst (diff)
downloadgentoo-2-9c4fdae3b9cec4a2ca1c0e41f16daf835966d314.tar.gz
gentoo-2-9c4fdae3b9cec4a2ca1c0e41f16daf835966d314.tar.bz2
gentoo-2-9c4fdae3b9cec4a2ca1c0e41f16daf835966d314.zip
New version, using prepackaged tarballs. Fixes #97879.
(Portage version: 2.0.51.19)
Diffstat (limited to 'app-doc/quanta-docs/quanta-docs-20041123.ebuild')
-rw-r--r--app-doc/quanta-docs/quanta-docs-20041123.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-doc/quanta-docs/quanta-docs-20041123.ebuild b/app-doc/quanta-docs/quanta-docs-20041123.ebuild
new file mode 100644
index 000000000000..08977a614fea
--- /dev/null
+++ b/app-doc/quanta-docs/quanta-docs-20041123.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-doc/quanta-docs/quanta-docs-20041123.ebuild,v 1.1 2005/07/09 19:48:39 greg_g Exp $
+
+DESCRIPTION="Language documentation files for quanta."
+HOMEPAGE="http://quanta.kdewebdev.org/"
+SRC_URI="mirror://gentoo/${PN}-css-${PV}.tar.bz2
+ mirror://gentoo/${PN}-html-${PV}.tar.bz2
+ mirror://gentoo/${PN}-javascript-${PV}.tar.bz2
+ mirror://gentoo/${PN}-php-${PV}.tar.bz2
+ mysql? ( mirror://gentoo/${PN}-mysql-${PV}.tar.bz2 )"
+# These files are snapshots based respectively on:
+# mirror://sourceforge/quanta/css.tar.bz2
+# mirror://sourceforge/quanta/html.tar.bz2
+# mirror://sourceforge/quanta/javascript.tar.bz2
+# mirror://sourceforge/quanta/php_manual_en_20030401.tar.bz2
+# mirror://sourceforge/quanta/mysql-20030405.tar.bz2
+
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="mysql"
+
+S=${WORKDIR}
+
+src_install() {
+ dodir /usr/share/apps/quanta/doc
+
+ local docdirs="css html javascript php"
+ use mysql && docdirs="${docdirs} mysql"
+
+ for i in ${docdirs}; do
+ cd "${S}/${i}"
+ cp -R "$i" "$i.docrc" "${D}/usr/share/apps/quanta/doc"
+ done
+}