summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2006-10-04 03:52:54 +0000
committerHanno Böck <hanno@gentoo.org>2006-10-04 03:52:54 +0000
commitff9118e508c571f4ee830c787e2627d0b6c0832d (patch)
tree8017e45272149d7edf2d9181fe02d36901008f71 /app-editors/bluefish/bluefish-1.0.6.ebuild
parentMerged changes with gcj-overlay, bug #145769. (diff)
downloadgentoo-2-ff9118e508c571f4ee830c787e2627d0b6c0832d.tar.gz
gentoo-2-ff9118e508c571f4ee830c787e2627d0b6c0832d.tar.bz2
gentoo-2-ff9118e508c571f4ee830c787e2627d0b6c0832d.zip
bluefish version bump
(Portage version: 2.1.2_pre2-r2)
Diffstat (limited to 'app-editors/bluefish/bluefish-1.0.6.ebuild')
-rw-r--r--app-editors/bluefish/bluefish-1.0.6.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-editors/bluefish/bluefish-1.0.6.ebuild b/app-editors/bluefish/bluefish-1.0.6.ebuild
new file mode 100644
index 000000000000..ded09bf9f63a
--- /dev/null
+++ b/app-editors/bluefish/bluefish-1.0.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/bluefish-1.0.6.ebuild,v 1.1 2006/10/04 03:52:54 hanno Exp $
+
+inherit eutils fdo-mime
+
+IUSE="nls spell gnome"
+
+DESCRIPTION="A GTK HTML editor for the experienced web designer or programmer."
+SRC_URI="http://www.bennewitz.com/bluefish/stable/source/${P}.tar.bz2"
+HOMEPAGE="http://bluefish.openoffice.nl/"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+
+RDEPEND=">=x11-libs/gtk+-2
+ dev-libs/libpcre
+ spell? ( app-text/aspell )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )
+ gnome? ( gnome-base/libgnomeui )"
+
+src_compile() {
+ econf --disable-update-databases \
+ `use_enable nls` \
+ `use_with gnome libgnomeui` || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}
+
+pkg_postinst() {
+ update-mime-database /usr/share/mime
+}