summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2012-04-08 21:18:49 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2012-04-08 21:18:49 +0000
commit67af3970c0ee8756a0b1c95ccf469ebd83273368 (patch)
tree6dc907c8c213700a886ed7d66da6efc07a4f42ed /app-editors/dhex
parentAlso remove orphan files. (diff)
downloadgentoo-2-67af3970c0ee8756a0b1c95ccf469ebd83273368.tar.gz
gentoo-2-67af3970c0ee8756a0b1c95ccf469ebd83273368.tar.bz2
gentoo-2-67af3970c0ee8756a0b1c95ccf469ebd83273368.zip
Version bump
(Portage version: 2.1.10.56/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/dhex')
-rw-r--r--app-editors/dhex/ChangeLog9
-rw-r--r--app-editors/dhex/dhex-0.66.ebuild37
2 files changed, 44 insertions, 2 deletions
diff --git a/app-editors/dhex/ChangeLog b/app-editors/dhex/ChangeLog
index 3eada0e8b987..9c006de1fe08 100644
--- a/app-editors/dhex/ChangeLog
+++ b/app-editors/dhex/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/dhex
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/dhex/ChangeLog,v 1.5 2011/07/13 19:46:29 maekke Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/dhex/ChangeLog,v 1.6 2012/04/08 21:18:49 dilfridge Exp $
+
+*dhex-0.66 (08 Apr 2012)
+
+ 08 Apr 2012; Andreas K. Huettel <dilfridge@gentoo.org> +dhex-0.66.ebuild:
+ Version bump
13 Jul 2011; Markus Meier <maekke@gentoo.org> dhex-0.65.ebuild:
x86 stable, bug #371971
diff --git a/app-editors/dhex/dhex-0.66.ebuild b/app-editors/dhex/dhex-0.66.ebuild
new file mode 100644
index 000000000000..5f9f990ff431
--- /dev/null
+++ b/app-editors/dhex/dhex-0.66.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/dhex/dhex-0.66.ebuild,v 1.1 2012/04/08 21:18:49 dilfridge Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+MY_P=${PN}_${PV}
+
+DESCRIPTION="ncurses-based hex-editor with diff mode"
+HOMEPAGE="http://www.dettus.net/dhex/"
+SRC_URI="http://www.dettus.net/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.63-Makefile.patch"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ dobin dhex
+ dodoc README.txt
+ doman dhex.1 dhex_markers.5 dhex_searchlog.5 dhexrc.5
+}