summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-01-30 16:25:41 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-01-30 16:25:41 +0000
commitcef98237489b10fb6897a1812360d5cf3a773336 (patch)
tree751e2f16112efd120b04844583f8ba78ce6b74b9 /app-editors/dhex
parentUse.mask enchant (diff)
downloadgentoo-2-cef98237489b10fb6897a1812360d5cf3a773336.tar.gz
gentoo-2-cef98237489b10fb6897a1812360d5cf3a773336.tar.bz2
gentoo-2-cef98237489b10fb6897a1812360d5cf3a773336.zip
New application, fixes bug 121086. Thanks to Adrian Frühwirth for the original ebuild.
(Portage version: 2.1.9.35/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/dhex')
-rw-r--r--app-editors/dhex/ChangeLog11
-rw-r--r--app-editors/dhex/dhex-0.63.ebuild37
-rw-r--r--app-editors/dhex/files/dhex-0.63-Makefile.patch15
-rw-r--r--app-editors/dhex/metadata.xml8
4 files changed, 71 insertions, 0 deletions
diff --git a/app-editors/dhex/ChangeLog b/app-editors/dhex/ChangeLog
new file mode 100644
index 000000000000..4ea1371befe3
--- /dev/null
+++ b/app-editors/dhex/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-editors/dhex
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/dhex/ChangeLog,v 1.1 2011/01/30 16:25:41 dilfridge Exp $
+
+*dhex-0.63 (30 Jan 2011)
+
+ 30 Jan 2011; Andreas K. Huettel <dilfridge@gentoo.org> +dhex-0.63.ebuild,
+ +files/dhex-0.63-Makefile.patch, +metadata.xml:
+ New application, fixes bug 121086. Thanks to Adrian Frühwirth for the
+ original ebuild.
+
diff --git a/app-editors/dhex/dhex-0.63.ebuild b/app-editors/dhex/dhex-0.63.ebuild
new file mode 100644
index 000000000000..4e2751a319a1
--- /dev/null
+++ b/app-editors/dhex/dhex-0.63.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/dhex/dhex-0.63.ebuild,v 1.1 2011/01/30 16:25:41 dilfridge Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+MY_P=${PN}_${PV}
+
+DESCRIPTION="ncurses-based hex-editor with diff mode"
+HOMEPAGE="http://www.dettus.net/dhex/"
+SRC_URI="http://www.dettus.net/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-Makefile.patch"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) || die
+}
+
+src_install() {
+ dobin dhex || die
+ dodoc README.txt || die
+ doman dhex.1 dhex_markers.5 dhex_searchlog.5 dhexrc.5 || die
+}
diff --git a/app-editors/dhex/files/dhex-0.63-Makefile.patch b/app-editors/dhex/files/dhex-0.63-Makefile.patch
new file mode 100644
index 000000000000..f99c9ff1bf2d
--- /dev/null
+++ b/app-editors/dhex/files/dhex-0.63-Makefile.patch
@@ -0,0 +1,15 @@
+diff -ruN dhex_0.63.orig/Makefile dhex_0.63/Makefile
+--- dhex_0.63.orig/Makefile 2011-01-29 00:19:37.000000000 +0100
++++ dhex_0.63/Makefile 2011-01-30 17:13:51.000000000 +0100
+@@ -1,11 +1,4 @@
+-CC= gcc
+-LDFLAGS= -L/usr/lib -L/usr/local/lib -L/usr/lib/ncurses -L/usr/local/lib/ncurses
+-CPPFLAGS= -I/usr/include -I/usr/local/include -I/usr/include/ncurses -I/usr/local/include/ncurses
+-CFLAGS= -O3 -Wall -std=c99
+-#CFLAGS+= -ffunction-sections -fdata-sections
+-#LDFLAGS+= --gc-sections
+ LIBS= -lncurses
+-DESTDIR= /usr/local/
+
+ OFILES=buffers.o input.o output.o machine_type.o main.o menu.o ui.o hexcalc.o search.o gpl.o configfile.o markers.o
+
diff --git a/app-editors/dhex/metadata.xml b/app-editors/dhex/metadata.xml
new file mode 100644
index 000000000000..89ed3af2460b
--- /dev/null
+++ b/app-editors/dhex/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>dilfridge@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>