summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Portnoy <avenj@gentoo.org>2003-03-29 19:38:10 +0000
committerJon Portnoy <avenj@gentoo.org>2003-03-29 19:38:10 +0000
commit5819697e4e8eacb24a297208b3e483fef24f23ad (patch)
tree262f973a63b9aec0f3e81f941a6ff293414ca7ef /app-editors/e3/e3-2.42.ebuild
parentdded mips to keywords (diff)
downloadgentoo-2-5819697e4e8eacb24a297208b3e483fef24f23ad.tar.gz
gentoo-2-5819697e4e8eacb24a297208b3e483fef24f23ad.tar.bz2
gentoo-2-5819697e4e8eacb24a297208b3e483fef24f23ad.zip
Version bump.
Diffstat (limited to 'app-editors/e3/e3-2.42.ebuild')
-rw-r--r--app-editors/e3/e3-2.42.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-editors/e3/e3-2.42.ebuild b/app-editors/e3/e3-2.42.ebuild
new file mode 100644
index 000000000000..3375713f611a
--- /dev/null
+++ b/app-editors/e3/e3-2.42.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/e3/e3-2.42.ebuild,v 1.1 2003/03/29 19:38:10 avenj Exp $
+
+DESCRIPTION="Super Tiny Editor with wordstar, vi, and emacs key bindings"
+SRC_URI="http://www.sax.de/~adlibit/${P}.tar.gz"
+HOMEPAGE="http://www.sax.de/~adlibit"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 -ppc -sparc"
+
+DEPEND="dev-lang/nasm"
+RDEPEND="sys-apps/sed"
+
+RESTRICT="nostrip"
+
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd ${WORKDIR}
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ dodir /usr/bin
+ dobin e3
+ dosym e3 /usr/bin/e3vi
+ dosym e3 /usr/bin/e3em
+ dosym e3 /usr/bin/e3ws
+ dosym e3 /usr/bin/e3pi
+ dosym e3 /usr/bin/e3ne
+ if [ "`use build`" ]; then
+ # easier-to-remember shell scripts
+ dobin ${FILESDIR}/vi
+ # this one is more trouble than its worth --woodchip
+ # dobin ${FILESDIR}/emacs
+ dobin ${FILESDIR}/pico
+ newbin ${FILESDIR}/pico nano
+ fi
+ cp e3.man e3.1
+ doman e3.1
+}