summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-05-17 22:50:33 +0000
committerUlrich Müller <ulm@gentoo.org>2007-05-17 22:50:33 +0000
commitaef8072955c81b1bd50a18ab3eacf2205b9a5bbe (patch)
treee44f5c0dccc60aca0e2a518ad6ed4b786a94f4bc /app-editors/emacs-cvs
parentFix bug #128837, ruby-talk:183494 (diff)
downloadgentoo-2-aef8072955c81b1bd50a18ab3eacf2205b9a5bbe.tar.gz
gentoo-2-aef8072955c81b1bd50a18ab3eacf2205b9a5bbe.tar.bz2
gentoo-2-aef8072955c81b1bd50a18ab3eacf2205b9a5bbe.zip
Fix logic of toolkit USE flags.
(Portage version: 2.1.2.7)
Diffstat (limited to 'app-editors/emacs-cvs')
-rw-r--r--app-editors/emacs-cvs/ChangeLog5
-rw-r--r--app-editors/emacs-cvs/emacs-cvs-22.0.9999-r10.ebuild39
-rw-r--r--app-editors/emacs-cvs/emacs-cvs-22.1.50.ebuild39
-rw-r--r--app-editors/emacs-cvs/emacs-cvs-23.0.0-r6.ebuild39
4 files changed, 75 insertions, 47 deletions
diff --git a/app-editors/emacs-cvs/ChangeLog b/app-editors/emacs-cvs/ChangeLog
index 6fb569003f75..f213702fd3fd 100644
--- a/app-editors/emacs-cvs/ChangeLog
+++ b/app-editors/emacs-cvs/ChangeLog
@@ -1,11 +1,12 @@
# ChangeLog for app-editors/emacs-cvs
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/ChangeLog,v 1.120 2007/05/17 20:32:51 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/ChangeLog,v 1.121 2007/05/17 22:50:33 ulm Exp $
*emacs-cvs-22.0.990 (17 May 2007)
17 May 2007; Ulrich Mueller <ulm@gentoo.org> -emacs-cvs-22.0.98.ebuild,
- +emacs-cvs-22.0.990.ebuild:
+ +emacs-cvs-22.0.990.ebuild, emacs-cvs-22.0.9999-r10.ebuild,
+ emacs-cvs-22.1.50.ebuild, emacs-cvs-23.0.0-r6.ebuild:
Version bump; logic of toolkit USE flags fixed. Clean up old version.
15 May 2007; Ulrich Mueller <ulm@gentoo.org> emacs-cvs-22.0.97.ebuild,
diff --git a/app-editors/emacs-cvs/emacs-cvs-22.0.9999-r10.ebuild b/app-editors/emacs-cvs/emacs-cvs-22.0.9999-r10.ebuild
index 1766e65265e1..68bd1c871029 100644
--- a/app-editors/emacs-cvs/emacs-cvs-22.0.9999-r10.ebuild
+++ b/app-editors/emacs-cvs/emacs-cvs-22.0.9999-r10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-22.0.9999-r10.ebuild,v 1.13 2007/05/15 15:02:26 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-22.0.9999-r10.ebuild,v 1.14 2007/05/17 22:50:33 ulm Exp $
ECVS_AUTH="pserver"
ECVS_SERVER="cvs.savannah.gnu.org:/sources/emacs"
@@ -28,7 +28,8 @@ RDEPEND="sys-libs/ncurses
hesiod? ( net-dns/hesiod )
spell? ( || ( app-text/ispell app-text/aspell ) )
alsa? ( media-sound/alsa-headers )
- X? ( $X_DEPEND
+ X? (
+ $X_DEPEND
x11-misc/emacs-desktop
gif? ( media-libs/giflib )
jpeg? ( media-libs/jpeg )
@@ -36,9 +37,14 @@ RDEPEND="sys-libs/ncurses
png? ( media-libs/libpng )
xpm? ( x11-libs/libXpm )
gtk? ( =x11-libs/gtk+-2* )
- !gtk? ( Xaw3d? ( x11-libs/Xaw3d ) )
- !Xaw3d? ( motif? ( x11-libs/openmotif ) )
- !motif? ( lesstif? ( x11-libs/lesstif ) ) )"
+ !gtk? (
+ Xaw3d? ( x11-libs/Xaw3d )
+ !Xaw3d? (
+ motif? ( x11-libs/openmotif )
+ !motif? ( lesstif? ( x11-libs/lesstif ) )
+ )
+ )
+ )"
DEPEND="${RDEPEND}
gzip-el? ( app-arch/gzip )"
@@ -54,8 +60,9 @@ src_unpack() {
cvs_src_unpack
cd "${S}"
- # FULL_VERSION keeps the full version number, which is needed in order to
- # determine some path information correctly for copy/move operations later on
+ # FULL_VERSION keeps the full version number, which is needed in
+ # order to determine some path information correctly for copy/move
+ # operations later on
FULL_VERSION=$(grep 'defconst[ ]*emacs-version' lisp/version.el \
| sed -e 's/^[^"]*"\([^"]*\)".*$/\1/')
[ "${FULL_VERSION}" ] || die "Cannot determine current Emacs version"
@@ -67,9 +74,11 @@ src_unpack() {
-e "s:/usr/lib/crtend.o:$(`tc-getCC` -print-file-name=crtend.o):g" \
"${S}"/src/s/freebsd.h || die "unable to sed freebsd.h settings"
if ! use gzip-el; then
- # Emacs' build system automatically detects the gzip binary and compresses
- # el files. We don't want that so confuse it with a wrong binary name
- sed -i -e "s/ gzip/ PrEvEnTcOmPrEsSiOn/" configure.in || die "unable to sed configure.in"
+ # Emacs' build system automatically detects the gzip binary and
+ # compresses el files. We don't want that so confuse it with a
+ # wrong binary name
+ sed -i -e "s/ gzip/ PrEvEnTcOmPrEsSiOn/" configure.in \
+ || die "unable to sed configure.in"
fi
epatch "${FILESDIR}/${PN}-Xaw3d-headers.patch"
@@ -102,9 +111,9 @@ src_compile() {
fi
if use X; then
- # GTK+ is the default toolkit if USE=gtk is chosen with other possibilities.
- # Emacs upstream thinks this should be standard policy on all
- # distributions
+ # GTK+ is the default toolkit if USE=gtk is chosen with other
+ # possibilities. Emacs upstream thinks this should be standard
+ # policy on all distributions
myconf="${myconf} --with-x"
myconf="${myconf} $(use_with xpm)"
myconf="${myconf} $(use_with toolkit-scroll-bars)"
@@ -132,8 +141,8 @@ src_compile() {
myconf="${myconf} --without-x"
fi
- # $(use_with hesiod) is not possible, as "--without-hesiod" breaks the build
- # system (has been reported upstream)
+ # $(use_with hesiod) is not possible, as "--without-hesiod" breaks
+ # the build system (has been reported upstream)
use hesiod && myconf="${myconf} --with-hesiod"
econf \
diff --git a/app-editors/emacs-cvs/emacs-cvs-22.1.50.ebuild b/app-editors/emacs-cvs/emacs-cvs-22.1.50.ebuild
index e0ca41fb84b9..7e6b3aed03c3 100644
--- a/app-editors/emacs-cvs/emacs-cvs-22.1.50.ebuild
+++ b/app-editors/emacs-cvs/emacs-cvs-22.1.50.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-22.1.50.ebuild,v 1.5 2007/05/15 15:02:26 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-22.1.50.ebuild,v 1.6 2007/05/17 22:50:33 ulm Exp $
ECVS_AUTH="pserver"
ECVS_SERVER="cvs.savannah.gnu.org:/sources/emacs"
@@ -28,7 +28,8 @@ RDEPEND="sys-libs/ncurses
hesiod? ( net-dns/hesiod )
spell? ( || ( app-text/ispell app-text/aspell ) )
alsa? ( media-sound/alsa-headers )
- X? ( $X_DEPEND
+ X? (
+ $X_DEPEND
x11-misc/emacs-desktop
gif? ( media-libs/giflib )
jpeg? ( media-libs/jpeg )
@@ -36,9 +37,14 @@ RDEPEND="sys-libs/ncurses
png? ( media-libs/libpng )
xpm? ( x11-libs/libXpm )
gtk? ( =x11-libs/gtk+-2* )
- !gtk? ( Xaw3d? ( x11-libs/Xaw3d ) )
- !Xaw3d? ( motif? ( x11-libs/openmotif ) )
- !motif? ( lesstif? ( x11-libs/lesstif ) ) )"
+ !gtk? (
+ Xaw3d? ( x11-libs/Xaw3d )
+ !Xaw3d? (
+ motif? ( x11-libs/openmotif )
+ !motif? ( lesstif? ( x11-libs/lesstif ) )
+ )
+ )
+ )"
DEPEND="${RDEPEND}
gzip-el? ( app-arch/gzip )"
@@ -55,8 +61,9 @@ src_unpack() {
cvs_src_unpack
cd "${S}"
- # FULL_VERSION keeps the full version number, which is needed in order to
- # determine some path information correctly for copy/move operations later on
+ # FULL_VERSION keeps the full version number, which is needed in
+ # order to determine some path information correctly for copy/move
+ # operations later on
FULL_VERSION=$(grep 'defconst[ ]*emacs-version' lisp/version.el \
| sed -e 's/^[^"]*"\([^"]*\)".*$/\1/')
[ "${FULL_VERSION}" ] || die "Cannot determine current Emacs version"
@@ -68,9 +75,11 @@ src_unpack() {
-e "s:/usr/lib/crtend.o:$(`tc-getCC` -print-file-name=crtend.o):g" \
"${S}"/src/s/freebsd.h || die "unable to sed freebsd.h settings"
if ! use gzip-el; then
- # Emacs' build system automatically detects the gzip binary and compresses
- # el files. We don't want that so confuse it with a wrong binary name
- sed -i -e "s/ gzip/ PrEvEnTcOmPrEsSiOn/" configure.in || die "unable to sed configure.in"
+ # Emacs' build system automatically detects the gzip binary and
+ # compresses el files. We don't want that so confuse it with a
+ # wrong binary name
+ sed -i -e "s/ gzip/ PrEvEnTcOmPrEsSiOn/" configure.in \
+ || die "unable to sed configure.in"
fi
epatch "${FILESDIR}/${PN}-Xaw3d-headers.patch"
@@ -103,9 +112,9 @@ src_compile() {
fi
if use X; then
- # GTK+ is the default toolkit if USE=gtk is chosen with other possibilities.
- # Emacs upstream thinks this should be standard policy on all
- # distributions
+ # GTK+ is the default toolkit if USE=gtk is chosen with other
+ # possibilities. Emacs upstream thinks this should be standard
+ # policy on all distributions
myconf="${myconf} --with-x"
myconf="${myconf} $(use_with xpm)"
myconf="${myconf} $(use_with toolkit-scroll-bars)"
@@ -133,8 +142,8 @@ src_compile() {
myconf="${myconf} --without-x"
fi
- # $(use_with hesiod) is not possible, as "--without-hesiod" breaks the build
- # system (has been reported upstream)
+ # $(use_with hesiod) is not possible, as "--without-hesiod" breaks
+ # the build system (has been reported upstream)
use hesiod && myconf="${myconf} --with-hesiod"
econf \
diff --git a/app-editors/emacs-cvs/emacs-cvs-23.0.0-r6.ebuild b/app-editors/emacs-cvs/emacs-cvs-23.0.0-r6.ebuild
index 7b855b81ff42..2d17086fa25c 100644
--- a/app-editors/emacs-cvs/emacs-cvs-23.0.0-r6.ebuild
+++ b/app-editors/emacs-cvs/emacs-cvs-23.0.0-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-23.0.0-r6.ebuild,v 1.10 2007/05/15 15:02:26 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-23.0.0-r6.ebuild,v 1.11 2007/05/17 22:50:33 ulm Exp $
ECVS_AUTH="pserver"
ECVS_SERVER="cvs.savannah.gnu.org:/sources/emacs"
@@ -28,7 +28,8 @@ RDEPEND="sys-libs/ncurses
hesiod? ( net-dns/hesiod )
spell? ( || ( app-text/ispell app-text/aspell ) )
alsa? ( media-sound/alsa-headers )
- X? ( $X_DEPEND
+ X? (
+ $X_DEPEND
x11-misc/emacs-desktop
gif? ( media-libs/giflib )
jpeg? ( media-libs/jpeg )
@@ -37,9 +38,14 @@ RDEPEND="sys-libs/ncurses
xpm? ( x11-libs/libXpm )
xft? ( media-libs/fontconfig virtual/xft >=dev-libs/libotf-0.9.4 )
gtk? ( =x11-libs/gtk+-2* )
- !gtk? ( Xaw3d? ( x11-libs/Xaw3d ) )
- !Xaw3d? ( motif? ( x11-libs/openmotif ) )
- !motif? ( lesstif? ( x11-libs/lesstif ) ) )"
+ !gtk? (
+ Xaw3d? ( x11-libs/Xaw3d )
+ !Xaw3d? (
+ motif? ( x11-libs/openmotif )
+ !motif? ( lesstif? ( x11-libs/lesstif ) )
+ )
+ )
+ )"
DEPEND="${RDEPEND}
gzip-el? ( app-arch/gzip )"
@@ -55,8 +61,9 @@ src_unpack() {
cvs_src_unpack
cd "${S}"
- # FULL_VERSION keeps the full version number, which is needed in order to
- # determine some path information correctly for copy/move operations later on
+ # FULL_VERSION keeps the full version number, which is needed in
+ # order to determine some path information correctly for copy/move
+ # operations later on
FULL_VERSION=$(grep 'defconst[ ]*emacs-version' lisp/version.el \
| sed -e 's/^[^"]*"\([^"]*\)".*$/\1/')
[ "${FULL_VERSION}" ] || die "Cannot determine current Emacs version"
@@ -68,9 +75,11 @@ src_unpack() {
-e "s:/usr/lib/crtend.o:$(`tc-getCC` -print-file-name=crtend.o):g" \
"${S}"/src/s/freebsd.h || die "unable to sed freebsd.h settings"
if ! use gzip-el; then
- # Emacs' build system automatically detects the gzip binary and compresses
- # el files. We don't want that so confuse it with a wrong binary name
- sed -i -e "s/ gzip/ PrEvEnTcOmPrEsSiOn/" configure.in || die "unable to sed configure.in"
+ # Emacs' build system automatically detects the gzip binary and
+ # compresses el files. We don't want that so confuse it with a
+ # wrong binary name
+ sed -i -e "s/ gzip/ PrEvEnTcOmPrEsSiOn/" configure.in \
+ || die "unable to sed configure.in"
fi
epatch "${FILESDIR}/${PN}-Xaw3d-headers.patch"
@@ -103,9 +112,9 @@ src_compile() {
fi
if use X; then
- # GTK+ is the default toolkit if USE=gtk is chosen with other possibilities.
- # Emacs upstream thinks this should be standard policy on all
- # distributions
+ # GTK+ is the default toolkit if USE=gtk is chosen with other
+ # possibilities. Emacs upstream thinks this should be standard
+ # policy on all distributions
myconf="${myconf} --with-x"
myconf="${myconf} $(use_with xpm)"
myconf="${myconf} $(use_with toolkit-scroll-bars)"
@@ -136,8 +145,8 @@ src_compile() {
myconf="${myconf} --without-x"
fi
- # $(use_with hesiod) is not possible, as "--without-hesiod" breaks the build
- # system (has been reported upstream)
+ # $(use_with hesiod) is not possible, as "--without-hesiod" breaks
+ # the build system (has been reported upstream)
use hesiod && myconf="${myconf} --with-hesiod"
econf \