summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2011-07-01 18:39:13 +0000
committerUlrich Müller <ulm@gentoo.org>2011-07-01 18:39:13 +0000
commitdc0005bfd31ca7eabdd987cba77e67b83e211b58 (patch)
treeb39f16a3a0a68db960a71775f9275fd63517a76f /app-editors/emacs-vcs
parent[www-plugins/google-talkplugin] Version bump (bug #373657) (diff)
downloadgentoo-2-dc0005bfd31ca7eabdd987cba77e67b83e211b58.tar.gz
gentoo-2-dc0005bfd31ca7eabdd987cba77e67b83e211b58.tar.bz2
gentoo-2-dc0005bfd31ca7eabdd987cba77e67b83e211b58.zip
Support gtk3 toolkit. New USE flags gsettings, gtk3, and wide-int.
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/emacs-vcs')
-rw-r--r--app-editors/emacs-vcs/ChangeLog6
-rw-r--r--app-editors/emacs-vcs/emacs-vcs-24.0.9999-r1.ebuild41
-rw-r--r--app-editors/emacs-vcs/metadata.xml5
3 files changed, 39 insertions, 13 deletions
diff --git a/app-editors/emacs-vcs/ChangeLog b/app-editors/emacs-vcs/ChangeLog
index 7c23fa4bc5a6..9e2957ab0d1a 100644
--- a/app-editors/emacs-vcs/ChangeLog
+++ b/app-editors/emacs-vcs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/emacs-vcs
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-vcs/ChangeLog,v 1.55 2011/03/19 09:34:59 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-vcs/ChangeLog,v 1.56 2011/07/01 18:39:13 ulm Exp $
+
+ 01 Jul 2011; Ulrich Mueller <ulm@gentoo.org> emacs-vcs-24.0.9999-r1.ebuild,
+ metadata.xml:
+ Support gtk3 toolkit. New USE flags gsettings, gtk3, and wide-int.
19 Mar 2011; Ulrich Mueller <ulm@gentoo.org> emacs-vcs-23.3.9999.ebuild,
emacs-vcs-24.0.9999-r1.ebuild:
diff --git a/app-editors/emacs-vcs/emacs-vcs-24.0.9999-r1.ebuild b/app-editors/emacs-vcs/emacs-vcs-24.0.9999-r1.ebuild
index 3f6433105706..6388351dcd57 100644
--- a/app-editors/emacs-vcs/emacs-vcs-24.0.9999-r1.ebuild
+++ b/app-editors/emacs-vcs/emacs-vcs-24.0.9999-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-vcs/emacs-vcs-24.0.9999-r1.ebuild,v 1.9 2011/03/19 09:34:59 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-vcs/emacs-vcs-24.0.9999-r1.ebuild,v 1.10 2011/07/01 18:39:13 ulm Exp $
EAPI=4
@@ -30,7 +30,7 @@ HOMEPAGE="http://www.gnu.org/software/emacs/"
LICENSE="GPL-3 FDL-1.3 BSD as-is MIT W3C unicode"
SLOT="24"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="alsa dbus gconf gif gnutls gpm gtk gzip-el hesiod imagemagick jpeg kerberos libxml2 m17n-lib motif png selinux sound source svg tiff toolkit-scroll-bars X Xaw3d xft +xpm"
+IUSE="alsa dbus gconf gif gnutls gpm gsettings gtk gtk3 gzip-el hesiod imagemagick jpeg kerberos libxml2 m17n-lib motif png selinux sound source svg tiff toolkit-scroll-bars wide-int X Xaw3d xft +xpm"
RESTRICT="strip"
RDEPEND="sys-libs/ncurses
@@ -47,7 +47,8 @@ RDEPEND="sys-libs/ncurses
x11-libs/libXmu
x11-libs/libXt
x11-misc/xbitmaps
- gconf? ( >=gnome-base/gconf-2.26.2 )
+ gsettings? ( >=dev-libs/glib-2.28.6 )
+ !gsettings? ( gconf? ( >=gnome-base/gconf-2.26.2 ) )
libxml2? ( >=dev-libs/libxml2-2.2.0 )
gif? ( media-libs/giflib )
jpeg? ( virtual/jpeg )
@@ -65,7 +66,10 @@ RDEPEND="sys-libs/ncurses
>=dev-libs/m17n-lib-1.5.1
)
)
- gtk? ( x11-libs/gtk+:2 )
+ gtk? (
+ gtk3? ( x11-libs/gtk+:3 )
+ !gtk3? ( x11-libs/gtk+:2 )
+ )
!gtk? (
Xaw3d? ( x11-libs/Xaw3d )
!Xaw3d? ( motif? ( >=x11-libs/openmotif-2.3:0 ) )
@@ -147,28 +151,41 @@ src_configure() {
if use X; then
myconf="${myconf} --with-x"
- myconf="${myconf} $(use_with gconf) $(use_with libxml2 xml2)"
+ myconf="${myconf} $(use_with libxml2 xml2)"
myconf="${myconf} $(use_with toolkit-scroll-bars)"
+ myconf="${myconf} $(use_with wide-int)"
myconf="${myconf} $(use_with gif) $(use_with jpeg)"
myconf="${myconf} $(use_with png) $(use_with svg rsvg)"
myconf="${myconf} $(use_with tiff) $(use_with xpm)"
- myconf="${myconf} $(use_with imagemagick) $(use_with xft)"
+ myconf="${myconf} $(use_with imagemagick)"
+
+ if use gsettings; then
+ myconf="${myconf} --with-gsettings --without-gconf"
+ use gconf && ewarn \
+ "USE flag \"gconf\" has no effect if \"gsettings\" is also set."
+ else
+ myconf="${myconf} --without-gsettings $(use_with gconf)"
+ fi
if use xft; then
+ myconf="${myconf} --with-xft"
myconf="${myconf} $(use_with m17n-lib libotf)"
myconf="${myconf} $(use_with m17n-lib m17n-flt)"
else
+ myconf="${myconf} --without-xft"
myconf="${myconf} --without-libotf --without-m17n-flt"
use m17n-lib && ewarn \
- "USE flag \"m17n-lib\" has no effect because xft is not set."
+ "USE flag \"m17n-lib\" has no effect if \"xft\" is not set."
fi
- # GTK+ is the default toolkit if USE=gtk is chosen with other
- # possibilities. Emacs upstream thinks this should be standard
- # policy on all distributions
if use gtk; then
- einfo "Configuring to build with GIMP Toolkit (GTK+)"
- myconf="${myconf} --with-x-toolkit=gtk"
+ if use gtk3; then
+ einfo "Configuring to build with GIMP Toolkit (GTK+ 3)"
+ myconf="${myconf} --with-x-toolkit=gtk3"
+ else
+ einfo "Configuring to build with GIMP Toolkit (GTK+ 2)"
+ myconf="${myconf} --with-x-toolkit=gtk"
+ fi
elif use Xaw3d; then
einfo "Configuring to build with Xaw3d (Athena/Lucid) toolkit"
myconf="${myconf} --with-x-toolkit=athena"
diff --git a/app-editors/emacs-vcs/metadata.xml b/app-editors/emacs-vcs/metadata.xml
index 161808dc2f32..060eda86a6e6 100644
--- a/app-editors/emacs-vcs/metadata.xml
+++ b/app-editors/emacs-vcs/metadata.xml
@@ -22,6 +22,10 @@
<use>
<flag name='gconf'>Use <pkg>gnome-base/gconf</pkg> to read the system
font name</flag>
+ <flag name='gsettings'>Use gsettings (<pkg>dev-libs/glib</pkg>) to read the
+ system font name</flag>
+ <flag name='gtk3'>Link against version 3 of the GIMP Toolkit instead of
+ version 2 (<pkg>x11-libs/gtk+</pkg>)</flag>
<flag name='gzip-el'>Compress bundled Emacs Lisp source</flag>
<flag name='hesiod'>Enable support for <pkg>net-dns/hesiod</pkg></flag>
<flag name='imagemagick'>Use <pkg>media-gfx/imagemagick</pkg> for image
@@ -30,5 +34,6 @@
of the internal Lisp implementations</flag>
<flag name='toolkit-scroll-bars'>Use the selected toolkit's scrollbars in
preference to Emacs' own scrollbars</flag>
+ <flag name='wide-int'>Prefer wide Emacs integers (typically 62-bit)</flag>
</use>
</pkgmetadata>