summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-02-04 23:18:00 +0000
committerAchim Gottinger <achim@gentoo.org>2001-02-04 23:18:00 +0000
commit4f9272f8beb6df1b2be2057057550773a12dc824 (patch)
treef408c7e2c67c7b5609f529186c60627d78ea0bfa /app-editors/emacs-x11/emacs-x11-20.7.ebuild
parent*** empty log message *** (diff)
downloadgentoo-2-4f9272f8beb6df1b2be2057057550773a12dc824.tar.gz
gentoo-2-4f9272f8beb6df1b2be2057057550773a12dc824.tar.bz2
gentoo-2-4f9272f8beb6df1b2be2057057550773a12dc824.zip
*** empty log message ***
Diffstat (limited to 'app-editors/emacs-x11/emacs-x11-20.7.ebuild')
-rw-r--r--app-editors/emacs-x11/emacs-x11-20.7.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-editors/emacs-x11/emacs-x11-20.7.ebuild b/app-editors/emacs-x11/emacs-x11-20.7.ebuild
new file mode 100644
index 000000000000..3e59ca7eded5
--- /dev/null
+++ b/app-editors/emacs-x11/emacs-x11-20.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Peter Gavin <pbg1854@garnet.acns.fsu.edu>
+
+A=emacs-20.7.tar.gz
+S=${WORKDIR}/emacs-20.7
+DESCRIPTION="An incredibly powerful, extensible text editor (X11 version)"
+SRC_URI="ftp://ftp.freesoftware.com/pub/gnu/emacs/emacs-20.7.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/emacs"
+RDEPEND=">=sys-libs/ncurses-4.0
+ >=sys-libs/glibc-2.0
+ >=x11-base/xfree-4.0
+ !app-editors/emacs-nogui"
+
+DEPEND=">=sys-libs/ncurses-4.0
+ >=sys-libs/glibc-2.0
+ >=x11-base/xfree-4.0
+ >=sys-devel/gettext-0.10.35"
+
+src_compile() {
+ cd ${S}
+ try ./configure --prefix=/usr/X11R6 --libexecdir=/usr/X11R6/lib --host=${CHOST} --with-x
+ try make
+}
+
+src_install () {
+ cd ${S}
+ try make prefix=${D}/usr/X11R6 libexecdir=${D}/usr/X11R6/lib install
+ dodoc BUGS ChangeLog README
+ gzip -9 ${D}/usr/X11R6/info/*
+}
+