summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2007-12-07 11:30:48 +0000
committerChristian Faulhammer <opfer@gentoo.org>2007-12-07 11:30:48 +0000
commit089481c80eade6f69ab92c761f950f8b0f5e3a77 (patch)
treeea8238fb4f1eae778cd45d289ad5538923039a84 /app-editors/emacs
parent Version bump, also adding a bunch of new use flags, restructuring the ebuild... (diff)
downloadgentoo-2-089481c80eade6f69ab92c761f950f8b0f5e3a77.tar.gz
gentoo-2-089481c80eade6f69ab92c761f950f8b0f5e3a77.tar.bz2
gentoo-2-089481c80eade6f69ab92c761f950f8b0f5e3a77.zip
clean up
(Portage version: 2.1.3.19)
Diffstat (limited to 'app-editors/emacs')
-rw-r--r--app-editors/emacs/ChangeLog6
-rw-r--r--app-editors/emacs/emacs-21.4-r8.ebuild211
-rw-r--r--app-editors/emacs/files/digest-emacs-21.4-r812
3 files changed, 5 insertions, 224 deletions
diff --git a/app-editors/emacs/ChangeLog b/app-editors/emacs/ChangeLog
index 24880e1e6dae..b9897ab2df61 100644
--- a/app-editors/emacs/ChangeLog
+++ b/app-editors/emacs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/emacs
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.220 2007/12/02 20:00:52 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.221 2007/12/07 11:30:47 opfer Exp $
+
+ 07 Dec 2007; Christian Faulhammer <opfer@gentoo.org>
+ -emacs-21.4-r8.ebuild:
+ clean up
02 Dec 2007; Ulrich Mueller <ulm@gentoo.org> emacs-18.59-r4.ebuild,
emacs-21.4-r12.ebuild, emacs-21.4-r14.ebuild, emacs-22.1-r3.ebuild:
diff --git a/app-editors/emacs/emacs-21.4-r8.ebuild b/app-editors/emacs/emacs-21.4-r8.ebuild
deleted file mode 100644
index dd30ff9f3eb3..000000000000
--- a/app-editors/emacs/emacs-21.4-r8.ebuild
+++ /dev/null
@@ -1,211 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.4-r8.ebuild,v 1.8 2007/10/14 08:34:43 ulm Exp $
-
-inherit flag-o-matic eutils alternatives toolchain-funcs
-
-DESCRIPTION="An incredibly powerful, extensible text editor"
-HOMEPAGE="http://www.gnu.org/software/emacs"
-SRC_URI="mirror://gnu/emacs/${P}a.tar.gz
- mirror://gentoo/emacs-21-patches.tar.bz2
- mirror://gentoo/emacs-21-files.tar.bz2
- leim? ( mirror://gnu/emacs/leim-${PV}.tar.gz )"
-
-LICENSE="GPL-2 BSD"
-SLOT="21"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="X Xaw3d leim lesstif motif nls sendmail"
-
-RDEPEND="sys-libs/ncurses
- X? ( x11-libs/libXext
- x11-libs/libICE
- x11-libs/libSM
- x11-libs/libXmu
- x11-libs/libXpm
- || ( media-fonts/font-adobe-100dpi
- media-fonts/font-adobe-75dpi )
- >=media-libs/giflib-4.1.0.1b
- >=media-libs/jpeg-6b-r2
- >=media-libs/tiff-3.5.5-r3
- >=media-libs/libpng-1.2.1
- !arm? (
- Xaw3d? ( x11-libs/Xaw3d )
- !Xaw3d? ( x11-libs/libXaw )
- motif? (
- lesstif? ( x11-libs/lesstif )
- !lesstif? ( >=x11-libs/openmotif-2.1.30 ) )
- )
- )
- nls? ( sys-devel/gettext )
- sendmail? ( virtual/mta )"
-
-DEPEND="${RDEPEND}
- >=sys-devel/autoconf-2.58
- X? ( x11-misc/xbitmaps )"
-
-DFILE=emacs-${SLOT}.desktop
-
-src_unpack() {
-
- unpack ${A}
-
- cd "${S}"
- epatch "${WORKDIR}/emacs-21.3-xorg.patch"
- epatch "${WORKDIR}/emacs-21.3-amd64.patch"
- epatch "${WORKDIR}/emacs-21.3-hppa.patch"
- epatch "${WORKDIR}/emacs-21.2-sh.patch"
- epatch "${WORKDIR}/emacs-21.4-libungif-gif-gentoo.patch"
-
- use ppc64 && epatch "${WORKDIR}/emacs-21.3-ppc64.patch"
-
- epatch "${WORKDIR}/emacs-21.4-autosave-tmp.patch"
- epatch "${WORKDIR}/emacs-21.4-blessmail-build.patch"
-
- # This will need to be updated for X-Compilation
- sed -i -e "s:/usr/lib/\([^ ]*\).o:/usr/$(get_libdir)/\1.o:g" \
- "${S}/src/s/gnu-linux.h"
-}
-
-src_compile() {
- export SANDBOX_ON=0
-
- # -fstack-protector gets internal compiler error at xterm.c (bug 33265)
- filter-flags -fstack-protector
-
- # emacs doesn't handle LDFLAGS properly (bug #77430 and bug #65002)
- unset LDFLAGS
-
- # ever since GCC 3.2
- replace-flags -O[3-9] -O2
-
- # this fixes bug 152006
- use ppc64 && append-flags -mno-fp-in-toc -mno-sum-in-toc
-
- # -march is known to cause signal 6 on some environment
- filter-flags "-march=*"
-
- export WANT_AUTOCONF=2.1
- autoconf
-
- local myconf
- use nls || myconf="${myconf} --disable-nls"
- if use X ; then
- if use motif && use lesstif; then
- append-ldflags -L/usr/X11R6/lib/lesstif -R/usr/X11R6/lib/lesstif
- export CPPFLAGS="${CPPFLAGS} -I/usr/X11R6/include/lesstif"
- fi
- myconf="${myconf}
- --with-x
- --with-xpm
- --with-jpeg
- --with-tiff
- --with-gif
- --with-png"
- if use Xaw3d ; then
- myconf="${myconf} --with-x-toolkit=athena"
- elif use motif ; then
- myconf="${myconf} --with-x-toolkit=motif"
- else
- # do not build emacs with any toolkit, bug 35300
- myconf="${myconf} --with-x-toolkit=no"
- fi
- else
- myconf="${myconf} --without-x"
- fi
- econf ${myconf} || die
- emake CC="$(tc-getCC)" || die
-
- einfo "Recompiling patched lisp files..."
- (cd lisp; emake recompile) || die
- emake CC="$(tc-getCC)" || die
-}
-
-src_install() {
- einstall || die
- for i in "${D}"/usr/bin/* ; do
- mv ${i} ${i}.emacs-${SLOT} || die "mv ${i} failed"
- done
- mv "${D}"/usr/bin/emacs{-${PV},}.emacs-${SLOT} || die "mv emacs failed"
- dohard /usr/bin/emacs.emacs-${SLOT} /usr/bin/emacs-${SLOT}
-
- einfo "Fixing info documentation..."
- mkdir "${T}/emacs-${SLOT}"
- mv "${D}/usr/share/info/dir" "${T}"
- for i in "${D}"/usr/share/info/*
- do
- mv ${i} "${T}"/emacs-${SLOT}/${i##*/}.info
- done
- mv "${T}/emacs-${SLOT}" "${D}/usr/share/info"
- mv "${T}/dir" "${D}/usr/share/info/emacs-${SLOT}"
-
- newenvd "${WORKDIR}/60emacs-${SLOT}.envd" "60emacs-${SLOT}"
-
- einfo "Fixing manpages..."
- for m in "${D}"/usr/share/man/man1/* ; do
- mv ${m} ${m/.1/.emacs-${SLOT}.1} || die "mv ${m} failed"
- done
-
- # avoid collision between slots
- rm "${D}"/usr/share/emacs/site-lisp/subdirs.el
-
- einfo "Fixing permissions..."
- find "${D}" -perm 664 |xargs chmod -f 644 2>/dev/null
- find "${D}" -type d |xargs chmod -f 755 2>/dev/null
-
- keepdir /usr/share/emacs/${PV}/leim
- keepdir /usr/share/emacs/site-lisp
-
- dodoc BUGS ChangeLog README
-
- insinto /usr/share/applications
- doins "${WORKDIR}/${DFILE}"
-}
-
-update-alternatives() {
- # extract the suffix of the manpages to determine the correct compression program
- local suffix=$(echo /usr/share/man/man1/emacs.emacs-*.1*|sed 's/.*\.1//')
-
- # this creates symlinks for binaries and man pages, so the correct ones in a slotted
- # environment can be accessed
- for i in emacs emacsclient etags ctags b2m ebrowse \
- rcs-checkin grep-changelog ; do
- alternatives_auto_makesym "/usr/bin/$i" "/usr/bin/${i}.emacs-*"
- done
-
- for j in emacs etags ctags gfdl
- do
- alternatives_auto_makesym "/usr/share/man/man1/$j.1${suffix}" "/usr/share/man/man1/$j.emacs-*"
- done
-}
-
-pkg_postinst() {
- test -f "${ROOT}"/usr/share/emacs/site-lisp/subdirs.el ||
- cp "${ROOT}"/usr/share/emacs{/${PV},}/site-lisp/subdirs.el
-
- update-alternatives
-
- if ! use sendmail; then
- while read line; do einfo "${line}"; done<<'EOF'
-
-You disabled sendmail support for Emacs. If you later install a MTA
-then you will need to recompile Emacs. See Bug #11104.
-
-EOF
- fi
- if use X; then
- while read line; do einfo "${line}"; done<<'EOF'
-
-You need to install some fonts for Emacs. Under monolithic
-XFree86/Xorg you typically had such fonts installed by default. With
-modular Xorg, you will have to perform this step yourself.
-
-Installing media-fonts/font-adobe-{75,100}dpi would satisfy basic
-Emacs requirements under X11.
-
-EOF
- fi
-}
-
-pkg_postrm() {
- update-alternatives
-}
diff --git a/app-editors/emacs/files/digest-emacs-21.4-r8 b/app-editors/emacs/files/digest-emacs-21.4-r8
deleted file mode 100644
index 90b82ba60dc1..000000000000
--- a/app-editors/emacs/files/digest-emacs-21.4-r8
+++ /dev/null
@@ -1,12 +0,0 @@
-MD5 a72cc753e258ddbb9bd952016121a8bf emacs-21-files.tar.bz2 900
-RMD160 71b4a7b6d6b2f47a087fdb54381513b82fb97411 emacs-21-files.tar.bz2 900
-SHA256 3d7c5b2ca8b11d3cd2dd9ea22b90867471de34552e4d1bae11206d18031f6ab2 emacs-21-files.tar.bz2 900
-MD5 c3394d805e6ed999c4ac7d197091f1e3 emacs-21-patches.tar.bz2 8891
-RMD160 ca0a44cc0d6e81fb245eb4f6069dd49550a9c55f emacs-21-patches.tar.bz2 8891
-SHA256 456af3ed5bcfa99af3fd67c281e391ca1b67599aed0cfd470adca8b34240d914 emacs-21-patches.tar.bz2 8891
-MD5 8f9d97cbd126121bd5d97e5e31168a87 emacs-21.4a.tar.gz 20403483
-RMD160 c312e739935b56d08783bbfe97992297a363cb8a emacs-21.4a.tar.gz 20403483
-SHA256 1d50ddae117c48d689a3d772e390569edccfdc22168be0112d2093bd2d7c3216 emacs-21.4a.tar.gz 20403483
-MD5 32938cb5a7505d995a1e835639d19707 leim-21.4.tar.gz 3291433
-RMD160 89e1108bfe06425a0d6b4d941f9c297551bafcca leim-21.4.tar.gz 3291433
-SHA256 db24946985dd644bfed18815d6e991dad27f8ab1fd5823dd6dc4eb8dcd04333b leim-21.4.tar.gz 3291433