summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2012-12-05 09:09:36 +0000
committerMichael Palimaka <kensington@gentoo.org>2012-12-05 09:09:36 +0000
commitd093538bb4e662d70271ac1a52698b55c36357cc (patch)
tree0c82e030a32494fdef4a0bc46b3d1da9c54065de /app-editors/focuswriter
parentInstall pam module and library under /lib, not /usr/lib (bug #445394, thanks ... (diff)
downloadgentoo-2-d093538bb4e662d70271ac1a52698b55c36357cc.tar.gz
gentoo-2-d093538bb4e662d70271ac1a52698b55c36357cc.tar.bz2
gentoo-2-d093538bb4e662d70271ac1a52698b55c36357cc.zip
Version bump, remove old.
(Portage version: 2.1.11.33/cvs/Linux x86_64, signed Manifest commit with key 675D0D2C)
Diffstat (limited to 'app-editors/focuswriter')
-rw-r--r--app-editors/focuswriter/ChangeLog8
-rw-r--r--app-editors/focuswriter/focuswriter-1.3.5.2.ebuild32
-rw-r--r--app-editors/focuswriter/focuswriter-1.4.1.ebuild44
3 files changed, 51 insertions, 33 deletions
diff --git a/app-editors/focuswriter/ChangeLog b/app-editors/focuswriter/ChangeLog
index ad258bca0433..25e603a05122 100644
--- a/app-editors/focuswriter/ChangeLog
+++ b/app-editors/focuswriter/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/focuswriter
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/focuswriter/ChangeLog,v 1.10 2012/11/20 20:47:31 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/focuswriter/ChangeLog,v 1.11 2012/12/05 09:09:36 kensington Exp $
+
+*focuswriter-1.4.1 (05 Dec 2012)
+
+ 05 Dec 2012; Michael Palimaka <kensington@gentoo.org>
+ +focuswriter-1.4.1.ebuild, -focuswriter-1.3.5.2.ebuild:
+ Version bump, remove old.
20 Nov 2012; Agostino Sarubbo <ago@gentoo.org> focuswriter-1.4.0.ebuild:
Stable for x86, wrt bug #442164
diff --git a/app-editors/focuswriter/focuswriter-1.3.5.2.ebuild b/app-editors/focuswriter/focuswriter-1.3.5.2.ebuild
deleted file mode 100644
index 3e8af0bf83ba..000000000000
--- a/app-editors/focuswriter/focuswriter-1.3.5.2.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/focuswriter/focuswriter-1.3.5.2.ebuild,v 1.3 2012/05/21 12:26:35 phajdan.jr Exp $
-
-EAPI=4
-
-#does nothing useful, LANGS="cs de el en es_MX es fi fr hu it nl pl pt_BR pt ru sv uk"
-inherit qt4-r2
-
-DESCRIPTION="A fullscreen and distraction-free word processor"
-HOMEPAGE="http://gottcode.org/focuswriter/"
-SRC_URI="http://gottcode.org/${PN}/${P}-src.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="debug"
-
-DEPEND="
- app-text/hunspell
- dev-libs/libzip
- x11-libs/qt-gui:4
- media-libs/sdl-mixer[wav]
- "
-RDEPEND="${DEPEND}"
-
-DOCS=( ChangeLog README )
-
-src_prepare() {
- sed -i -e '/PREFIX/s:/usr/local:/usr:' ${PN}.pro || die
- qt4-r2_src_prepare
-}
diff --git a/app-editors/focuswriter/focuswriter-1.4.1.ebuild b/app-editors/focuswriter/focuswriter-1.4.1.ebuild
new file mode 100644
index 000000000000..1f53222aab8b
--- /dev/null
+++ b/app-editors/focuswriter/focuswriter-1.4.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/focuswriter/focuswriter-1.4.1.ebuild,v 1.1 2012/12/05 09:09:36 kensington Exp $
+
+EAPI=5
+PLOCALES="ca cs da de el en es es_MX fi fr hu it ja nl pl pt_BR pt ru sk sv uk zh_CN"
+PLOCALE_BACKUP="en"
+inherit qt4-r2 l10n
+
+DESCRIPTION="A fullscreen and distraction-free word processor"
+HOMEPAGE="http://gottcode.org/focuswriter/"
+SRC_URI="http://gottcode.org/${PN}/${P}-src.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="
+ app-text/enchant
+ dev-libs/libzip
+ media-libs/sdl-mixer[wav]
+ sys-libs/zlib
+ x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+DOCS=( ChangeLog CREDITS README )
+
+src_prepare() {
+ l10n_for_each_disabled_locale_do rm_loc
+}
+
+src_configure() {
+ eqmake4 PREFIX="${EPREFIX}/usr"
+}
+
+rm_loc() {
+ sed -e "s|translations/${PN}_${1}.ts||" -i ${PN}.pro || die 'sed failed'
+ rm translations/${PN}_${1}.{ts,qm} || die "removing ${1} locale failed"
+}