summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-05-31 22:12:04 +0000
committerMike Frysinger <vapier@gentoo.org>2004-05-31 22:12:04 +0000
commit85bf0780b54b0388919f656d5d2475ac8dfbfc7d (patch)
tree5462eacfdcae74754e7ca88e02f792ab14b385f0 /app-editors/fte
parentversion bump, first gpg-signed package ;) (Manifest recommit) (diff)
downloadgentoo-2-85bf0780b54b0388919f656d5d2475ac8dfbfc7d.tar.gz
gentoo-2-85bf0780b54b0388919f656d5d2475ac8dfbfc7d.tar.bz2
gentoo-2-85bf0780b54b0388919f656d5d2475ac8dfbfc7d.zip
dont install uselss COPYING file and fix other stuff while i'm at it
Diffstat (limited to 'app-editors/fte')
-rw-r--r--app-editors/fte/fte-20010819-r2.ebuild38
-rw-r--r--app-editors/fte/fte-20010819-r3.ebuild43
-rw-r--r--app-editors/fte/fte-20020324-r1.ebuild38
-rw-r--r--app-editors/fte/fte-20020324-r2.ebuild38
-rw-r--r--app-editors/fte/fte-20020324.ebuild38
5 files changed, 77 insertions, 118 deletions
diff --git a/app-editors/fte/fte-20010819-r2.ebuild b/app-editors/fte/fte-20010819-r2.ebuild
index 8733a95d093d..60a5a9afedfe 100644
--- a/app-editors/fte/fte-20010819-r2.ebuild
+++ b/app-editors/fte/fte-20010819-r2.ebuild
@@ -1,44 +1,33 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/fte/fte-20010819-r2.ebuild,v 1.16 2004/03/13 22:29:59 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/fte/fte-20010819-r2.ebuild,v 1.17 2004/05/31 22:12:03 vapier Exp $
inherit eutils
-IUSE="gpm slang X"
-
DESCRIPTION="Lightweight text-mode editor"
HOMEPAGE="http://fte.sourceforge.net"
SRC_URI="mirror://sourceforge/fte/fte-20010819-src.zip
mirror://sourceforge/fte/fte-20010819-common.zip"
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86 sparc "
+SLOT="0"
+KEYWORDS="x86 sparc"
+IUSE="gpm slang X"
RDEPEND=">=sys-libs/ncurses-5.2
gpm? ( >=sys-libs/gpm-1.20 )"
-
DEPEND="app-arch/unzip
slang? ( sys-libs/slang )
${RDEPEND}"
-TARGETS=""
-
-if [ "`use slang`" ] ; then
- TARGETS="$TARGETS sfte"
-fi
-
-if [ "`use X`" ] ; then
- TARGETS="$TARGETS xfte"
-fi
-
-if [ "`use gpm`" ] ; then
- TARGETS="$TARGETS vfte"
-fi
+set_targets() {
+ export TARGETS=""
+ use slang && TARGETS="$TARGETS sfte"
+ use X && TARGETS="$TARGETS xfte"
+ use gpm && TARGETS="$TARGETS vfte"
+}
src_unpack() {
-
- cd ${WORKDIR}
unpack fte-20010819-src.zip
unpack fte-20010819-common.zip
@@ -49,6 +38,7 @@ src_unpack() {
cp src/fte-unix.mak src/fte-unix.mak.orig
+ set_targets
sed \
-e "s:@targets@:${TARGETS}:" \
-e "s:@cflags@:${CFLAGS}:" \
@@ -62,17 +52,18 @@ src_compile() {
../src/cfte main.fte ../src/system.fterc
}
-src_install () {
+src_install() {
local files
into /usr
+ set_targets
files="${TARGETS} cfte compkeys"
for i in ${files} ; do
dobin src/$i ;
done
- dodoc Artistic CHANGES BUGS COPYING HISTORY README TODO
+ dodoc Artistic CHANGES BUGS HISTORY README TODO
dodir etc/fte
cp src/system.fterc ${D}/etc/fte/system.fterc
@@ -90,4 +81,3 @@ src_install () {
cp -R config/* ${D}/usr/share/fte
rm -rf ${D}/usr/share/fte/CVS
}
-
diff --git a/app-editors/fte/fte-20010819-r3.ebuild b/app-editors/fte/fte-20010819-r3.ebuild
index 89a8df00a6e3..78010fe7b51e 100644
--- a/app-editors/fte/fte-20010819-r3.ebuild
+++ b/app-editors/fte/fte-20010819-r3.ebuild
@@ -1,45 +1,34 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/fte/fte-20010819-r3.ebuild,v 1.16 2004/03/13 22:29:59 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/fte/fte-20010819-r3.ebuild,v 1.17 2004/05/31 22:12:03 vapier Exp $
inherit eutils
-IUSE="gpm slang X"
-
DESCRIPTION="Lightweight text-mode editor"
+HOMEPAGE="http://fte.sourceforge.net"
SRC_URI="mirror://sourceforge/fte/${P}-src.zip
mirror://sourceforge/fte/${P}-common.zip"
-HOMEPAGE="http://fte.sourceforge.net"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 sparc"
+IUSE="gpm slang X"
RDEPEND=">=sys-libs/ncurses-5.2
gpm? ( >=sys-libs/gpm-1.20 )"
-
DEPEND="${RDEPEND}
slang? ( sys-libs/slang )
app-arch/unzip
X? ( virtual/x11 )"
-TARGETS=""
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 sparc"
-
-if [ "`use slang`" ] ; then
- TARGETS="${TARGETS} sfte"
-fi
-
-if [ "`use X`" ] ; then
- TARGETS="${TARGETS} xfte"
-fi
-
-if [ "`use gpm`" ] ; then
- TARGETS="${TARGETS} vfte"
-fi
+set_targets() {
+ export TARGETS=""
+ use slang && TARGETS="$TARGETS sfte"
+ use X && TARGETS="$TARGETS xfte"
+ use gpm && TARGETS="$TARGETS vfte"
+}
src_unpack() {
-
- cd ${WORKDIR}
unpack fte-20010819-src.zip
unpack fte-20010819-common.zip
@@ -48,6 +37,7 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/${P}-gentoo.diff
+ set_targets
sed -i -e "s:@targets@:${TARGETS}:" \
-e "s:@cflags@:${CFLAGS}:" \
src/fte-unix.mak
@@ -60,17 +50,18 @@ src_compile() {
../src/cfte main.fte ../src/system.fterc
}
-src_install () {
+src_install() {
local files
into /usr
+ set_targets
files="${TARGETS} cfte compkeys"
for i in ${files} ; do
dobin src/$i ;
done
- dodoc Artistic CHANGES BUGS COPYING HISTORY README TODO
+ dodoc Artistic CHANGES BUGS HISTORY README TODO
dodir etc/fte
cp src/system.fterc ${D}/etc/fte/system.fterc
diff --git a/app-editors/fte/fte-20020324-r1.ebuild b/app-editors/fte/fte-20020324-r1.ebuild
index 3e6158827b8b..c53e494f0677 100644
--- a/app-editors/fte/fte-20020324-r1.ebuild
+++ b/app-editors/fte/fte-20020324-r1.ebuild
@@ -1,39 +1,30 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/fte/fte-20020324-r1.ebuild,v 1.4 2004/03/13 22:29:59 mr_bones_ Exp $
-
-IUSE="gpm slang X"
+# $Header: /var/cvsroot/gentoo-x86/app-editors/fte/fte-20020324-r1.ebuild,v 1.5 2004/05/31 22:12:03 vapier Exp $
DESCRIPTION="Lightweight text-mode editor"
+HOMEPAGE="http://fte.sourceforge.net"
SRC_URI="mirror://sourceforge/fte/${P}-src.zip
mirror://sourceforge/fte/${P}-common.zip"
-HOMEPAGE="http://fte.sourceforge.net"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 ~ppc sparc"
+IUSE="gpm slang X"
RDEPEND=">=sys-libs/ncurses-5.2
gpm? ( >=sys-libs/gpm-1.20 )"
-
DEPEND="${RDEPEND}
slang? ( sys-libs/slang )
app-arch/unzip
X? ( virtual/x11 )"
-TARGETS=""
-
-if [ "`use slang`" ] ; then
- TARGETS="${TARGETS} sfte"
-fi
-
-if [ "`use X`" ] ; then
- TARGETS="${TARGETS} xfte"
-fi
-
-if [ "`use gpm`" ] ; then
- TARGETS="${TARGETS} vfte"
-fi
+set_targets() {
+ export TARGETS=""
+ use slang && TARGETS="$TARGETS sfte"
+ use X && TARGETS="$TARGETS xfte"
+ use gpm && TARGETS="$TARGETS vfte"
+}
src_unpack() {
@@ -47,6 +38,7 @@ src_unpack() {
cp src/fte-unix.mak src/fte-unix.mak.orig
+ set_targets
sed \
-e "s:@targets@:${TARGETS}:" \
-e "s:@cflags@:${CFLAGS}:" \
@@ -57,16 +49,18 @@ src_compile() {
DEFFLAGS="PREFIX=/usr CONFIGDIR=/usr/share/fte \
DEFAULT_FTE_CONFIG=../config/main.fte OPTIMIZE="
- emake $DEFFLAGS TARGETS="$TARGETS" all || die
+ set_targets
+ emake $DEFFLAGS TARGETS="${TARGETS}" all || die
cd config
../src/cfte main.fte ../src/system.fterc
}
-src_install () {
+src_install() {
local files
into /usr
+ set_targets
files="${TARGETS} cfte compkeys"
for i in ${files} ; do
@@ -75,7 +69,7 @@ src_install () {
dobin ${FILESDIR}/fte
- dodoc Artistic CHANGES BUGS COPYING HISTORY README TODO
+ dodoc Artistic CHANGES BUGS HISTORY README TODO
dodir etc/fte
cp src/system.fterc ${D}/etc/fte/system.fterc
diff --git a/app-editors/fte/fte-20020324-r2.ebuild b/app-editors/fte/fte-20020324-r2.ebuild
index cb4aad0b511f..937e57af1547 100644
--- a/app-editors/fte/fte-20020324-r2.ebuild
+++ b/app-editors/fte/fte-20020324-r2.ebuild
@@ -1,45 +1,34 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/fte/fte-20020324-r2.ebuild,v 1.1 2004/03/17 14:32:49 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/fte/fte-20020324-r2.ebuild,v 1.2 2004/05/31 22:12:03 vapier Exp $
inherit eutils
-IUSE="gpm slang X"
-
DESCRIPTION="Lightweight text-mode editor"
+HOMEPAGE="http://fte.sourceforge.net"
SRC_URI="mirror://sourceforge/fte/${P}-src.zip
mirror://sourceforge/fte/${P}-common.zip"
-HOMEPAGE="http://fte.sourceforge.net"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc"
+IUSE="gpm slang X"
RDEPEND=">=sys-libs/ncurses-5.2
gpm? ( >=sys-libs/gpm-1.20 )"
-
DEPEND="${RDEPEND}
slang? ( sys-libs/slang )
app-arch/unzip
X? ( virtual/x11 )"
-TARGETS=""
-
-if [ "`use slang`" ] ; then
- TARGETS="${TARGETS} sfte"
-fi
-
-if [ "`use X`" ] ; then
- TARGETS="${TARGETS} xfte"
-fi
-
-if [ "`use gpm`" ] ; then
- TARGETS="${TARGETS} vfte"
-fi
+set_targets() {
+ export TARGETS=""
+ use slang && TARGETS="$TARGETS sfte"
+ use X && TARGETS="$TARGETS xfte"
+ use gpm && TARGETS="$TARGETS vfte"
+}
src_unpack() {
-
- cd ${WORKDIR}
unpack fte-20020324-src.zip
unpack fte-20020324-common.zip
@@ -49,6 +38,7 @@ src_unpack() {
epatch ${FILESDIR}/configpath.patch
+ set_targets
sed \
-e "s:@targets@:${TARGETS}:" \
-e "s:@cflags@:${CFLAGS}:" \
@@ -59,13 +49,15 @@ src_compile() {
DEFFLAGS="PREFIX=/usr CONFIGDIR=/usr/share/fte \
DEFAULT_FTE_CONFIG=../config/main.fte OPTIMIZE="
+ set_targets
emake $DEFFLAGS TARGETS="$TARGETS" all || die
}
-src_install () {
+src_install() {
local files
into /usr
+ set_targets
files="${TARGETS} cfte compkeys"
for i in ${files} ; do
@@ -74,7 +66,7 @@ src_install () {
dobin ${FILESDIR}/fte
- dodoc Artistic CHANGES BUGS COPYING HISTORY README TODO
+ dodoc Artistic CHANGES BUGS HISTORY README TODO
keepdir etc/fte
diff --git a/app-editors/fte/fte-20020324.ebuild b/app-editors/fte/fte-20020324.ebuild
index 4cab48ab2885..07fc0b21da84 100644
--- a/app-editors/fte/fte-20020324.ebuild
+++ b/app-editors/fte/fte-20020324.ebuild
@@ -1,43 +1,32 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/fte/fte-20020324.ebuild,v 1.17 2004/03/13 22:29:59 mr_bones_ Exp $
-
-IUSE="gpm slang X"
+# $Header: /var/cvsroot/gentoo-x86/app-editors/fte/fte-20020324.ebuild,v 1.18 2004/05/31 22:12:03 vapier Exp $
DESCRIPTION="Lightweight text-mode editor"
+HOMEPAGE="http://fte.sourceforge.net/"
SRC_URI="mirror://sourceforge/fte/${P}-src.zip
mirror://sourceforge/fte/${P}-common.zip"
-HOMEPAGE="http://fte.sourceforge.net"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 ppc sparc"
+IUSE="gpm slang X"
RDEPEND=">=sys-libs/ncurses-5.2
gpm? ( >=sys-libs/gpm-1.20 )"
-
DEPEND="${RDEPEND}
slang? ( sys-libs/slang )
app-arch/unzip
X? ( virtual/x11 )"
-TARGETS=""
-
-if [ "`use slang`" ] ; then
- TARGETS="${TARGETS} sfte"
-fi
-
-if [ "`use X`" ] ; then
- TARGETS="${TARGETS} xfte"
-fi
-
-if [ "`use gpm`" ] ; then
- TARGETS="${TARGETS} vfte"
-fi
+set_targets() {
+ export TARGETS=""
+ use slang && TARGETS="$TARGETS sfte"
+ use X && TARGETS="$TARGETS xfte"
+ use gpm && TARGETS="$TARGETS vfte"
+}
src_unpack() {
-
- cd ${WORKDIR}
unpack fte-20020324-src.zip
unpack fte-20020324-common.zip
@@ -47,6 +36,7 @@ src_unpack() {
cp src/fte-unix.mak src/fte-unix.mak.orig
+ set_targets
sed \
-e "s:@targets@:${TARGETS}:" \
-e "s:@cflags@:${CFLAGS}:" \
@@ -57,23 +47,25 @@ src_compile() {
DEFFLAGS="PREFIX=/usr CONFIGDIR=/usr/share/fte \
DEFAULT_FTE_CONFIG=../config/main.fte OPTIMIZE="
+ set_targets
emake $DEFFLAGS TARGETS="$TARGETS" all || die
cd config
../src/cfte main.fte ../src/system.fterc
}
-src_install () {
+src_install() {
local files
into /usr
+ set_targets
files="${TARGETS} cfte compkeys"
for i in ${files} ; do
dobin src/$i ;
done
- dodoc Artistic CHANGES BUGS COPYING HISTORY README TODO
+ dodoc Artistic CHANGES BUGS HISTORY README TODO
dodir etc/fte
cp src/system.fterc ${D}/etc/fte/system.fterc