summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2003-09-18 16:54:42 +0000
committerAron Griffis <agriffis@gentoo.org>2003-09-18 16:54:42 +0000
commit345f75ae43441c860465696f6e07f9bd7e23a8d0 (patch)
tree10b3472a227625f8e1478379133ca2529d6dfdcb /app-editors/gvim/gvim-6.2-r3.ebuild
parentpatchlevel bump (diff)
downloadgentoo-2-345f75ae43441c860465696f6e07f9bd7e23a8d0.tar.gz
gentoo-2-345f75ae43441c860465696f6e07f9bd7e23a8d0.tar.bz2
gentoo-2-345f75ae43441c860465696f6e07f9bd7e23a8d0.zip
patchlevel bump
Diffstat (limited to 'app-editors/gvim/gvim-6.2-r3.ebuild')
-rw-r--r--app-editors/gvim/gvim-6.2-r3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-editors/gvim/gvim-6.2-r3.ebuild b/app-editors/gvim/gvim-6.2-r3.ebuild
new file mode 100644
index 000000000000..5fc72f0ac968
--- /dev/null
+++ b/app-editors/gvim/gvim-6.2-r3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/gvim-6.2-r3.ebuild,v 1.1 2003/09/18 16:54:39 agriffis Exp $
+
+inherit vim
+
+VIM_VERSION="6.2"
+VIM_GENTOO_PATCHES="vim-6.2.069-gentoo-patches.tar.bz2"
+VIM_ORG_PATCHES="vim-6.2.098-patches.tar.bz2"
+
+SRC_URI="${SRC_URI}
+ ftp://ftp.vim.org/pub/vim/unix/vim-${VIM_VERSION}.tar.bz2
+ nls? ( ftp://ftp.vim.org/pub/vim/extra/vim-${VIM_VERSION}-lang.tar.gz )
+ mirror://gentoo/${VIM_GENTOO_PATCHES}
+ mirror://gentoo/${VIM_ORG_PATCHES}"
+
+S=${WORKDIR}/vim${VIM_VERSION/.}
+DESCRIPTION="Graphical Vim"
+KEYWORDS="alpha ~ppc ~sparc x86"
+PROVIDE="virtual/editor"
+DEPEND="${DEPEND}
+ ~app-editors/vim-core-${PV}
+ x11-base/xfree
+ gtk2? ( >=x11-libs/gtk+-2.1 virtual/xft ) :
+ ( gnome? ( gnome-base/gnome-libs ) :
+ ( gtk? ( =x11-libs/gtk+-1.2* ) :
+ ( motif? ( virtual/motif ) ) ) )"