summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2007-09-27 09:39:58 +0000
committerAli Polatel <hawking@gentoo.org>2007-09-27 09:39:58 +0000
commit1cbcf5d626995a4df69d4535bc3ddbe4fe6f706e (patch)
tree26004ef202f3ec8fc93b35246a0c05f4c0dc18fb /app-editors/gvim/gvim-7.1.123.ebuild
parentVersion bump. Drop old. (diff)
downloadgentoo-2-1cbcf5d626995a4df69d4535bc3ddbe4fe6f706e.tar.gz
gentoo-2-1cbcf5d626995a4df69d4535bc3ddbe4fe6f706e.tar.bz2
gentoo-2-1cbcf5d626995a4df69d4535bc3ddbe4fe6f706e.zip
Version bump. Drop old. Added new gvim.desktop file for bug 190289, thanks to Chidambar Zinnoury.
(Portage version: 2.1.3.9)
Diffstat (limited to 'app-editors/gvim/gvim-7.1.123.ebuild')
-rw-r--r--app-editors/gvim/gvim-7.1.123.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-editors/gvim/gvim-7.1.123.ebuild b/app-editors/gvim/gvim-7.1.123.ebuild
new file mode 100644
index 000000000000..47f95a057aa6
--- /dev/null
+++ b/app-editors/gvim/gvim-7.1.123.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/gvim-7.1.123.ebuild,v 1.1 2007/09/27 09:39:57 hawking Exp $
+
+inherit vim
+
+VIM_VERSION="7.1"
+VIM_GENTOO_PATCHES="vim-${VIM_VERSION}-gentoo-patches.tar.bz2"
+VIM_ORG_PATCHES="vim-patches-${PV}.tar.gz"
+GVIMRC_FILE_SUFFIX="-r1"
+GVIM_DESKTOP_SUFFIX="-r1"
+
+SRC_URI="ftp://ftp.vim.org/pub/vim/unstable/unix/vim-${VIM_VERSION}.tar.bz2
+ ftp://ftp.vim.org/pub/vim/extra/vim-${VIM_VERSION}-lang.tar.gz
+ ftp://ftp.vim.org/pub/vim/extra/vim-${VIM_VERSION}-extra.tar.gz
+ mirror://gentoo/${VIM_GENTOO_PATCHES}
+ mirror://gentoo/${VIM_ORG_PATCHES}"
+
+S="${WORKDIR}/vim${VIM_VERSION/.}"
+DESCRIPTION="GUI version of the Vim text editor"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="aqua gnome gtk motif nextaw"
+PROVIDE="virtual/editor"
+DEPEND="${DEPEND}
+ ~app-editors/vim-core-${PV}
+ x11-libs/libXext
+ !aqua? (
+ gtk? (
+ >=x11-libs/gtk+-2.6
+ virtual/xft
+ gnome? ( >=gnome-base/libgnomeui-2.6 )
+ )
+ !gtk? (
+ motif? (
+ x11-libs/openmotif
+ )
+ !motif? (
+ nextaw? (
+ x11-libs/neXtaw
+ )
+ !nextaw? ( x11-libs/libXaw )
+ )
+ )
+ )"