summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Knight <tomk@gentoo.org>2005-03-22 19:10:57 +0000
committerTom Knight <tomk@gentoo.org>2005-03-22 19:10:57 +0000
commit8667b49e0fc8f2eb08e815e1b338705af38ac7ff (patch)
treeb352212772d6e824cba3b8d1dbe591c930140438 /app-editors/joe/joe-3.2.ebuild
parentBug 86161 - threaded perl and tests (diff)
downloadgentoo-2-8667b49e0fc8f2eb08e815e1b338705af38ac7ff.tar.gz
gentoo-2-8667b49e0fc8f2eb08e815e1b338705af38ac7ff.tar.bz2
gentoo-2-8667b49e0fc8f2eb08e815e1b338705af38ac7ff.zip
Version bump to 3.2, added eutils inherit to 3.0-r2
Diffstat (limited to 'app-editors/joe/joe-3.2.ebuild')
-rw-r--r--app-editors/joe/joe-3.2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-editors/joe/joe-3.2.ebuild b/app-editors/joe/joe-3.2.ebuild
new file mode 100644
index 000000000000..0acb76b6b51e
--- /dev/null
+++ b/app-editors/joe/joe-3.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/joe-3.2.ebuild,v 1.1 2005/03/22 19:10:57 tomk Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="A free ASCII-Text Screen Editor for UNIX"
+HOMEPAGE="http://sourceforge.net/projects/joe-editor/"
+SRC_URI="mirror://sourceforge/joe-editor/${P}.tar.gz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~amd64"
+IUSE=""
+
+DEPEND=">=sys-libs/ncurses-5.2-r2"
+PROVIDE="virtual/editor"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # Fix bug #50271 (joe 3.0 documentation doesn't reflect new config file location)
+ sed -e 's:${prefix}/etc/joerc:@sysconfdir@/joe/joerc:' -i joerc.in
+ for i in jmacsrc.in jpicorc.in jstarrc.in rjoerc.in joe.1.in
+ do
+ sed -e 's:@sysconfdir@/:@sysconfdir@/joe/:' -i ${i}
+ done
+}
+
+src_compile() {
+ # Bug 34609 (joe 2.9.8 editor seg-faults on 'find and replace' when compiled with -Os)
+ replace-flags "-Os" "-O2"
+
+ econf || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failed"
+ dodoc ChangeLog HINTS INFO LIST NEWS README TODO
+}
+
+pkg_postinst() {
+ echo
+ einfo "Global configuration has been moved from /etc to /etc/joe."
+ einfo "You should move or remove your old configuration files."
+ echo
+}