summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-01-24 22:13:57 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-01-24 22:13:57 +0000
commita66573b444b06ad497b4ef61c51da8cec36601c4 (patch)
treec92da5631bee33d9706be95f00a506da41565e72 /app-editors/kile/kile-2.1_beta5.ebuild
parentppc stable wrt #352608 (diff)
downloadgentoo-2-a66573b444b06ad497b4ef61c51da8cec36601c4.tar.gz
gentoo-2-a66573b444b06ad497b4ef61c51da8cec36601c4.tar.bz2
gentoo-2-a66573b444b06ad497b4ef61c51da8cec36601c4.zip
Version bump
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/kile/kile-2.1_beta5.ebuild')
-rw-r--r--app-editors/kile/kile-2.1_beta5.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/app-editors/kile/kile-2.1_beta5.ebuild b/app-editors/kile/kile-2.1_beta5.ebuild
new file mode 100644
index 000000000000..e6ed6c24c8f5
--- /dev/null
+++ b/app-editors/kile/kile-2.1_beta5.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/kile/kile-2.1_beta5.ebuild,v 1.1 2011/01/24 22:13:57 scarabeus Exp $
+
+EAPI=3
+
+if [[ ${PV} != *9999* ]]; then
+ KDE_DOC_DIRS="doc"
+ KDE_HANDBOOK="optional"
+ MY_P=${P/_beta/b}
+ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+else
+ EGIT_REPO_URI="http://anongit.kde.org/kile"
+ GIT_ECLASS="git"
+fi
+
+inherit kde4-base ${GIT_ECLASS}
+
+DESCRIPTION="A Latex Editor and TeX shell for KDE"
+HOMEPAGE="http://kile.sourceforge.net/"
+
+LICENSE="FDL-1.2 GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+SLOT="4"
+IUSE="debug +pdf +png"
+
+DEPEND="
+ x11-misc/shared-mime-info
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kdebase-data)
+ || (
+ $(add_kdebase_dep okular 'pdf?,ps')
+ app-text/acroread
+ )
+ virtual/latex-base
+ virtual/tex-base
+ pdf? (
+ app-text/dvipdfmx
+ app-text/ghostscript-gpl
+ )
+ png? (
+ app-text/dvipng
+ media-gfx/imagemagick[png]
+ )
+"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( kile-remote-control.txt )
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ # I know upstream wants to help us but it doesn't work..
+ sed -e '/INSTALL( FILES AUTHORS/s/^/#DISABLED /' \
+ -i CMakeLists.txt || die
+
+ [[ ${PV} != *9999* ]] && { use handbook || rm -fr doc ; }
+}