summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-06-17 21:49:44 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-06-17 21:49:44 +0000
commit5716659dd0b1de31f093502a22bc69214bf77b62 (patch)
tree506bebd6cd503670d6ee20131512a26f739fe4be /app-editors/kile
parentDon't hardwire blas, but let cmake find it, bug 370721 (diff)
downloadgentoo-2-5716659dd0b1de31f093502a22bc69214bf77b62.tar.gz
gentoo-2-5716659dd0b1de31f093502a22bc69214bf77b62.tar.bz2
gentoo-2-5716659dd0b1de31f093502a22bc69214bf77b62.zip
Version bump
(Portage version: 2.1.10.1/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/kile')
-rw-r--r--app-editors/kile/ChangeLog7
-rw-r--r--app-editors/kile/kile-2.1.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/app-editors/kile/ChangeLog b/app-editors/kile/ChangeLog
index 8e1ba9cee1db..965e8e0116d2 100644
--- a/app-editors/kile/ChangeLog
+++ b/app-editors/kile/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/kile
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/kile/ChangeLog,v 1.142 2011/05/13 11:10:20 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/kile/ChangeLog,v 1.143 2011/06/17 21:49:44 dilfridge Exp $
+
+*kile-2.1 (17 Jun 2011)
+
+ 17 Jun 2011; Andreas K. Huettel <dilfridge@gentoo.org> +kile-2.1.ebuild:
+ Version bump
13 May 2011; Tomáš Chvátal <scarabeus@gentoo.org> -kile-2.1_beta4.ebuild:
remove old
diff --git a/app-editors/kile/kile-2.1.ebuild b/app-editors/kile/kile-2.1.ebuild
new file mode 100644
index 000000000000..1f7b09df0c39
--- /dev/null
+++ b/app-editors/kile/kile-2.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/kile/kile-2.1.ebuild,v 1.1 2011/06/17 21:49:44 dilfridge Exp $
+
+EAPI=3
+
+if [[ ${PV} != *9999* ]]; then
+ KDE_DOC_DIRS="doc"
+ KDE_HANDBOOK="optional"
+ MY_P=${P/_beta/b}
+ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+else
+ EGIT_REPO_URI="http://anongit.kde.org/kile"
+ GIT_ECLASS="git"
+fi
+
+inherit kde4-base ${GIT_ECLASS}
+
+DESCRIPTION="A Latex Editor and TeX shell for KDE"
+HOMEPAGE="http://kile.sourceforge.net/"
+
+LICENSE="FDL-1.2 GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+SLOT="4"
+IUSE="debug +pdf +png"
+
+DEPEND="
+ x11-misc/shared-mime-info
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kdebase-data)
+ || (
+ $(add_kdebase_dep okular 'pdf?,ps')
+ app-text/acroread
+ )
+ virtual/latex-base
+ virtual/tex-base
+ pdf? (
+ app-text/dvipdfmx
+ app-text/ghostscript-gpl
+ )
+ png? (
+ app-text/dvipng
+ media-gfx/imagemagick[png]
+ )
+"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( kile-remote-control.txt )
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ # I know upstream wants to help us but it doesn't work..
+ sed -e '/INSTALL( FILES AUTHORS/s/^/#DISABLED /' \
+ -i CMakeLists.txt || die
+
+ [[ ${PV} != *9999* ]] && { use handbook || rm -fr doc ; }
+}