summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-03-27 20:39:55 +0000
committerMike Frysinger <vapier@gentoo.org>2015-03-27 20:39:55 +0000
commitcda26e40f8606f379bbc0f22181b04b7ae1f5096 (patch)
tree3e02f4df0768d70128dcccb0fc76c75f2056203a /app-editors/nano
parentVersion bump. (diff)
downloadgentoo-2-cda26e40f8606f379bbc0f22181b04b7ae1f5096.tar.gz
gentoo-2-cda26e40f8606f379bbc0f22181b04b7ae1f5096.tar.bz2
gentoo-2-cda26e40f8606f379bbc0f22181b04b7ae1f5096.zip
Add upstream fix for building with USE=-spell #544296 by Karl Lindén.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'app-editors/nano')
-rw-r--r--app-editors/nano/ChangeLog6
-rw-r--r--app-editors/nano/files/nano-2.4.0-no-speller.patch88
-rw-r--r--app-editors/nano/nano-2.4.0.ebuild3
3 files changed, 95 insertions, 2 deletions
diff --git a/app-editors/nano/ChangeLog b/app-editors/nano/ChangeLog
index f53fb8e97f05..6623642618ac 100644
--- a/app-editors/nano/ChangeLog
+++ b/app-editors/nano/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/nano
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/ChangeLog,v 1.317 2015/03/23 07:14:32 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/ChangeLog,v 1.318 2015/03/27 20:39:55 vapier Exp $
+
+ 27 Mar 2015; Mike Frysinger <vapier@gentoo.org>
+ +files/nano-2.4.0-no-speller.patch, nano-2.4.0.ebuild:
+ Add upstream fix for building with USE=-spell #544296 by Karl Lindén.
*nano-2.4.0 (23 Mar 2015)
diff --git a/app-editors/nano/files/nano-2.4.0-no-speller.patch b/app-editors/nano/files/nano-2.4.0-no-speller.patch
new file mode 100644
index 000000000000..4405266bb0af
--- /dev/null
+++ b/app-editors/nano/files/nano-2.4.0-no-speller.patch
@@ -0,0 +1,88 @@
+https://bugs.gentoo.org/show_bug.cgi?id=544296
+https://savannah.gnu.org/bugs/?44607
+
+From 14a9c8aa0b124dc580c4805e848e6ff0880b43bd Mon Sep 17 00:00:00 2001
+From: Benno Schulenberg <bensberg@justemail.net>
+Date: Fri, 27 Mar 2015 16:55:49 +0000
+Subject: [PATCH] Treating the formatter like a speller, to fix compilation
+ with --disable-speller. This fixes Savannah bug #44607.
+
+git-svn-id: svn://svn.savannah.gnu.org/nano/trunk/nano@5168 35c25a1d-7b9e-4130-9fde-d3aeb78583b8
+---
+ ChangeLog | 2 ++
+ src/global.c | 10 ++++++++--
+ src/text.c | 3 ++-
+ 3 files changed, 12 insertions(+), 3 deletions(-)
+
+ChangeLog
+ * src/global.c, src/text.c: Treat the formatter like a speller, to fix
+ compilation with --disable-speller. Fixes Savannah bug #44607.
+
+diff --git a/src/global.c b/src/global.c
+index 4643af2..27ff938 100644
+--- a/src/global.c
++++ b/src/global.c
+@@ -639,8 +639,10 @@ void shortcut_init(void)
+ const char *nano_lint_msg = N_("Invoke the linter, if available");
+ const char *nano_prevlint_msg = N_("Go to previous linter msg");
+ const char *nano_nextlint_msg = N_("Go to next linter msg");
++#ifndef DISABLE_SPELLER
+ const char *nano_formatter_msg = N_("Invoke formatter, if available");
+ #endif
++#endif
+ #endif /* !DISABLE_HELP */
+
+ #ifndef DISABLE_HELP
+@@ -736,9 +738,11 @@ void shortcut_init(void)
+ #ifndef DISABLE_COLOR
+ add_to_funcs(do_linter, MMAIN,
+ N_("To Linter"), IFSCHELP(nano_lint_msg), TOGETHER, NOVIEW);
++#ifndef DISABLE_SPELLER
+ add_to_funcs(do_formatter, MMAIN,
+ N_("Formatter"), IFSCHELP(nano_formatter_msg), BLANKAFTER, NOVIEW);
+ #endif
++#endif
+
+ #ifndef NANO_TINY
+ add_to_funcs(case_sens_void, MWHEREIS|MREPLACE,
+@@ -1006,12 +1010,14 @@ void shortcut_init(void)
+ #ifndef DISABLE_SPELLER
+ add_to_sclist(MMAIN, "^T", do_spell, 0);
+ add_to_sclist(MMAIN, "F12", do_spell, 0);
++#ifndef DISABLE_COLOR
++ add_to_sclist(MMAIN, "^T", do_formatter, 0);
++ add_to_sclist(MMAIN, "F12", do_formatter, 0);
++#endif
+ #else
+ #ifndef DISABLE_COLOR
+ add_to_sclist(MMAIN, "^T", do_linter, 0);
+ add_to_sclist(MMAIN, "F12", do_linter, 0);
+- add_to_sclist(MMAIN, "^T", do_formatter, 0);
+- add_to_sclist(MMAIN, "F12", do_formatter, 0);
+ #endif
+ #endif
+ add_to_sclist(MMAIN, "^C", do_cursorpos_void, 0);
+diff --git a/src/text.c b/src/text.c
+index 8814b49..98b2f80 100644
+--- a/src/text.c
++++ b/src/text.c
+@@ -3223,6 +3223,7 @@ free_lints_and_return:
+ lint_cleanup();
+ }
+
++#ifndef DISABLE_SPELLER
+ /* Run a formatter for the given syntax.
+ * Expects the formatter to be non-interactive and
+ * operate on a file in-place, which we'll pass it
+@@ -3370,7 +3371,7 @@ void do_formatter(void)
+
+ statusbar(finalstatus);
+ }
+-
++#endif /* !DISABLE_SPELLER */
+ #endif /* !DISABLE_COLOR */
+
+ #ifndef NANO_TINY
+--
+2.3.3
+
diff --git a/app-editors/nano/nano-2.4.0.ebuild b/app-editors/nano/nano-2.4.0.ebuild
index 97f166586410..7553247be58d 100644
--- a/app-editors/nano/nano-2.4.0.ebuild
+++ b/app-editors/nano/nano-2.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-2.4.0.ebuild,v 1.1 2015/03/23 07:14:32 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-2.4.0.ebuild,v 1.2 2015/03/27 20:39:55 vapier Exp $
EAPI="4"
@@ -30,6 +30,7 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"
src_prepare() {
+ epatch "${FILESDIR}"/${P}-no-speller.patch #544296
epatch_user
}