summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2007-04-17 09:13:31 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2007-04-17 09:13:31 +0000
commitd2c869b5bfb25ab7f8640519b21453380547239e (patch)
tree1b1e53dd04c320598e93b58b639da03a72d263b4 /app-editors/scite
parentVersion bump, thanks to steveb <steeeeeveee at gmx dot net> and Natanael Copa... (diff)
downloadgentoo-2-d2c869b5bfb25ab7f8640519b21453380547239e.tar.gz
gentoo-2-d2c869b5bfb25ab7f8640519b21453380547239e.tar.bz2
gentoo-2-d2c869b5bfb25ab7f8640519b21453380547239e.zip
Version bump.
(Portage version: 2.1.2.4)
Diffstat (limited to 'app-editors/scite')
-rw-r--r--app-editors/scite/ChangeLog8
-rw-r--r--app-editors/scite/files/digest-scite-1.733
-rw-r--r--app-editors/scite/files/scite-1.73-install.patch20
-rw-r--r--app-editors/scite/scite-1.73.ebuild73
4 files changed, 103 insertions, 1 deletions
diff --git a/app-editors/scite/ChangeLog b/app-editors/scite/ChangeLog
index b9202d5ea935..16440c7d0e10 100644
--- a/app-editors/scite/ChangeLog
+++ b/app-editors/scite/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/scite
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/ChangeLog,v 1.60 2007/03/13 17:54:02 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/ChangeLog,v 1.61 2007/04/17 09:13:31 nelchael Exp $
+
+*scite-1.73 (17 Apr 2007)
+
+ 17 Apr 2007; Krzysiek Pawlik <nelchael@gentoo.org>
+ +files/scite-1.73-install.patch, +scite-1.73.ebuild:
+ Version bump.
13 Mar 2007; Gustavo Zacarias <gustavoz@gentoo.org> scite-1.72.ebuild:
Stable on sparc
diff --git a/app-editors/scite/files/digest-scite-1.73 b/app-editors/scite/files/digest-scite-1.73
new file mode 100644
index 000000000000..730be17b1b21
--- /dev/null
+++ b/app-editors/scite/files/digest-scite-1.73
@@ -0,0 +1,3 @@
+MD5 0e8e4139b5f5db445b3da9ff070d9d3a scite173.tgz 1343699
+RMD160 443fa627dbe559fa3ec3620bbec759ba0dc93634 scite173.tgz 1343699
+SHA256 1dde09224162f3dadd440ba08beb1f425c997e73559e2107f4fc4bfd52a779c4 scite173.tgz 1343699
diff --git a/app-editors/scite/files/scite-1.73-install.patch b/app-editors/scite/files/scite-1.73-install.patch
new file mode 100644
index 000000000000..c1d87501c855
--- /dev/null
+++ b/app-editors/scite/files/scite-1.73-install.patch
@@ -0,0 +1,20 @@
+--- scite/gtk/makefile.orig 2006-10-09 06:26:55 -0300
++++ scite/gtk/makefile 2006-10-09 06:36:09 -0300
+@@ -123,11 +123,14 @@
+
+ ifdef gnomeprefix
+ ifdef GTK2
+- $(INSTALL) -m 755 -D SciTE.desktop $(DESTDIR)$(datadir)/applications/SciTE.desktop
++ $(INSTALL) -m 755 -d $(DESTDIR)$(datadir)/applications/
++ $(INSTALL) -m 755 SciTE.desktop $(DESTDIR)$(datadir)/applications/
+ else
+- $(INSTALL) -m 755 -D SciTE.desktop $(DESTDIR)$(datadir)/applications/SciTE.desktop
++ $(INSTALL) -m 755 -d $(DESTDIR)$(datadir)/applications/
++ $(INSTALL) -m 755 SciTE.desktop $(DESTDIR)$(datadir)/applications/
+ endif
+- $(INSTALL) -m 644 -D Sci48M.png $(DESTDIR)$(pixmapdir)/Sci48M.png
++ $(INSTALL) -m 644 -d $(DESTDIR)$(pixmapdir)/
++ $(INSTALL) -m 644 Sci48M.png $(DESTDIR)$(pixmapdir)/Sci48M.png
+ endif
+
+ uninstall:
diff --git a/app-editors/scite/scite-1.73.ebuild b/app-editors/scite/scite-1.73.ebuild
new file mode 100644
index 000000000000..1d12dea52fbd
--- /dev/null
+++ b/app-editors/scite/scite-1.73.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/scite-1.73.ebuild,v 1.1 2007/04/17 09:13:31 nelchael Exp $
+
+inherit toolchain-funcs eutils
+
+MY_PV=${PV//./}
+DESCRIPTION="A very powerful editor for programmers"
+HOMEPAGE="http://scintilla.sourceforge.net/SciTE.html"
+SRC_URI="mirror://sourceforge/scintilla/${PN}${MY_PV}.tgz"
+
+LICENSE="Scintilla"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="lua"
+
+RDEPEND=">=x11-libs/gtk+-2
+ lua? ( >=dev-lang/lua-5 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=sys-apps/sed-4"
+
+S=${WORKDIR}/${PN}/gtk
+
+src_unpack() {
+ unpack ${A}
+ cd ${WORKDIR}/scintilla/gtk
+ sed -i makefile \
+ -e "s#^CXXFLAGS=#CXXFLAGS=${CXXFLAGS} #" \
+ -e "s#^\(CXXFLAGS=.*\)-Os#\1#" \
+ -e "s#^CC =\(.*\)#CC = $(tc-getCXX)#" \
+ || die "error patching makefile"
+
+ cd ${S}
+ sed -i makefile \
+ -e 's#usr/local#usr#g' \
+ -e 's#/gnome/apps/Applications#/applications#' \
+ -e "s#^CXXFLAGS=#CXXFLAGS=${CXXFLAGS} #" \
+ -e "s#^\(CXXFLAGS=.*\)-Os#\1#" \
+ -e "s#^CC =\(.*\)#CC = $(tc-getCXX)#" \
+ -e 's#${D}##' \
+ -e 's#-g root#-g 0#' \
+ || die "error patching makefile"
+ epatch ${FILESDIR}/${P}-install.patch
+}
+
+src_compile() {
+ make -C ../../scintilla/gtk || die "prep make failed"
+ if use lua; then
+ emake || die "make failed"
+ else
+ emake NO_LUA=1 || die "make failed"
+ fi
+}
+
+src_install() {
+ dodir /usr/bin
+ dodir /usr/share/{pixmaps,applications}
+
+ make prefix=${D}/usr install || die
+
+ # we have to keep this because otherwise it'll break upgrading
+ mv ${D}/usr/bin/SciTE ${D}/usr/bin/scite
+ dosym /usr/bin/scite /usr/bin/SciTE
+
+ # replace .desktop file with our own working version
+ insinto /usr/share/applications
+ rm -f ${D}/usr/share/applications/SciTE.desktop
+ doins ${FILESDIR}/scite.desktop
+
+ doman ../doc/scite.1
+ dodoc ../README
+}