summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2010-02-27 19:52:06 +0000
committerBen de Groot <yngwin@gentoo.org>2010-02-27 19:52:06 +0000
commit343e586e434dbd392974aeb624069acd4c0a6844 (patch)
tree93b8085f510d66a143fa7ba6e52e18f5e94d5673 /app-editors/tea
parentfix initial data locating (diff)
downloadgentoo-2-343e586e434dbd392974aeb624069acd4c0a6844.tar.gz
gentoo-2-343e586e434dbd392974aeb624069acd4c0a6844.tar.bz2
gentoo-2-343e586e434dbd392974aeb624069acd4c0a6844.zip
Assign to Qt herd. Version bump. Drop unneccessary elog message.
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/tea')
-rw-r--r--app-editors/tea/ChangeLog8
-rw-r--r--app-editors/tea/metadata.xml7
-rw-r--r--app-editors/tea/tea-27.0.0.ebuild48
3 files changed, 57 insertions, 6 deletions
diff --git a/app-editors/tea/ChangeLog b/app-editors/tea/ChangeLog
index ca909da41a1b..55a1cd76c604 100644
--- a/app-editors/tea/ChangeLog
+++ b/app-editors/tea/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/tea
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/ChangeLog,v 1.47 2010/01/07 09:37:08 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/ChangeLog,v 1.48 2010/02/27 19:52:06 yngwin Exp $
+
+*tea-27.0.0 (27 Feb 2010)
+
+ 27 Feb 2010; Ben de Groot <yngwin@gentoo.org> +tea-27.0.0.ebuild,
+ metadata.xml:
+ Assign to Qt herd. Version bump. Drop unneccessary elog message.
07 Jan 2010; <hwoarang@gentoo.org> tea-26.0.1.ebuild:
replace qt4 eclass with qt4-r2
diff --git a/app-editors/tea/metadata.xml b/app-editors/tea/metadata.xml
index f03903b4402c..49e454fcc744 100644
--- a/app-editors/tea/metadata.xml
+++ b/app-editors/tea/metadata.xml
@@ -1,11 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>no-herd</herd>
- <maintainer>
- <email>maintainer-needed@gentoo.org</email>
- </maintainer>
- <longdescription>
+ <herd>qt</herd>
+ <longdescription>
A very small Qt text editor. It has lots of extra features including syntax
highlighting and a built in file manager as well as a built in image viewer.
It can also read lots of 'other' filetypes.
diff --git a/app-editors/tea/tea-27.0.0.ebuild b/app-editors/tea/tea-27.0.0.ebuild
new file mode 100644
index 000000000000..502cfcb8fc76
--- /dev/null
+++ b/app-editors/tea/tea-27.0.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/tea-27.0.0.ebuild,v 1.1 2010/02/27 19:52:06 yngwin Exp $
+
+EAPI="2"
+inherit eutils qt4-r2
+
+DESCRIPTION="Small, lightweight Qt text editor"
+HOMEPAGE="http://tea-editor.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tea-editor/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86 ~x86-fbsd"
+IUSE="aspell hunspell"
+
+DEPEND="x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ x11-libs/qt-svg:4
+ x11-libs/qt-script:4"
+RDEPEND="${DEPEND}
+ aspell? ( app-text/aspell )
+ hunspell? ( app-text/hunspell )"
+
+src_configure() {
+ local myopts
+ if use aspell ; then
+ myopts="USE_ASPELL=true"
+ else
+ myopts="USE_ASPELL=false"
+ fi
+
+ if use hunspell ; then
+ myopts="${myopts} USE_HUNSPELL=true"
+ else
+ myopts="${myopts} USE_HUNSPELL=false"
+ fi
+
+ eqmake4 src.pro PREFIX="/usr/bin" ${myopts}
+}
+
+src_install() {
+ dobin bin/tea || die
+ dodoc AUTHORS ChangeLog NEWS NEWS-RU TODO || die
+ doicon icons/tea_icon_v2.png || die
+
+ make_desktop_entry tea Tea tea_icon_v2 Utility
+}