summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-08-27 07:29:33 +0000
committerTim Harder <radhermit@gentoo.org>2013-08-27 07:29:33 +0000
commit17fecb9c193e7bc2d429bd7c5ecd0fd8137b268a (patch)
tree2fb4095a1e3bfa500c4f60289911e022b34aee19 /app-editors/vile
parentVersion bump. (diff)
downloadgentoo-2-17fecb9c193e7bc2d429bd7c5ecd0fd8137b268a.tar.gz
gentoo-2-17fecb9c193e7bc2d429bd7c5ecd0fd8137b268a.tar.bz2
gentoo-2-17fecb9c193e7bc2d429bd7c5ecd0fd8137b268a.zip
Version bump.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-editors/vile')
-rw-r--r--app-editors/vile/ChangeLog9
-rw-r--r--app-editors/vile/vile-9.8k.ebuild48
2 files changed, 55 insertions, 2 deletions
diff --git a/app-editors/vile/ChangeLog b/app-editors/vile/ChangeLog
index 0d4291753bb1..54fb42ce186b 100644
--- a/app-editors/vile/ChangeLog
+++ b/app-editors/vile/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/vile
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vile/ChangeLog,v 1.47 2012/08/28 08:29:46 radhermit Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vile/ChangeLog,v 1.48 2013/08/27 07:29:33 radhermit Exp $
+
+*vile-9.8k (27 Aug 2013)
+
+ 27 Aug 2013; Tim Harder <radhermit@gentoo.org> +vile-9.8k.ebuild:
+ Version bump.
28 Aug 2012; Tim Harder <radhermit@gentoo.org> -vile-9.4d.ebuild:
Remove old.
diff --git a/app-editors/vile/vile-9.8k.ebuild b/app-editors/vile/vile-9.8k.ebuild
new file mode 100644
index 000000000000..3a8d68186f6c
--- /dev/null
+++ b/app-editors/vile/vile-9.8k.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vile/vile-9.8k.ebuild,v 1.1 2013/08/27 07:29:33 radhermit Exp $
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="VI Like Emacs -- yet another full-featured vi clone"
+HOMEPAGE="http://invisible-island.net/vile/"
+SRC_URI="ftp://invisible-island.net/vile/current/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="perl"
+
+RDEPEND=">=sys-libs/ncurses-5.2
+ perl? ( dev-lang/perl )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ app-admin/eselect-vi"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-9.8h-flex.patch
+}
+
+src_configure() {
+ econf \
+ --with-ncurses \
+ $(use_with perl )
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc CHANGES* README doc/*.doc
+ dohtml doc/*.html
+}
+
+pkg_postinst() {
+ einfo "Updating ${EPREFIX}/usr/bin/vi symlink"
+ eselect vi update --if-unset
+}
+
+pkg_postrm() {
+ einfo "Updating ${EPREFIX}/usr/bin/vi symlink"
+ eselect vi update --if-unset
+}