summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2010-08-16 20:11:30 +0000
committerJim Ramsay <lack@gentoo.org>2010-08-16 20:11:30 +0000
commit3be3c27308c5757a2420af2a23820f5152d9d24f (patch)
tree155b566e8a06e4af96ace664b6d278177043ae60 /app-editors/vim/vim-7.3.ebuild
parentNew release: vim-7.3 (Bug 333003) (diff)
downloadgentoo-2-3be3c27308c5757a2420af2a23820f5152d9d24f.tar.gz
gentoo-2-3be3c27308c5757a2420af2a23820f5152d9d24f.tar.bz2
gentoo-2-3be3c27308c5757a2420af2a23820f5152d9d24f.zip
New release: vim-7.3 (Bug 333003)
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/vim/vim-7.3.ebuild')
-rw-r--r--app-editors/vim/vim-7.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-editors/vim/vim-7.3.ebuild b/app-editors/vim/vim-7.3.ebuild
new file mode 100644
index 000000000000..6ff26911cbdc
--- /dev/null
+++ b/app-editors/vim/vim-7.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/vim-7.3.ebuild,v 1.1 2010/08/16 20:11:30 lack Exp $
+
+EAPI=3
+VIM_VERSION="7.3"
+inherit vim
+
+#VIM_ORG_PATCHES="vim-patches-${PV}.tar.gz"
+
+SRC_URI="ftp://ftp.vim.org/pub/vim/unix/vim-${VIM_VERSION}.tar.bz2"
+
+# New release: No patches yet
+# mirror://gentoo/${VIM_ORG_PATCHES}
+
+S="${WORKDIR}/vim${VIM_VERSION/.}"
+DESCRIPTION="Vim, an improved vi-style text editor"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+src_prepare() {
+ vim_src_prepare
+
+ if [[ ${CHOST} == *-interix* ]]; then
+ epatch "${FILESDIR}"/${PN}-7.1-interix-link.patch
+ epatch "${FILESDIR}"/${PN}-7.1.319-interix-cflags.patch
+ fi
+ epatch "${FILESDIR}"/${PN}-7.1.285-darwin-x11link.patch
+}