summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2003-05-28 11:44:47 +0000
committerAron Griffis <agriffis@gentoo.org>2003-05-28 11:44:47 +0000
commit821be8da2c26f9587e3c0031bc745aa8d5c8241d (patch)
tree162fc2861f424204de031812acc7c476f7c004e7 /app-editors/vim
parentfix bug 19438 (diff)
downloadgentoo-2-821be8da2c26f9587e3c0031bc745aa8d5c8241d.tar.gz
gentoo-2-821be8da2c26f9587e3c0031bc745aa8d5c8241d.tar.bz2
gentoo-2-821be8da2c26f9587e3c0031bc745aa8d5c8241d.zip
fix bug 19438
Diffstat (limited to 'app-editors/vim')
-rw-r--r--app-editors/vim/ChangeLog8
-rw-r--r--app-editors/vim/Manifest4
-rw-r--r--app-editors/vim/files/digest-vim-6.2_pre6-r13
-rw-r--r--app-editors/vim/vim-6.2_pre6-r1.ebuild22
4 files changed, 34 insertions, 3 deletions
diff --git a/app-editors/vim/ChangeLog b/app-editors/vim/ChangeLog
index 2b96971ddc86..d1c8fc334510 100644
--- a/app-editors/vim/ChangeLog
+++ b/app-editors/vim/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/vim
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/ChangeLog,v 1.57 2003/05/26 15:27:15 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/ChangeLog,v 1.58 2003/05/28 11:44:19 agriffis Exp $
+
+*vim-6.2_pre6-r1 (28 May 2003)
+
+ 28 May 2003; Aron Griffis <agriffis@gentoo.org> vim-6.2_pre6-r1.ebuild:
+ Add patch to make autoconf-2.57 work with Vim. This fixes bug 19438. Bram is
+ also integrating this patch into his sources.
*vim-6.2_pre6 (26 May 2003)
diff --git a/app-editors/vim/Manifest b/app-editors/vim/Manifest
index 8109fdefde05..7942185b2095 100644
--- a/app-editors/vim/Manifest
+++ b/app-editors/vim/Manifest
@@ -5,10 +5,10 @@ MD5 2dcc758706b7ab09352ea49f2f480d85 vim-6.2_pre4.ebuild 775
MD5 3921851881b23d1ecdc1a9f7ff9e11cd vim-6.2_pre6.ebuild 792
MD5 c1e211aaaabf14d6746829544e53b413 vim-6.2_pre1.ebuild 784
MD5 c8241c77a55138468ec5745af3fd9c6d vim-6.2_pre3.ebuild 775
-MD5 eb5a713f7432171f0d3d0e80413c90de ChangeLog 10596
+MD5 ea5210f5b9c8c0b445d25fc9dea8e56c ChangeLog 10830
MD5 77766d8697a1591edafebfdf7328fc3a vim-6.1-r21.ebuild 752
MD5 375c2f013ea6a3a7ad2f5f297f681178 vim-6.2_pre5.ebuild 775
-MD5 84769129bfe9f8b9a7812ae74eca5321 vim-6.2_pre6-r1.ebuild 792
+MD5 ff57ad24e51584046983b2328b44e96c vim-6.2_pre6-r1.ebuild 795
MD5 c1c3576985bcab3a31e4abd27ee00d07 files/digest-vim-6.2_pre1 201
MD5 bd60e74d8b97496b46e4c67d6f3f250c files/digest-vim-6.2_pre2 202
MD5 6308e9c63def2292a39768b027e7dd8d files/digest-vim-6.2_pre3 202
diff --git a/app-editors/vim/files/digest-vim-6.2_pre6-r1 b/app-editors/vim/files/digest-vim-6.2_pre6-r1
new file mode 100644
index 000000000000..93df69b80b50
--- /dev/null
+++ b/app-editors/vim/files/digest-vim-6.2_pre6-r1
@@ -0,0 +1,3 @@
+MD5 cf795137e89d788a951962ac2c640eb8 vim-6.2f.tar.bz2 3253921
+MD5 52bfae9d2fb3a5716ba4d8a36e043fb9 vim-6.2f-lang.tar.gz 1077181
+MD5 d6a9c0f37545532e0b2e0b9da205b933 vim-6.2f-gentoo-patches.tar.bz2 3649
diff --git a/app-editors/vim/vim-6.2_pre6-r1.ebuild b/app-editors/vim/vim-6.2_pre6-r1.ebuild
new file mode 100644
index 000000000000..36f0dee8ab26
--- /dev/null
+++ b/app-editors/vim/vim-6.2_pre6-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/vim-6.2_pre6-r1.ebuild,v 1.1 2003/05/28 11:44:19 agriffis Exp $
+
+inherit vim
+
+VIM_VERSION="6.2f"
+VIM_GENTOO_PATCHES="vim-6.2f-gentoo-patches.tar.bz2"
+VIM_ORG_PATCHES="" # no patches available
+
+SRC_URI="${SRC_URI}
+ ftp://ftp.vim.org/pub/vim/unstable/unix/vim-${VIM_VERSION}.tar.bz2
+ nls? ( ftp://ftp.vim.org/pub/vim/unstable/extra/vim-${VIM_VERSION}-lang.tar.gz )
+ mirror://gentoo/${VIM_GENTOO_PATCHES}"
+# mirror://gentoo/${VIM_ORG_PATCHES}"
+
+S=${WORKDIR}/vim${VIM_VERSION/.}
+DESCRIPTION="Vi IMproved!"
+KEYWORDS="~alpha ~arm ~hppa ~mips ~ppc ~sparc ~x86"
+PROVIDE="virtual/editor"
+DEPEND="${DEPEND}
+ ~app-editors/vim-core-${PV}"