summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-08-28 08:35:45 +0000
committerTim Harder <radhermit@gentoo.org>2012-08-28 08:35:45 +0000
commitcd5dbd009633668800ddf7172ea15472c6ac8b83 (patch)
tree5a9a8c3edf585aab41a0fc2ef42fb565ef283286 /app-editors/xvile
parentRemove old. (diff)
downloadgentoo-2-cd5dbd009633668800ddf7172ea15472c6ac8b83.tar.gz
gentoo-2-cd5dbd009633668800ddf7172ea15472c6ac8b83.tar.bz2
gentoo-2-cd5dbd009633668800ddf7172ea15472c6ac8b83.zip
Version bump.
(Portage version: 2.2.0_alpha123/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/xvile')
-rw-r--r--app-editors/xvile/ChangeLog8
-rw-r--r--app-editors/xvile/files/vile-9.8h-flex.patch30
-rw-r--r--app-editors/xvile/xvile-9.8h.ebuild48
3 files changed, 85 insertions, 1 deletions
diff --git a/app-editors/xvile/ChangeLog b/app-editors/xvile/ChangeLog
index 87c6d332717a..68ed20716ca9 100644
--- a/app-editors/xvile/ChangeLog
+++ b/app-editors/xvile/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/xvile
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xvile/ChangeLog,v 1.31 2012/08/28 08:29:00 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xvile/ChangeLog,v 1.32 2012/08/28 08:35:45 radhermit Exp $
+
+*xvile-9.8h (28 Aug 2012)
+
+ 28 Aug 2012; Tim Harder <radhermit@gentoo.org> +xvile-9.8h.ebuild,
+ +files/vile-9.8h-flex.patch:
+ Version bump.
28 Aug 2012; Tim Harder <radhermit@gentoo.org> -xvile-9.4d.ebuild:
Remove old.
diff --git a/app-editors/xvile/files/vile-9.8h-flex.patch b/app-editors/xvile/files/vile-9.8h-flex.patch
new file mode 100644
index 000000000000..bb1c1c301110
--- /dev/null
+++ b/app-editors/xvile/files/vile-9.8h-flex.patch
@@ -0,0 +1,30 @@
+--- vile-9.8h/filters/filters.h
++++ vile-9.8h/filters/filters.h
+@@ -200,27 +200,6 @@
+ #endif
+ #endif /* __GNUC__ */
+
+-/*
+- * 2003/5/20 - "new" flex 2.5.31:
+- * workaround for "developers" who don't use compiler-warnings...
+- * perhaps by the time "new" flex merits the term "beta", they'll fix this:
+- */
+-#if defined(FLEX_BETA)
+-extern FILE *yyget_in (void);
+-extern FILE *yyget_out (void);
+-extern char *yyget_text (void);
+-extern int yyget_debug (void);
+-extern int yyget_leng (void);
+-extern int yyget_lineno (void);
+-extern int yylex_destroy (void);
+-extern void yyset_debug (int bdebug);
+-extern void yyset_in (FILE * in_str);
+-extern void yyset_lineno (int line_number);
+-extern void yyset_out (FILE * out_str);
+-/* there's also warnings for unused 'yyunput()', but I don't see a fix */
+-/* flex's skeleton includes <unistd.h> - no particular reason apparent */
+-#endif
+-
+ #define YY_NO_INPUT 1 /* get rid of 'input()' function */
+
+ /*
diff --git a/app-editors/xvile/xvile-9.8h.ebuild b/app-editors/xvile/xvile-9.8h.ebuild
new file mode 100644
index 000000000000..634bd2e557df
--- /dev/null
+++ b/app-editors/xvile/xvile-9.8h.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xvile/xvile-9.8h.ebuild,v 1.1 2012/08/28 08:35:45 radhermit Exp $
+
+EAPI="4"
+
+inherit eutils
+
+MY_P="${PN/x/}-${PV}"
+DESCRIPTION="VI Like Emacs -- yet another full-featured vi clone"
+HOMEPAGE="http://invisible-island.net/vile/"
+SRC_URI="ftp://invisible-island.net/vile/current/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="perl"
+
+RDEPEND="perl? ( dev-lang/perl )
+ =app-editors/vile-${PV}
+ >=x11-libs/libX11-1.0.0
+ >=x11-libs/libXt-1.0.0
+ >=x11-libs/libICE-1.0.0
+ >=x11-libs/libSM-1.0.0
+ >=x11-libs/libXaw-1.0.1
+ >=x11-libs/libXpm-3.5.4.2
+ >=x11-proto/xproto-7.0.4"
+DEPEND="${RDEPEND}
+ sys-devel/flex"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${MY_P}-flex.patch
+}
+
+src_configure() {
+ econf \
+ --with-ncurses \
+ --with-x \
+ $(use_with perl)
+}
+
+src_install() {
+ dobin xvile
+ dodoc CHANGES* README doc/*.doc
+ dohtml doc/*.html
+}