summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-05-28 15:41:04 +0000
committerMike Frysinger <vapier@gentoo.org>2004-05-28 15:41:04 +0000
commit05554055fef72aa90b009568a2082f6e55b7c10e (patch)
tree168c5ec2e07bb7721bd80b5446f565e9dd5ba577 /app-editors
parentUpstream requested minor changes (Manifest recommit) (diff)
downloadgentoo-2-05554055fef72aa90b009568a2082f6e55b7c10e.tar.gz
gentoo-2-05554055fef72aa90b009568a2082f6e55b7c10e.tar.bz2
gentoo-2-05554055fef72aa90b009568a2082f6e55b7c10e.zip
you fools need to learn how to inherit eutils for epatch
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/emacs/emacs-18.59.ebuild9
-rw-r--r--app-editors/jedit/jedit-4.2_pre12.ebuild9
2 files changed, 12 insertions, 6 deletions
diff --git a/app-editors/emacs/emacs-18.59.ebuild b/app-editors/emacs/emacs-18.59.ebuild
index de31af6fcf4d..cc3a234d076e 100644
--- a/app-editors/emacs/emacs-18.59.ebuild
+++ b/app-editors/emacs/emacs-18.59.ebuild
@@ -1,16 +1,19 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-18.59.ebuild,v 1.1 2004/05/13 15:27:43 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-18.59.ebuild,v 1.2 2004/05/28 15:40:59 vapier Exp $
+
+inherit eutils
DESCRIPTION="The extensible self-documenting text editor"
+HOMEPAGE="http://www.gnu.org/software/emacs/"
SRC_URI="ftp://ftp.gnu.org/old-gnu/emacs/${P}.tar.gz
ftp://ftp.splode.com/pub/users/friedman/patches/${P}-linux22x-elf-glibc2.diff.gz"
-HOMEPAGE="http://www.gnu.org/software/emacs/"
+LICENSE="GPL-1"
SLOT="1"
KEYWORDS="~x86"
-LICENSE="GPL-1"
IUSE="X"
+
DEPEND="sys-libs/ncurses
X? ( virtual/x11 )"
PROVIDE="virtual/editor"
diff --git a/app-editors/jedit/jedit-4.2_pre12.ebuild b/app-editors/jedit/jedit-4.2_pre12.ebuild
index 3a4bb91deac6..f8986653aba4 100644
--- a/app-editors/jedit/jedit-4.2_pre12.ebuild
+++ b/app-editors/jedit/jedit-4.2_pre12.ebuild
@@ -1,15 +1,18 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/jedit-4.2_pre12.ebuild,v 1.1 2004/05/03 03:06:04 anti Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/jedit-4.2_pre12.ebuild,v 1.2 2004/05/28 15:40:59 vapier Exp $
+
+inherit eutils
MY_PV="42pre12"
DESCRIPTION="Programmer's editor written in Java"
-HOMEPAGE="http://www.jedit.org"
+HOMEPAGE="http://www.jedit.org/"
SRC_URI="mirror://sourceforge/jedit/jedit${MY_PV}source.tar.gz"
+
LICENSE="GPL-2"
-KEYWORDS="~x86 ~sparc ~ppc ~amd64"
SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc ~amd64"
IUSE="jikes"
RDEPEND=">=virtual/jdk-1.3"