summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-03-19 06:46:42 +0000
committerTim Harder <radhermit@gentoo.org>2012-03-19 06:46:42 +0000
commit13c491d10e77e4dea1beb1638fe31181c32c1c38 (patch)
tree7efbb0a230f302be54c3d61428b8d82af061a340 /app-editors
parentVersion bump. (diff)
downloadgentoo-2-13c491d10e77e4dea1beb1638fe31181c32c1c38.tar.gz
gentoo-2-13c491d10e77e4dea1beb1638fe31181c32c1c38.tar.bz2
gentoo-2-13c491d10e77e4dea1beb1638fe31181c32c1c38.zip
Version bump.
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/xvile/ChangeLog9
-rw-r--r--app-editors/xvile/xvile-9.8g.ebuild44
2 files changed, 51 insertions, 2 deletions
diff --git a/app-editors/xvile/ChangeLog b/app-editors/xvile/ChangeLog
index c0ee233ecff1..0aa622011416 100644
--- a/app-editors/xvile/ChangeLog
+++ b/app-editors/xvile/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/xvile
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xvile/ChangeLog,v 1.24 2011/12/13 22:07:53 radhermit Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xvile/ChangeLog,v 1.25 2012/03/19 06:46:42 radhermit Exp $
+
+*xvile-9.8g (19 Mar 2012)
+
+ 19 Mar 2012; Tim Harder <radhermit@gentoo.org> +xvile-9.8g.ebuild:
+ Version bump.
13 Dec 2011; Tim Harder <radhermit@gentoo.org> xvile-9.8e.ebuild:
Remove unnecessary eutils usage.
diff --git a/app-editors/xvile/xvile-9.8g.ebuild b/app-editors/xvile/xvile-9.8g.ebuild
new file mode 100644
index 000000000000..4b9efa89e40b
--- /dev/null
+++ b/app-editors/xvile/xvile-9.8g.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xvile/xvile-9.8g.ebuild,v 1.1 2012/03/19 06:46:42 radhermit Exp $
+
+EAPI="4"
+
+inherit versionator
+
+MY_P="${PN/x/}-${PV}"
+DESCRIPTION="VI Like Emacs -- yet another full-featured vi clone"
+HOMEPAGE="http://invisible-island.net/vile/"
+SRC_URI="ftp://invisible-island.net/vile/current/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="perl"
+
+RDEPEND="perl? ( dev-lang/perl )
+ =app-editors/vile-${PV}
+ >=x11-libs/libX11-1.0.0
+ >=x11-libs/libXt-1.0.0
+ >=x11-libs/libICE-1.0.0
+ >=x11-libs/libSM-1.0.0
+ >=x11-libs/libXaw-1.0.1
+ >=x11-libs/libXpm-3.5.4.2
+ >=x11-proto/xproto-7.0.4"
+DEPEND="${RDEPEND}
+ sys-devel/flex"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ econf \
+ --with-ncurses \
+ --with-x \
+ $(use_with perl)
+}
+
+src_install() {
+ dobin xvile
+ dodoc CHANGES* README doc/*.doc
+ dohtml doc/*.html
+}