summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2010-06-23 19:14:16 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2010-06-23 19:14:16 +0000
commit28896fd536e5a961efd052a0d839a5672bbeeb38 (patch)
treec88c4920b670afb7ebe301e35968ee67cb6c35a9 /app-editors
parentMissing libpanelapplet-2.0 rdep wrt #320117 by Diego E. Pettenò. (diff)
downloadgentoo-2-28896fd536e5a961efd052a0d839a5672bbeeb38.tar.gz
gentoo-2-28896fd536e5a961efd052a0d839a5672bbeeb38.tar.bz2
gentoo-2-28896fd536e5a961efd052a0d839a5672bbeeb38.zip
Version bump.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/scite/ChangeLog8
-rw-r--r--app-editors/scite/files/scite-2.12-install.patch16
-rw-r--r--app-editors/scite/files/scite-2.12-no-lua.patch16
-rw-r--r--app-editors/scite/scite-2.12.ebuild82
4 files changed, 121 insertions, 1 deletions
diff --git a/app-editors/scite/ChangeLog b/app-editors/scite/ChangeLog
index 14f76182a0fb..0bdd2bf65127 100644
--- a/app-editors/scite/ChangeLog
+++ b/app-editors/scite/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/scite
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/ChangeLog,v 1.96 2010/05/19 18:31:29 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/ChangeLog,v 1.97 2010/06/23 19:14:16 nelchael Exp $
+
+*scite-2.12 (23 Jun 2010)
+
+ 23 Jun 2010; Krzysztof Pawlik <nelchael@gentoo.org> +scite-2.12.ebuild,
+ +files/scite-2.12-install.patch, +files/scite-2.12-no-lua.patch:
+ Version bump.
19 May 2010; Krzysztof Pawlik <nelchael@gentoo.org> -scite-1.78.ebuild,
-files/scite-1.78-install.patch, -files/scite-1.78-no-lua.patch,
diff --git a/app-editors/scite/files/scite-2.12-install.patch b/app-editors/scite/files/scite-2.12-install.patch
new file mode 100644
index 000000000000..ccce6fe145f1
--- /dev/null
+++ b/app-editors/scite/files/scite-2.12-install.patch
@@ -0,0 +1,16 @@
+diff -Nru vanilla//scite/gtk/makefile patched//scite/gtk/makefile
+--- vanilla//scite/gtk/makefile 2010-06-23 18:04:42.631333431 +0100
++++ patched//scite/gtk/makefile 2010-06-23 18:06:11.150336242 +0100
+@@ -107,8 +107,10 @@
+ done
+
+ ifdef gnomeprefix
+- $(INSTALL) -m 755 -D SciTE.desktop $(DESTDIR)$(datadir)/applications/SciTE.desktop
+- $(INSTALL) -m 644 -D Sci48M.png $(DESTDIR)$(pixmapdir)/Sci48M.png
++ $(INSTALL) -m 755 -d $(DESTDIR)$(datadir)/applications/
++ $(INSTALL) -m 755 SciTE.desktop $(DESTDIR)$(datadir)/applications/
++ $(INSTALL) -m 755 -d $(DESTDIR)$(pixmapdir)/
++ $(INSTALL) -m 644 Sci48M.png $(DESTDIR)$(pixmapdir)/Sci48M.png
+ endif
+
+ uninstall:
diff --git a/app-editors/scite/files/scite-2.12-no-lua.patch b/app-editors/scite/files/scite-2.12-no-lua.patch
new file mode 100644
index 000000000000..106c2453aa44
--- /dev/null
+++ b/app-editors/scite/files/scite-2.12-no-lua.patch
@@ -0,0 +1,16 @@
+diff -Nru vanilla//scite/src/SciTEProps.cxx patched//scite/src/SciTEProps.cxx
+--- vanilla//scite/src/SciTEProps.cxx 2010-06-23 18:04:42.639336085 +0100
++++ patched//scite/src/SciTEProps.cxx 2010-06-23 18:07:00.606351119 +0100
+@@ -1532,10 +1532,12 @@
+
+ // return the int value of the command name passed in.
+ int SciTEBase::GetMenuCommandAsInt(SString commandName) {
++#ifndef NO_LUA
+ int i = IFaceTable::FindConstant(commandName.c_str());
+ if (i != -1) {
+ return IFaceTable::constants[i].value;
+ }
++#endif
+ // Otherwise we might have entered a number as command to access a "SCI_" command
+ return commandName.value();
+ }
diff --git a/app-editors/scite/scite-2.12.ebuild b/app-editors/scite/scite-2.12.ebuild
new file mode 100644
index 000000000000..c0e13d18cc3f
--- /dev/null
+++ b/app-editors/scite/scite-2.12.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/scite-2.12.ebuild,v 1.1 2010/06/23 19:14:16 nelchael Exp $
+
+inherit toolchain-funcs eutils
+
+MY_PV=${PV//./}
+DESCRIPTION="A very powerful editor for programmers"
+HOMEPAGE="http://www.scintilla.org/SciTE.html"
+SRC_URI="mirror://sourceforge/scintilla/${PN}${MY_PV}.tgz"
+
+LICENSE="Scintilla"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="lua"
+
+RDEPEND=">=x11-libs/gtk+-2
+ lua? ( >=dev-lang/lua-5 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=sys-apps/sed-4"
+
+S="${WORKDIR}/${PN}/gtk"
+
+src_unpack() {
+ unpack ${A}
+ cd "${WORKDIR}/scintilla/gtk"
+ sed -i makefile \
+ -e "s#^CXXFLAGS=#CXXFLAGS=${CXXFLAGS} #" \
+ -e "s#^\(CXXFLAGS=.*\)-Os#\1#" \
+ -e "s#^CC =\(.*\)#CC = $(tc-getCXX)#" \
+ -e "s#-Os##" \
+ || die "error patching makefile"
+
+ cd "${WORKDIR}/scite/gtk"
+ sed -i makefile \
+ -e "s#-rdynamic#-rdynamic ${LDFLAGS}#" \
+ || die "error patching makefile"
+
+ cd "${S}"
+ sed -i makefile \
+ -e 's#usr/local#usr#g' \
+ -e 's#/gnome/apps/Applications#/applications#' \
+ -e "s#^CXXFLAGS=#CXXFLAGS=${CXXFLAGS} #" \
+ -e "s#^\(CXXFLAGS=.*\)-Os#\1#" \
+ -e "s#^CC =\(.*\)#CC = $(tc-getCXX)#" \
+ -e 's#${D}##' \
+ -e 's#-g root#-g 0#' \
+ -e "s#-Os##" \
+ || die "error patching makefile"
+ cd "${WORKDIR}"
+ epatch "${FILESDIR}/${PN}-2.12-install.patch"
+ epatch "${FILESDIR}/${PN}-2.12-no-lua.patch"
+}
+
+src_compile() {
+ make -C ../../scintilla/gtk || die "prep make failed"
+ if use lua; then
+ emake || die "make failed"
+ else
+ emake NO_LUA=1 || die "make failed"
+ fi
+}
+
+src_install() {
+ dodir /usr/bin
+ dodir /usr/share/{pixmaps,applications}
+
+ make prefix="${D}/usr" install || die
+
+ # we have to keep this because otherwise it'll break upgrading
+ mv "${D}/usr/bin/SciTE" "${D}/usr/bin/scite"
+ dosym /usr/bin/scite /usr/bin/SciTE
+
+ # replace .desktop file with our own working version
+ insinto /usr/share/applications
+ rm -f "${D}/usr/share/applications/SciTE.desktop"
+ doins "${FILESDIR}/scite.desktop"
+
+ doman ../doc/scite.1
+ dodoc ../README
+}