summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2015-01-17 01:32:26 +0000
committerTim Harder <radhermit@gentoo.org>2015-01-17 01:32:26 +0000
commit316faa019dbaadf75d678365cc33ab314a512271 (patch)
treee92a21f49ba34d4a334cfdf42a5d306b99ce793c /app-editors
parentVersion bump. (diff)
downloadgentoo-2-316faa019dbaadf75d678365cc33ab314a512271.tar.gz
gentoo-2-316faa019dbaadf75d678365cc33ab314a512271.tar.bz2
gentoo-2-316faa019dbaadf75d678365cc33ab314a512271.zip
Version bump.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/hteditor/ChangeLog9
-rw-r--r--app-editors/hteditor/hteditor-2.1.0.ebuild49
2 files changed, 56 insertions, 2 deletions
diff --git a/app-editors/hteditor/ChangeLog b/app-editors/hteditor/ChangeLog
index 8fc4e59b268f..8337f514b140 100644
--- a/app-editors/hteditor/ChangeLog
+++ b/app-editors/hteditor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/hteditor
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/hteditor/ChangeLog,v 1.70 2014/10/08 01:57:25 radhermit Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/hteditor/ChangeLog,v 1.71 2015/01/17 01:32:26 radhermit Exp $
+
+*hteditor-2.1.0 (17 Jan 2015)
+
+ 17 Jan 2015; Tim Harder <radhermit@gentoo.org> +hteditor-2.1.0.ebuild:
+ Version bump.
08 Oct 2014; Tim Harder <radhermit@gentoo.org> -hteditor-2.0.20.ebuild,
-hteditor-2.0.21.ebuild:
diff --git a/app-editors/hteditor/hteditor-2.1.0.ebuild b/app-editors/hteditor/hteditor-2.1.0.ebuild
new file mode 100644
index 000000000000..a53a00962cee
--- /dev/null
+++ b/app-editors/hteditor/hteditor-2.1.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/hteditor/hteditor-2.1.0.ebuild,v 1.1 2015/01/17 01:32:26 radhermit Exp $
+
+EAPI=5
+
+inherit toolchain-funcs
+
+MY_P=${P/editor}
+
+DESCRIPTION="A file viewer, editor and analyzer for text, binary, and executable files"
+HOMEPAGE="http://hte.sourceforge.net/ https://github.com/sebastianbiallas/ht/"
+SRC_URI="mirror://sourceforge/hte/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="X"
+
+RDEPEND="sys-libs/ncurses
+ X? ( x11-libs/libX11 )
+ >=dev-libs/lzo-2"
+DEPEND="${RDEPEND}
+ virtual/yacc
+ sys-devel/flex"
+
+DOCS=( AUTHORS ChangeLog KNOWNBUGS README TODO )
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ econf \
+ $(use_enable X x11-textmode) \
+ --enable-maintainermode
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)" CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
+}
+
+src_install() {
+ #For prefix
+ chmod u+x "${S}/install-sh"
+
+ default
+
+ dohtml doc/*.html
+ doinfo doc/*.info
+}