summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-04-17 04:16:21 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-04-17 04:16:21 +0000
commit318cc92f3679821f3c71c702c0c3e4fb65bb67fb (patch)
tree9889a3ff38b4d80d139abfcf0b50bbe036545ee1 /app-editors
parentWhen java-config is ran it places an invalid environmental variable within /e... (diff)
downloadgentoo-2-318cc92f3679821f3c71c702c0c3e4fb65bb67fb.tar.gz
gentoo-2-318cc92f3679821f3c71c702c0c3e4fb65bb67fb.tar.bz2
gentoo-2-318cc92f3679821f3c71c702c0c3e4fb65bb67fb.zip
Includes SANDBOX_DISABLED="1" (quick and dirty fix) to prevent xemacs segfaults.
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/xemacs/ChangeLog10
-rw-r--r--app-editors/xemacs/files/digest-xemacs-21.4.6-r43
-rw-r--r--app-editors/xemacs/xemacs-21.4.6-r4.ebuild104
3 files changed, 116 insertions, 1 deletions
diff --git a/app-editors/xemacs/ChangeLog b/app-editors/xemacs/ChangeLog
index 2743becbc9ba..4dacf0783cb5 100644
--- a/app-editors/xemacs/ChangeLog
+++ b/app-editors/xemacs/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-editors/xemacs
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/ChangeLog,v 1.6 2002/04/16 05:21:16 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/ChangeLog,v 1.7 2002/04/17 04:16:21 mkennedy Exp $
+
+*xemasc-21.4.6-r4 (16 Apr 2002)
+
+ 16 Apr 2002: Matthew Kennedy <mkennedy@gentoo.org>
+ xemacs-21.4.6-r4.ebuild, files/digest-xemacs-21.4.6-r4, ChanegLog :
+
+ Includes SANDBOX_DISABLED="1" (quick and dirty fix) to prevent
+ xemacs segfaults.
*xemacs-21.4.6-r3 (15 Apr 2002)
diff --git a/app-editors/xemacs/files/digest-xemacs-21.4.6-r4 b/app-editors/xemacs/files/digest-xemacs-21.4.6-r4
new file mode 100644
index 000000000000..59f9f28f98be
--- /dev/null
+++ b/app-editors/xemacs/files/digest-xemacs-21.4.6-r4
@@ -0,0 +1,3 @@
+MD5 e27bf0aa5c332d8ee130633df7c2ca3e xemacs-21.4.6.tar.gz 10460867
+MD5 8ffd5903390fc49fd78c4e4517c0f111 efs-1.27-pkg.tar.gz 370061
+MD5 a4d511159174e4da1b20456a9c20eab5 xemacs-base-1.58-pkg.tar.gz 457041
diff --git a/app-editors/xemacs/xemacs-21.4.6-r4.ebuild b/app-editors/xemacs/xemacs-21.4.6-r4.ebuild
new file mode 100644
index 000000000000..46fc36928ab8
--- /dev/null
+++ b/app-editors/xemacs/xemacs-21.4.6-r4.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Geert Bevin <gbevin@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/xemacs-21.4.6-r4.ebuild,v 1.1 2002/04/17 04:16:21 mkennedy Exp $
+
+# this is just TEMPORARY until we can get to the core of the problem
+SANDBOX_DISABLED="1"
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="The ultimate emacs, IMO. This is a non-FSF but still free for use version of the biggest text editor ever created."
+EFS=1.27
+BASE=1.58
+SRC_URI="http://ftp.us.xemacs.org/ftp/pub/xemacs/xemacs-21.4/${P}.tar.gz
+ http://ftp.us.xemacs.org/ftp/pub/xemacs/packages/efs-${EFS}-pkg.tar.gz
+ http://ftp.us.xemacs.org/ftp/pub/xemacs/packages/xemacs-base-${BASE}-pkg.tar.gz"
+HOMEPAGE="http://www.xemacs.org"
+
+DEPEND="sys-libs/ncurses
+ >=sys-libs/db-3
+ nas? ( media-libs/nas )
+ esd? ( media-sound/esound )
+ motif? ( >=x11-libs/openmotif-2.1.30 )
+ X? ( virtual/x11
+ media-libs/libpng
+ media-libs/tiff
+ media-libs/jpeg
+ media-libs/compface )"
+
+PROVIDE="virtual/emacs"
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack ${P}.tar.gz
+ patch -p0 <${FILESDIR}/emodules.info-gentoo.patch
+}
+
+src_compile() {
+local myopts
+local soundopts
+
+ if [ "`use X`" ]
+ then
+ myopts="--with-x \
+ --with-jpeg \
+ --with-png \
+ --with-tiff \
+ --with-xface \
+ --with-menubars=lucid \
+ --with-scrollbars=lucid"
+
+ use motif \
+ && myopts="${myopts} --with-dialogs=motif --with-widgets=motif" \
+ || myopts="${myopts} --with-dialogs=lucid --with-widgets=lucid"
+ else
+ myopts="--without-x"
+ fi
+
+ use gpm \
+ && myopts="${myopts} --with-gpm" \
+ || myopts="${myopts} --without-gpm"
+
+ soundopts="native"
+ use nas \
+ && soundopts="$soundopts,nas"
+
+ use esd \
+ && soundopts="$soundopts,esd"
+
+ myopts="${myopts} --with-sound=$soundopts"
+
+ ./configure ${myopts} \
+ --with-database=gnudbm \
+ --prefix=/usr \
+ --with-ncurses \
+ --with-pop \
+ --without-dragndrop \
+ --with-xpm \
+ --with-gif=no \
+ --with-site-lisp=yes \
+ --package-path=/usr/lib/xemacs/xemacs-packages/ \
+ --with-msw=no \
+ || die
+
+ emake || die
+}
+
+src_install() {
+ make prefix="${D}/usr" \
+ mandir="${D}/usr/share/man/man1" \
+ infodir="${D}/usr/share/info" \
+ install || die
+
+ # Install the two packages
+ dodir /usr/lib/xemacs/xemacs-packages/
+ cd "${D}/usr/lib/xemacs/xemacs-packages/"
+ unpack "efs-${EFS}-pkg.tar.gz"
+ unpack "xemacs-base-${BASE}-pkg.tar.gz"
+
+ #remove extraneous files
+ cd "${D}/usr/share/info"
+ rm -f dir info.info texinfo* termcap*
+ cd "${S}"
+ dodoc BUGS CHANGES-release COPYING GETTING* INSTALL ISSUES PROBLEMS README*
+}