summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-10-14 22:04:59 +0000
committerUlrich Müller <ulm@gentoo.org>2009-10-14 22:04:59 +0000
commit3fd625c0f27706a90dfbcecfbd1d32d1ecd9fcef (patch)
tree6c536155d8af6332ad7a705d1ea883a6a69dae63 /app-editors
parentversion bump from bug #166166 (diff)
downloadgentoo-2-3fd625c0f27706a90dfbcecfbd1d32d1ecd9fcef.tar.gz
gentoo-2-3fd625c0f27706a90dfbcecfbd1d32d1ecd9fcef.tar.bz2
gentoo-2-3fd625c0f27706a90dfbcecfbd1d32d1ecd9fcef.zip
Version bump.
(Portage version: 2.2_rc44/cvs/Linux i686)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/jasspa-microemacs/ChangeLog10
-rw-r--r--app-editors/jasspa-microemacs/files/20091011-ncurses.patch15
-rw-r--r--app-editors/jasspa-microemacs/jasspa-microemacs-20091011.ebuild75
3 files changed, 98 insertions, 2 deletions
diff --git a/app-editors/jasspa-microemacs/ChangeLog b/app-editors/jasspa-microemacs/ChangeLog
index 25c611a98f26..35a8a6561d95 100644
--- a/app-editors/jasspa-microemacs/ChangeLog
+++ b/app-editors/jasspa-microemacs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/jasspa-microemacs
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jasspa-microemacs/ChangeLog,v 1.35 2009/04/11 13:27:49 ulm Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jasspa-microemacs/ChangeLog,v 1.36 2009/10/14 22:04:59 ulm Exp $
+
+*jasspa-microemacs-20091011 (14 Oct 2009)
+
+ 14 Oct 2009; Ulrich Mueller <ulm@gentoo.org>
+ +files/20091011-ncurses.patch, +jasspa-microemacs-20091011.ebuild:
+ Version bump.
11 Apr 2009; Ulrich Mueller <ulm@gentoo.org>
files/jasspa-microemacs.desktop:
diff --git a/app-editors/jasspa-microemacs/files/20091011-ncurses.patch b/app-editors/jasspa-microemacs/files/20091011-ncurses.patch
new file mode 100644
index 000000000000..92a2885895b1
--- /dev/null
+++ b/app-editors/jasspa-microemacs/files/20091011-ncurses.patch
@@ -0,0 +1,15 @@
+--- me091011-orig/src/linux26.gmk
++++ me091011/src/linux26.gmk
+@@ -66,12 +66,7 @@
+ # accomplish this try to compile test.c and see if it can link termcap. For
+ # Linux 2.6 then preference would appear to be "ncurses" rather than "termcap".
+ #
+-test = $(shell echo "\#include <stdio.h>" > _t.c ; echo "main() { printf(\"HW\n\"); }" >> _t.c ; $(LD) $(LDFLAGS) -o /dev/null -lncurses _t.c 2>&1 ; rm -f _t.c)
+-ifneq "$(strip $(test))" ""
+-CONSOLE_LIBS = -ltermcap
+-else
+ CONSOLE_LIBS = -lncurses
+-endif
+ #
+ # Rules
+ .SUFFIXES: .c .oc .ow .ob .on .ov .oe .odc .odw .odb .odn .odv .ode
diff --git a/app-editors/jasspa-microemacs/jasspa-microemacs-20091011.ebuild b/app-editors/jasspa-microemacs/jasspa-microemacs-20091011.ebuild
new file mode 100644
index 000000000000..4a412357cd39
--- /dev/null
+++ b/app-editors/jasspa-microemacs/jasspa-microemacs-20091011.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jasspa-microemacs/jasspa-microemacs-20091011.ebuild,v 1.1 2009/10/14 22:04:59 ulm Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Jasspa Microemacs"
+HOMEPAGE="http://www.jasspa.com/"
+SRC_URI="http://www.jasspa.com/release_20090909/jasspa-mesrc-${PV}.tar.gz
+ !nanoemacs? (
+ http://www.jasspa.com/release_20090909/jasspa-memacros-${PV}.tar.gz
+ http://www.jasspa.com/release_20090909/jasspa-mehtml-${PV}.tar.gz
+ http://www.jasspa.com/release_20060909/meicons-extra.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nanoemacs X xpm"
+
+RDEPEND="sys-libs/ncurses
+ X? ( x11-libs/libX11
+ xpm? ( x11-libs/libXpm ) )
+ nanoemacs? ( !app-editors/ne )"
+
+DEPEND="${RDEPEND}
+ X? ( x11-libs/libXt
+ x11-proto/xproto )"
+
+S="${WORKDIR}/me${PV:2}/src"
+
+src_unpack() {
+ unpack jasspa-mesrc-${PV}.tar.gz
+ if ! use nanoemacs; then
+ mkdir "${WORKDIR}/jasspa"
+ cd "${WORKDIR}/jasspa"
+ # everything except jasspa-mesrc
+ unpack ${A/jasspa-mesrc-${PV}.tar.gz/}
+ fi
+ cd "${S}"
+ epatch "${FILESDIR}/${PV}-ncurses.patch"
+
+ # allow for some variables to be passed to make
+ sed -i '/make/s/\$OPTIONS/& CC="$CC" COPTIMISE="$CFLAGS" STRIP=true/' \
+ build || die "sed failed"
+}
+
+src_compile() {
+ local loadpath="~/.jasspa:/usr/share/jasspa/site:/usr/share/jasspa"
+ local me="" type=c
+ use nanoemacs && me="-ne"
+ use X && type=cw
+ use xpm || export XPM_INCLUDE=. # prevent Xpm autodetection
+
+ CC="$(tc-getCC)" ./build ${me} -t ${type} -p "${loadpath}" \
+ || die "build failed"
+}
+
+src_install() {
+ local me=me type=c
+ use nanoemacs && me=ne
+ use X && type=cw
+ newbin ${me}${type} ${me} || die "newbin failed"
+
+ if ! use nanoemacs; then
+ keepdir /usr/share/jasspa/site
+ insinto /usr/share
+ doins -r "${WORKDIR}/jasspa"
+ if use X; then
+ insinto /usr/share/applications
+ doins "${FILESDIR}/${PN}.desktop"
+ fi
+ fi
+
+ dodoc ../faq.txt ../readme.txt ../change.log || die "dodoc failed"
+}