summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-03-01 07:42:26 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-03-01 07:42:26 +0000
commit52da763e658d53ebec3487a4247a3853ebf4f05d (patch)
tree69cac837e75e81e0361073648a1517d7f0ff47ed /app-editors
parentDon't block spice[smartcard] as libcacard is the real blocker and it doesn't ... (diff)
downloadgentoo-2-52da763e658d53ebec3487a4247a3853ebf4f05d.tar.gz
gentoo-2-52da763e658d53ebec3487a4247a3853ebf4f05d.tar.bz2
gentoo-2-52da763e658d53ebec3487a4247a3853ebf4f05d.zip
cleanup and fix building wrt bug 459654
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/elvis/ChangeLog8
-rw-r--r--app-editors/elvis/elvis-2.2.0-r4.ebuild36
2 files changed, 25 insertions, 19 deletions
diff --git a/app-editors/elvis/ChangeLog b/app-editors/elvis/ChangeLog
index 18fd1a4f4a0e..791ad10fc0ac 100644
--- a/app-editors/elvis/ChangeLog
+++ b/app-editors/elvis/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/elvis
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/elvis/ChangeLog,v 1.49 2012/09/09 17:10:12 armin76 Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/elvis/ChangeLog,v 1.50 2013/03/01 07:42:26 ssuominen Exp $
+
+ 01 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> elvis-2.2.0-r4.ebuild:
+ Move ./configure from src_compile() to src_configure(). Fix building with
+ sys-libs/ncurses[tinfo] wrt #459654 by Diego Elio Pettenò
09 Sep 2012; Raúl Porcel <armin76@gentoo.org> elvis-2.2.0-r3.ebuild,
elvis-2.2.0-r4.ebuild:
diff --git a/app-editors/elvis/elvis-2.2.0-r4.ebuild b/app-editors/elvis/elvis-2.2.0-r4.ebuild
index 186102f9c160..e5ce8e0efa46 100644
--- a/app-editors/elvis/elvis-2.2.0-r4.ebuild
+++ b/app-editors/elvis/elvis-2.2.0-r4.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/elvis/elvis-2.2.0-r4.ebuild,v 1.6 2012/09/09 17:10:12 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/elvis/elvis-2.2.0-r4.ebuild,v 1.7 2013/03/01 07:42:26 ssuominen Exp $
-EAPI="3"
-
-inherit eutils versionator
+EAPI=5
+inherit eutils versionator toolchain-funcs
MY_PV=$(replace_version_separator 2 '_')
@@ -17,31 +16,34 @@ SLOT="0"
KEYWORDS="amd64 ppc ppc64 x86 ~x86-interix ~ppc-macos ~x86-macos ~m68k-mint ~sparc-solaris"
IUSE="X"
-DEPEND=">=sys-libs/ncurses-5.2
+RDEPEND=">=sys-libs/ncurses-5.7-r7
X? ( >=x11-proto/xproto-7.0.4
>=x11-libs/libX11-1.0.0
>=x11-libs/libXt-1.0.0
>=x11-libs/libXpm-3.5.4.2
>=x11-libs/libXft-2.1.8.2 )
app-admin/eselect-vi"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
S=${WORKDIR}/${PN}-${MY_PV}
src_prepare() {
- epatch "${FILESDIR}"/ft2.3-symbol-collision-fix.patch \
- "${FILESDIR}"/${P}-glibc-2.10.patch
- epatch "${FILESDIR}"/${P}-interix.patch
+ epatch \
+ "${FILESDIR}"/ft2.3-symbol-collision-fix.patch \
+ "${FILESDIR}"/${P}-glibc-2.10.patch \
+ "${FILESDIR}"/${P}-interix.patch
}
-src_compile() {
+src_configure() {
./configure \
- --libs="-lncurses" \
+ --libs="$($(tc-getPKG_CONFIG) --libs ncurses)" \
--prefix="${EPREFIX}"/usr \
--bindir="${EPREFIX}"/usr/bin \
--datadir="${EPREFIX}"/usr/share/elvis \
- --docdir="${EPREFIX}"/usr/share/doc/"${PF}" \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
$(use_with X x) \
- || die "configure failed"
+ || die
# Some Makefile fixups (must happen after configure)
# Use our CFLAGS
@@ -62,19 +64,19 @@ src_install() {
dodir /usr/bin
dodir /usr/share/man/man1
dodir /usr/share/elvis
- dodir /usr/share/doc/"${PF}"
+ dodir /usr/share/doc/${PF}
dodir /etc
- make install \
+ emake install \
PREFIX="${ED}"/usr \
BINDIR="${ED}"/usr/bin \
DATADIR="${ED}"/usr/share/elvis \
- DOCDIR="${ED}"/usr/share/doc/"${PF}" || die 'make install failed'
+ DOCDIR="${ED}"/usr/share/doc/${PF}
# Install the man-pages
mv doc/elvis.man doc/elvis.1
mv doc/elvtags.man doc/elvtags.1
mv doc/ref.man doc/ref.1
- doman doc/*.1 || die 'doman failed'
+ doman doc/*.1
# Fixup some READMEs
sed -i -e "s,${ED},,g" "${ED}"/etc/elvis/README \