summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-03-16 10:23:30 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-03-16 10:23:30 +0000
commit6b29753db5dbfbb796a8116edac601d9e03aa8d3 (patch)
tree44f27facfa5448c3d05cb5200e736631fffb2fbe /app-editors
parentBump (diff)
downloadgentoo-2-6b29753db5dbfbb796a8116edac601d9e03aa8d3.tar.gz
gentoo-2-6b29753db5dbfbb796a8116edac601d9e03aa8d3.tar.bz2
gentoo-2-6b29753db5dbfbb796a8116edac601d9e03aa8d3.zip
Bump
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/tea/ChangeLog7
-rw-r--r--app-editors/tea/tea-32.0.0.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/app-editors/tea/ChangeLog b/app-editors/tea/ChangeLog
index 5aa1578fbc39..f4a19972d48e 100644
--- a/app-editors/tea/ChangeLog
+++ b/app-editors/tea/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/tea
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/ChangeLog,v 1.51 2012/01/21 22:08:26 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/ChangeLog,v 1.52 2012/03/16 10:23:30 patrick Exp $
+
+*tea-32.0.0 (16 Mar 2012)
+
+ 16 Mar 2012; Patrick Lauer <patrick@gentoo.org> +tea-32.0.0.ebuild:
+ Bump
*tea-31.2.0 (21 Jan 2012)
diff --git a/app-editors/tea/tea-32.0.0.ebuild b/app-editors/tea/tea-32.0.0.ebuild
new file mode 100644
index 000000000000..0b327089d8b9
--- /dev/null
+++ b/app-editors/tea/tea-32.0.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/tea-32.0.0.ebuild,v 1.1 2012/03/16 10:23:30 patrick Exp $
+
+EAPI=4
+inherit eutils qt4-r2
+
+DESCRIPTION="Small, lightweight Qt text editor"
+HOMEPAGE="http://tea-editor.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tea-editor/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86 ~x86-fbsd"
+IUSE="aspell hunspell"
+
+RDEPEND="sys-libs/zlib
+ x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ aspell? ( app-text/aspell )
+ hunspell? ( app-text/hunspell )"
+DEPEND="${RDEPEND}
+ hunspell? ( dev-util/pkgconfig )"
+
+src_configure() {
+ local myopts
+ if use aspell ; then
+ myopts="USE_ASPELL=true"
+ else
+ myopts="USE_ASPELL=false"
+ fi
+
+ if use hunspell ; then
+ myopts="${myopts} USE_HUNSPELL=true"
+ else
+ myopts="${myopts} USE_HUNSPELL=false"
+ fi
+
+ eqmake4 src.pro PREFIX="/usr/bin" ${myopts}
+}
+
+src_install() {
+ dobin bin/tea
+ dodoc AUTHORS ChangeLog NEWS NEWS-RU TODO
+ doicon icons/tea_icon_v2.png
+
+ make_desktop_entry tea Tea tea_icon_v2 Utility
+}