summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-04-02 14:21:08 +0000
committerMike Frysinger <vapier@gentoo.org>2008-04-02 14:21:08 +0000
commit6d9d3a96f5a8603e7a36e26abe1e97c0a62b4ee2 (patch)
tree150c24d1751691e2731bf8f1654f12190c2325bb /app-editors
parentfix security bug #213940 (diff)
downloadgentoo-2-6d9d3a96f5a8603e7a36e26abe1e97c0a62b4ee2.tar.gz
gentoo-2-6d9d3a96f5a8603e7a36e26abe1e97c0a62b4ee2.tar.bz2
gentoo-2-6d9d3a96f5a8603e7a36e26abe1e97c0a62b4ee2.zip
Version bump.
(Portage version: 2.2_pre5)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/nano/ChangeLog7
-rw-r--r--app-editors/nano/nano-2.1.1.ebuild75
2 files changed, 81 insertions, 1 deletions
diff --git a/app-editors/nano/ChangeLog b/app-editors/nano/ChangeLog
index c92075bb18e4..22e0931acb4d 100644
--- a/app-editors/nano/ChangeLog
+++ b/app-editors/nano/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/nano
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/ChangeLog,v 1.184 2008/03/29 20:15:07 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/ChangeLog,v 1.185 2008/04/02 14:21:08 vapier Exp $
+
+*nano-2.1.1 (02 Apr 2008)
+
+ 02 Apr 2008; Mike Frysinger <vapier@gentoo.org> +nano-2.1.1.ebuild:
+ Version bump.
29 Mar 2008; Mike Frysinger <vapier@gentoo.org> nano-2.1.0.ebuild:
Bind the color/multibuffer/nanorc options to USE=-minimal #214132 by John SJ
diff --git a/app-editors/nano/nano-2.1.1.ebuild b/app-editors/nano/nano-2.1.1.ebuild
new file mode 100644
index 000000000000..25911c5f93b0
--- /dev/null
+++ b/app-editors/nano/nano-2.1.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-2.1.1.ebuild,v 1.1 2008/04/02 14:21:08 vapier Exp $
+
+inherit eutils
+if [[ ${PV} == "9999" ]] ; then
+ ECVS_SERVER="savannah.gnu.org:/cvsroot/nano"
+ ECVS_MODULE="nano"
+ ECVS_AUTH="pserver"
+ ECVS_USER="anonymous"
+ inherit cvs
+else
+ MY_P=${PN}-${PV/_}
+ SRC_URI="http://www.nano-editor.org/dist/v${PV:0:3}/${MY_P}.tar.gz"
+fi
+
+DESCRIPTION="GNU GPL'd Pico clone with more functionality"
+HOMEPAGE="http://www.nano-editor.org/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="debug justify minimal ncurses nls slang spell unicode"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ nls? ( sys-devel/gettext )
+ !ncurses? ( slang? ( sys-libs/slang ) )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ if [[ ! -e configure ]] ; then
+ ./autogen.sh || die "autogen failed"
+ fi
+}
+
+src_compile() {
+ local myconf=""
+ use ncurses \
+ && myconf="--without-slang" \
+ || myconf="${myconf} $(use_with slang)"
+
+ econf \
+ --bindir=/bin \
+ $(use_enable !minimal color) \
+ $(use_enable !minimal multibuffer) \
+ $(use_enable !minimal nanorc) \
+ --disable-wrapping-as-root \
+ $(use_enable spell) \
+ $(use_enable justify) \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_enable unicode utf8) \
+ $(use_enable minimal tiny) \
+ ${myconf} \
+ || die "configure failed"
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc ChangeLog README doc/nanorc.sample AUTHORS BUGS NEWS TODO
+ dohtml *.html
+ insinto /etc
+ newins doc/nanorc.sample nanorc
+
+ dodir /usr/bin
+ dosym /bin/nano /usr/bin/nano
+}
+
+pkg_postinst() {
+ elog "More helpful info about nano, visit the GDP page:"
+ elog "http://www.gentoo.org/doc/en/nano-basics-guide.xml"
+}