summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2013-02-28 17:56:16 +0000
committerUlrich Müller <ulm@gentoo.org>2013-02-28 17:56:16 +0000
commit6ea1b86cc4764097a5014d3ca80ff8d87251b1e1 (patch)
tree0698526329be46e4a4eb5423192a7b7937bf966a /app-editors
parentBlock opensmtpd. (diff)
downloadgentoo-2-6ea1b86cc4764097a5014d3ca80ff8d87251b1e1.tar.gz
gentoo-2-6ea1b86cc4764097a5014d3ca80ff8d87251b1e1.tar.bz2
gentoo-2-6ea1b86cc4764097a5014d3ca80ff8d87251b1e1.zip
Fix build failure with separate tinfo library.
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key 9433907D693FB5B8!)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/teco/ChangeLog7
-rw-r--r--app-editors/teco/teco-1.00-r3.ebuild14
2 files changed, 14 insertions, 7 deletions
diff --git a/app-editors/teco/ChangeLog b/app-editors/teco/ChangeLog
index 2e2553c626ae..40f4f6019d94 100644
--- a/app-editors/teco/ChangeLog
+++ b/app-editors/teco/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-editors/teco
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/teco/ChangeLog,v 1.25 2012/12/27 17:30:11 ulm Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/teco/ChangeLog,v 1.26 2013/02/28 17:56:16 ulm Exp $
+
+ 28 Feb 2013; Ulrich Müller <ulm@gentoo.org> teco-1.00-r3.ebuild:
+ Fix build failure with separate tinfo library.
27 Dec 2012; Ulrich Müller <ulm@gentoo.org> teco-1.00-r3.ebuild:
Fix unpack, bug 448840.
diff --git a/app-editors/teco/teco-1.00-r3.ebuild b/app-editors/teco/teco-1.00-r3.ebuild
index 76b5aec8234e..ebbe8707af9a 100644
--- a/app-editors/teco/teco-1.00-r3.ebuild
+++ b/app-editors/teco/teco-1.00-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/teco/teco-1.00-r3.ebuild,v 1.13 2012/12/27 17:30:11 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/teco/teco-1.00-r3.ebuild,v 1.14 2013/02/28 17:56:16 ulm Exp $
EAPI=3
@@ -20,7 +20,8 @@ KEYWORDS="alpha ~amd64 ~ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solari
IUSE="doc"
RDEPEND="sys-libs/ncurses"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
S=${WORKDIR}
@@ -34,14 +35,17 @@ src_unpack() {
}
src_prepare() {
- sed -e 's:\$(CC):& $(LDFLAGS):;s:-ltermcap:-lncurses:' -i Makefile || die
+ local pkg_config=$("$(tc-getPKG_CONFIG)" --libs ncurses)
+ sed -i -e "s:\$(CC):& \$(LDFLAGS):;s:-ltermcap:${pkg_config}:" \
+ Makefile || die
# bug 103257
epatch "${FILESDIR}"/${PN}-double-free.diff
epatch "${FILESDIR}"/${PN}-gcc4.patch
}
src_compile() {
- append-flags -ansi -D_POSIX_SOURCE
+ append-flags -ansi
+ append-cppflags -D_POSIX_SOURCE
emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die
}