summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-12-07 02:02:32 +0000
committerMike Frysinger <vapier@gentoo.org>2005-12-07 02:02:32 +0000
commit77a7541743af6480c34fe8fb5f255570dfa157b1 (patch)
tree282f18b7e4baeeef7f93526b55c8f666813a57cd /app-editors
parentFixups for vim7 (diff)
downloadgentoo-2-77a7541743af6480c34fe8fb5f255570dfa157b1.tar.gz
gentoo-2-77a7541743af6480c34fe8fb5f255570dfa157b1.tar.bz2
gentoo-2-77a7541743af6480c34fe8fb5f255570dfa157b1.zip
some initial support for live cvs
(Portage version: 2.0.53)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/nano/nano-1.3.9.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/app-editors/nano/nano-1.3.9.ebuild b/app-editors/nano/nano-1.3.9.ebuild
index abb0a8c24ab1..51cc4e103303 100644
--- a/app-editors/nano/nano-1.3.9.ebuild
+++ b/app-editors/nano/nano-1.3.9.ebuild
@@ -1,7 +1,11 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-1.3.9.ebuild,v 1.1 2005/10/26 00:11:29 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-1.3.9.ebuild,v 1.2 2005/12/07 02:02:32 vapier Exp $
+#ECVS_SERVER="savannah.gnu.org:/cvsroot/nano"
+#ECVS_USER="anoncvs"
+#ECVS_MODULE="nano"
+#inherit cvs
inherit eutils
MY_P=${PN}-${PV/_}
@@ -20,6 +24,10 @@ DEPEND=">=sys-libs/ncurses-5.2
PROVIDE="virtual/editor"
src_compile() {
+ if [[ ! -e configure ]] ; then
+ ./autogen.sh || die "autogen failed"
+ fi
+
local myconf=""
use ncurses \
&& myconf="--without-slang" \