summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2010-06-27 02:51:52 +0000
committerRyan Hill <dirtyepic@gentoo.org>2010-06-27 02:51:52 +0000
commit7ba03ba687496f28bf203d6e4d32bf9f6f5229a2 (patch)
tree6d4b4ba95cb065ee45aad3f3065315dafc25de95 /app-editors
parent[app-misc/tmux-1.2] Changed the dep order for vim / gvim by Tiago's request -... (diff)
downloadgentoo-2-7ba03ba687496f28bf203d6e4d32bf9f6f5229a2.tar.gz
gentoo-2-7ba03ba687496f28bf203d6e4d32bf9f6f5229a2.tar.bz2
gentoo-2-7ba03ba687496f28bf203d6e4d32bf9f6f5229a2.zip
Version bump. Improved HTML/XML autoindent and autocomp. Bug fixes.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/editra/ChangeLog7
-rw-r--r--app-editors/editra/editra-0.5.72.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/app-editors/editra/ChangeLog b/app-editors/editra/ChangeLog
index c2effb358338..a7616e70f96a 100644
--- a/app-editors/editra/ChangeLog
+++ b/app-editors/editra/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/editra
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/editra/ChangeLog,v 1.14 2010/05/22 20:34:46 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/editra/ChangeLog,v 1.15 2010/06/27 02:51:52 dirtyepic Exp $
+
+*editra-0.5.72 (27 Jun 2010)
+
+ 27 Jun 2010; Ryan Hill <dirtyepic@gentoo.org> +editra-0.5.72.ebuild:
+ Version bump. Improved HTML/XML autoindent and autocomp. Bug fixes.
*editra-0.5.60 (22 May 2010)
diff --git a/app-editors/editra/editra-0.5.72.ebuild b/app-editors/editra/editra-0.5.72.ebuild
new file mode 100644
index 000000000000..64947ce822d8
--- /dev/null
+++ b/app-editors/editra/editra-0.5.72.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/editra/editra-0.5.72.ebuild,v 1.1 2010/06/27 02:51:52 dirtyepic Exp $
+
+EAPI=2
+SUPPORT_PYTHON_ABIS=1
+PYTHON_DEPEND="2:2.5"
+
+inherit distutils eutils fdo-mime python
+
+MY_PN=${PN/e/E}
+
+DESCRIPTION="Multi-platform text editor supporting over 50 programming languages."
+HOMEPAGE="http://editra.org http://pypi.python.org/pypi/Editra"
+SRC_URI="http://editra.org/uploads/src/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="wxWinLL-3.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="spell"
+
+DEPEND=">=dev-python/wxpython-2.8.9.2:2.8
+ >=dev-python/setuptools-0.6"
+# setuptools is RDEPEND because it's used by the runtime for installing plugins
+RDEPEND="${DEPEND}
+ spell? ( dev-python/pyenchant )"
+
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}"/${MY_PN}-${PV}
+
+src_compile() {
+ distutils_src_compile --no-clean # http://code.google.com/p/editra/issues/detail?id=481
+}
+
+src_install() {
+ distutils_src_install --no-clean
+ insinto /usr/share/pixmaps
+ doins "${S}"/pixmaps/editra.png
+ make_desktop_entry Editra Editra editra "Development;TextEditor"
+ dodoc FAQ THANKS
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+ fdo-mime_desktop_database_update
+}