summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-03-23 04:56:25 +0000
committerMike Frysinger <vapier@gentoo.org>2005-03-23 04:56:25 +0000
commit8e789330b789d09e42a90f025587fe4717be6a0c (patch)
treed3faf1a70b76e694dec6061c4d3f09c4b56003a6 /app-editors
parenttweak gen_usr_ldscript to handle more than 1 param at a time (diff)
downloadgentoo-2-8e789330b789d09e42a90f025587fe4717be6a0c.tar.gz
gentoo-2-8e789330b789d09e42a90f025587fe4717be6a0c.tar.bz2
gentoo-2-8e789330b789d09e42a90f025587fe4717be6a0c.zip
fix debug typo in source #86339
(Portage version: 2.0.51.19)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/nano/files/nano-1.3.6-debug-typo.patch15
-rw-r--r--app-editors/nano/nano-1.3.6.ebuild3
2 files changed, 17 insertions, 1 deletions
diff --git a/app-editors/nano/files/nano-1.3.6-debug-typo.patch b/app-editors/nano/files/nano-1.3.6-debug-typo.patch
new file mode 100644
index 000000000000..3d13327a55c1
--- /dev/null
+++ b/app-editors/nano/files/nano-1.3.6-debug-typo.patch
@@ -0,0 +1,15 @@
+Fix a simple typo when building with debug turned on.
+
+http://bugs.gentoo.org/show_bug.cgi?id=86339
+
+--- src/chars.c
++++ src/chars.c
+@@ -455,7 +455,7 @@
+ {
+ size_t pos_prev = pos;
+
+- assert(str != NULL && pos <= strlen(buf));
++ assert(buf != NULL && pos <= strlen(buf));
+
+ /* There is no library function to move backward one multibyte
+ * character. Here is the naive, O(pos) way to do it. */
diff --git a/app-editors/nano/nano-1.3.6.ebuild b/app-editors/nano/nano-1.3.6.ebuild
index 4fb49fa2c6ce..89041fdaf3bc 100644
--- a/app-editors/nano/nano-1.3.6.ebuild
+++ b/app-editors/nano/nano-1.3.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-1.3.6.ebuild,v 1.1 2005/03/22 06:22:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-1.3.6.ebuild,v 1.2 2005/03/23 04:56:25 vapier Exp $
inherit eutils
@@ -25,6 +25,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
use nomac && epatch "${FILESDIR}"/${P}-nomac.patch
+ epatch "${FILESDIR}"/${P}-debug-typo.patch
}
src_compile() {