summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2005-11-19 20:36:34 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2005-11-19 20:36:34 +0000
commit8f7e395fa7d07d8eb0124bca888a0c49fd674885 (patch)
treeb0d60695c238a1a9d33af225e62b6a015847e10e /app-editors
parentStable on SPARC wrt bug #112837. (diff)
downloadgentoo-2-8f7e395fa7d07d8eb0124bca888a0c49fd674885.tar.gz
gentoo-2-8f7e395fa7d07d8eb0124bca888a0c49fd674885.tar.bz2
gentoo-2-8f7e395fa7d07d8eb0124bca888a0c49fd674885.zip
Version bumping to newest version
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/mp/ChangeLog7
-rw-r--r--app-editors/mp/Manifest2
-rw-r--r--app-editors/mp/files/digest-mp-3.3.161
-rw-r--r--app-editors/mp/mp-3.3.16.ebuild62
4 files changed, 71 insertions, 1 deletions
diff --git a/app-editors/mp/ChangeLog b/app-editors/mp/ChangeLog
index 752d0a8ae59d..6de33e57b638 100644
--- a/app-editors/mp/ChangeLog
+++ b/app-editors/mp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/mp
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/ChangeLog,v 1.48 2005/11/19 19:58:04 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/ChangeLog,v 1.49 2005/11/19 20:36:34 compnerd Exp $
+
+*mp-3.3.16 (19 Nov 2005)
+
+ 19 Nov 2005; Saleem Abdulrasool <compnerd@gentoo.org> +mp-3.3.16.ebuild:
+ Version bump to newest upstream release
*mp-3.3.14-r1 (19 Nov 2005)
diff --git a/app-editors/mp/Manifest b/app-editors/mp/Manifest
index a7c7967ce886..19438fea2c06 100644
--- a/app-editors/mp/Manifest
+++ b/app-editors/mp/Manifest
@@ -3,6 +3,7 @@ MD5 0bc70f6cef8183401387b78185cb0682 files/digest-mp-3.3.12 61
MD5 0bc70f6cef8183401387b78185cb0682 files/digest-mp-3.3.12-r1 61
MD5 a3eed5e928a918715c8e92adea33279a files/digest-mp-3.3.14 61
MD5 a3eed5e928a918715c8e92adea33279a files/digest-mp-3.3.14-r1 61
+MD5 a435c4de791687194efa9b4641ba45c4 files/digest-mp-3.3.16 61
MD5 82dd8f227fdd5b56584b2adf5242a53b files/gentoo-synh-mp.patch-3.2.11 2027
MD5 f58c1b9239be39f8724f3a172f67c465 files/mp-3.3.9-fix-builtin-regex-warnings.diff 1353
MD5 9ba478d874ba2172b5e7a75d56748d41 files/regex-warnings.patch 2120
@@ -11,3 +12,4 @@ MD5 62003cdd33546404251ec486b56a1a26 mp-3.3.12-r1.ebuild 1298
MD5 b7e83987d6e55c189819f98dad5c11f8 mp-3.3.12.ebuild 1386
MD5 9b01ea518198f9497b54763c5d8635ce mp-3.3.14-r1.ebuild 1513
MD5 0019625b631e2ae00d973de13726302b mp-3.3.14.ebuild 1622
+MD5 008a52293dad1e8dfb9c6ae340f1490c mp-3.3.16.ebuild 1531
diff --git a/app-editors/mp/files/digest-mp-3.3.16 b/app-editors/mp/files/digest-mp-3.3.16
new file mode 100644
index 000000000000..86f4e48d322f
--- /dev/null
+++ b/app-editors/mp/files/digest-mp-3.3.16
@@ -0,0 +1 @@
+MD5 d806d578fb37e3e69b5c69af7965d49a mp-3.3.16.tar.gz 276885
diff --git a/app-editors/mp/mp-3.3.16.ebuild b/app-editors/mp/mp-3.3.16.ebuild
new file mode 100644
index 000000000000..5157ed24ffc9
--- /dev/null
+++ b/app-editors/mp/mp-3.3.16.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/mp-3.3.16.ebuild,v 1.1 2005/11/19 20:36:34 compnerd Exp $
+
+inherit eutils
+
+DESCRIPTION="Minimum Profit: A text editor for programmers"
+HOMEPAGE="http://www.triptico.com/software/mp.html"
+SRC_URI="http://www.triptico.com/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc-macos ~ppc64 ~sparc ~x86"
+IUSE="gtk ncurses nls pcre"
+
+RDEPEND="virtual/libc
+ ncurses? ( sys-libs/ncurses )
+ gtk? ( >=x11-libs/gtk+-2 >=x11-libs/pango-1.8.0 )
+ !gtk? ( sys-libs/ncurses )
+ nls? ( sys-devel/gettext )
+ pcre? ( dev-libs/libpcre )
+ dev-lang/perl"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ local myconf="--without-win32 --without-gtk1"
+
+ if use gtk ; then
+ ! use ncurses && myconf="${myconf} --without-curses"
+ else
+ myconf="${myconf} --without-gtk2"
+ fi
+
+ use nls || myconfig="${myconf} --without-i18n --without-gettext"
+ use pcre || myconf="${myconf} --without-pcre --with-included-regex"
+
+ sh config.sh ${myconf} || die "Configure failed"
+
+ echo ${CFLAGS} >> config.cflags
+ echo ${LDFLAGS} >> config.ldflags
+
+ emake || die "Compile Failed"
+}
+
+src_install() {
+ dobin mp || die "Install Failed"
+
+ use gtk && dosym mp ${DESTTREE}/bin/gmp
+
+ dodoc AUTHORS README Changelog mprc.sample
+ doman mp.1
+}
+
+pkg_postinst() {
+ if use gtk ; then
+ einfo
+ einfo "mp is symlinked to gmp! Use mp -tx to use text mode!"
+ einfo
+ epause 5
+ fi
+}