summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-20 15:50:55 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-20 15:50:55 +0000
commitabbba1ee16884a89e7d2a9d2faf934a33b3e5184 (patch)
tree5b6e027aabeaa266c248ae41773830a70d184084 /app-editors
parentCloses #10722 (diff)
downloadgentoo-2-abbba1ee16884a89e7d2a9d2faf934a33b3e5184.tar.gz
gentoo-2-abbba1ee16884a89e7d2a9d2faf934a33b3e5184.tar.bz2
gentoo-2-abbba1ee16884a89e7d2a9d2faf934a33b3e5184.zip
changed ./configure to econf and a few other cleanups
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/nano/files/newfile-gentoo.patch15
-rw-r--r--app-editors/nano/nano-1.0.9.ebuild26
2 files changed, 24 insertions, 17 deletions
diff --git a/app-editors/nano/files/newfile-gentoo.patch b/app-editors/nano/files/newfile-gentoo.patch
new file mode 100644
index 000000000000..c52c2ae1ade6
--- /dev/null
+++ b/app-editors/nano/files/newfile-gentoo.patch
@@ -0,0 +1,15 @@
+--- nano.c.orig 2002-11-20 10:37:52.000000000 -0500
++++ nano.c 2002-11-20 10:36:24.000000000 -0500
+@@ -2525,9 +2525,10 @@
+
+ /* Now we check to see if argv[optind] is non-null to determine if
+ we're dealing with a new file or not, not argc == 1... */
+- if (argv[optind] == NULL)
++ if (argv[optind] == NULL) {
+ new_file();
+- else
++ statusbar(_("Gentoo pwns j00"));
++ } else
+ open_file(filename, 0, 0);
+
+ if (startline > 0)
diff --git a/app-editors/nano/nano-1.0.9.ebuild b/app-editors/nano/nano-1.0.9.ebuild
index 07ccd47d5c4c..be31cecfe908 100644
--- a/app-editors/nano/nano-1.0.9.ebuild
+++ b/app-editors/nano/nano-1.0.9.ebuild
@@ -1,25 +1,23 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-1.0.9.ebuild,v 1.6 2002/10/23 19:23:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-1.0.9.ebuild,v 1.7 2002/11/20 15:50:55 vapier Exp $
-IUSE="nls build slang"
-
-S=${WORKDIR}/${P}
DESCRIPTION="clone of Pico with more functions in a smaller size"
SRC_URI="http://www.nano-editor.org/dist/v1.0/${P}.tar.gz"
HOMEPAGE="http://www.nano-editor.org/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc sparc64 alpha"
+IUSE="nls build slang"
+
DEPEND="virtual/glibc
>=sys-libs/ncurses-5.2
slang? ( >=sys-libs/slang-1.4.4-r1 )
nls? ( sys-devel/gettext )"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 ppc sparc sparc64 alpha"
-
src_compile() {
- local myconf
+ local myconf="--enable-extra"
use slang && myconf="${myconf} --with-slang"
use nls || myconf="${myconf} --disable-nls"
@@ -28,14 +26,8 @@ src_compile() {
myconf="${myconf} --disable-wrapping-as-root"
fi
- ./configure \
- --build=${CHOST} \
- --prefix=/usr \
- --enable-extra \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- ${myconf} || die "./configure failed"
-
+ econf ${myconf}
+ patch -p0 < ${FILESDIR}/newfile-gentoo.patch
emake || die
}