summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2002-01-23 23:37:56 +0000
committerMikael Hallendal <hallski@gentoo.org>2002-01-23 23:37:56 +0000
commitafcf7f973cccb149a19672b3a2156994a10a35ce (patch)
tree0d5b4379dcace2eef2163ef88c403970e9b1fdc0 /app-editors
parentv1.6.6 (diff)
downloadgentoo-2-afcf7f973cccb149a19672b3a2156994a10a35ce.tar.gz
gentoo-2-afcf7f973cccb149a19672b3a2156994a10a35ce.tar.bz2
gentoo-2-afcf7f973cccb149a19672b3a2156994a10a35ce.zip
fixed issue #109 with info dir-stuff, also updated to current ebuild standard
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/jed/files/digest-jed-0.99.14-r1 (renamed from app-editors/jed/files/digest-jed-0.99.14)0
-rw-r--r--app-editors/jed/files/jed.info.diff15
-rw-r--r--app-editors/jed/jed-0.99.14-r1.ebuild72
-rw-r--r--app-editors/jed/jed-0.99.14.ebuild51
4 files changed, 87 insertions, 51 deletions
diff --git a/app-editors/jed/files/digest-jed-0.99.14 b/app-editors/jed/files/digest-jed-0.99.14-r1
index 0ecd4a339e0e..0ecd4a339e0e 100644
--- a/app-editors/jed/files/digest-jed-0.99.14
+++ b/app-editors/jed/files/digest-jed-0.99.14-r1
diff --git a/app-editors/jed/files/jed.info.diff b/app-editors/jed/files/jed.info.diff
new file mode 100644
index 000000000000..2292be356020
--- /dev/null
+++ b/app-editors/jed/files/jed.info.diff
@@ -0,0 +1,15 @@
+--- jed.info.orig Thu Jan 24 00:25:56 2002
++++ jed.info Thu Jan 24 00:30:11 2002
+@@ -1,6 +1,12 @@
+ This is Info file jed.info, produced by Makeinfo-1.55 from the input
+ file jed.ti.
+
++INFO-DIR-SECTION Editors
++START-INFO-DIR-ENTRY
++* Jed: (jed). Console S-Lang-based editor.
++END-INFO-DIR-ENTRY
++
++
+ 
+ Indirect:
+ jed.1in: 83
diff --git a/app-editors/jed/jed-0.99.14-r1.ebuild b/app-editors/jed/jed-0.99.14-r1.ebuild
new file mode 100644
index 000000000000..2fc80bcd00a8
--- /dev/null
+++ b/app-editors/jed/jed-0.99.14-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Grant Goodyear <g2boojum@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jed/jed-0.99.14-r1.ebuild,v 1.1 2002/01/23 23:37:56 hallski Exp $
+
+P0=${PN}-B0.99-14
+S=${WORKDIR}/${P0}
+DESCRIPTION="Console S-Lang-based editor"
+SRC_URI="ftp://space.mit.edu/pub/davis/jed/v0.99/${P0}.tar.bz2"
+HOMEPAGE="http://space.mit.edu/~davis/jed/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/slang-1.3.11
+ X? ( virtual/x11 )
+ gpm? ( sys-libs/gpm )"
+
+src_compile() {
+ export JED_ROOT=/usr/share/jed
+
+ ./configure --host=${CHOST} \
+ --prefix=$JED_ROOT \
+ --bindir=/usr/bin \
+ --mandir=/usr/share/man
+ assert
+
+ if [ -n "`use gpm`" ] ; then
+ cd src
+ mv Makefile Makefile.orig
+ sed -e 's/#MOUSEFLAGS/MOUSEFLAGS/' \
+ -e 's/#MOUSELIB/MOUSELIB/' \
+ -e 's/#GPMMOUSEO/GPMMOUSEO/' \
+ -e 's/#OBJGPMMOUSEO/OBJGPMMOUSEO/' \
+ Makefile.orig > Makefile
+ cd ${S}
+ fi
+
+ make clean || die
+
+ emake || die
+
+ if [ -n "`use X`" ] ; then
+ emake xjed || die
+ fi
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ cd doc
+ cp README AUTHORS
+
+ cd ${S}
+ dodoc COPYING COPYRIGHT INSTALL INSTALL.unx README \
+ doc/AUTHORS doc/manual/jed.tex
+
+ cd ${S}/info
+ rm info.info
+ patch < ${FILESDIR}/jed.info.diff || die
+ cd ${S}
+
+ insinto /usr/share/info
+ doins info/*
+
+ insinto /etc
+ doins lib/jed.conf
+
+ cd ${D}
+ rm -rf usr/share/jed/info
+ # can't rm usr/share/jed/doc -- used internally by jed/xjed
+}
+
+
diff --git a/app-editors/jed/jed-0.99.14.ebuild b/app-editors/jed/jed-0.99.14.ebuild
deleted file mode 100644
index cb8d5acdd354..000000000000
--- a/app-editors/jed/jed-0.99.14.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Grant Goodyear <g2boojum@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jed/jed-0.99.14.ebuild,v 1.3 2001/11/10 02:54:28 hallski Exp $
-
-P0=${PN}-B0.99-14
-S=${WORKDIR}/${P0}
-DESCRIPTION="Console S-Lang-based editor"
-SRC_URI="ftp://space.mit.edu/pub/davis/jed/v0.99/${P0}.tar.bz2"
-HOMEPAGE="http://space.mit.edu/~davis/jed/"
-
-DEPEND="virtual/glibc
- >=sys-libs/slang-1.3.11
- X? ( virtual/x11 )
- gpm? ( sys-libs/gpm )"
-
-src_compile() {
-
- export JED_ROOT=/usr/share/jed
- try ./configure --prefix=$JED_ROOT --host=${CHOST} --bindir=/usr/bin --mandir=/usr/share/man
- if [ -n "`use gpm`" ] ; then
- cd src
- mv Makefile Makefile.orig
- sed -e 's/#MOUSEFLAGS/MOUSEFLAGS/' -e 's/#MOUSELIB/MOUSELIB/' -e 's/#GPMMOUSEO/GPMMOUSEO/' -e 's/#OBJGPMMOUSEO/OBJGPMMOUSEO/' Makefile.orig > Makefile
- cd ..
- fi
- try make clean
- try make
- if [ -n "`use X`" ] ; then
- try make xjed
- fi
-
-}
-
-src_install () {
-
- try make DESTDIR=${D} install
- cd doc
- cp README AUTHORS
- cd ..
- dodoc COPYING COPYRIGHT INSTALL INSTALL.unx README doc/AUTHORS doc/manual/jed.tex
- insinto /usr/share/info
- doins info/*
- insinto /etc
- doins lib/jed.conf
- cd ${D}
- rm -rf usr/share/jed/info
- # can't rm usr/share/jed/doc -- used internally by jed/xjed
-
-}
-