summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-07-12 20:03:35 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-07-12 20:03:35 +0000
commitb78a5a0806063b72cdc52e572a6392a1056a2249 (patch)
treed0951a47400c664b5ee3177bb1a1043fc86a74d6 /app-editors
parentInitial version. Closes #4110. (diff)
downloadgentoo-2-b78a5a0806063b72cdc52e572a6392a1056a2249.tar.gz
gentoo-2-b78a5a0806063b72cdc52e572a6392a1056a2249.tar.bz2
gentoo-2-b78a5a0806063b72cdc52e572a6392a1056a2249.zip
should have cvsupped first.
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/jedit/jedit-4.0.3-r1.ebuild27
1 files changed, 19 insertions, 8 deletions
diff --git a/app-editors/jedit/jedit-4.0.3-r1.ebuild b/app-editors/jedit/jedit-4.0.3-r1.ebuild
index 52c4a7a5193a..0be4a5ab359a 100644
--- a/app-editors/jedit/jedit-4.0.3-r1.ebuild
+++ b/app-editors/jedit/jedit-4.0.3-r1.ebuild
@@ -1,27 +1,38 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# Author: Maik Schreiber <bZ@iq-computing.de>
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/jedit-4.0.3-r1.ebuild,v 1.1 2002/07/12 16:30:43 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/jedit-4.0.3-r1.ebuild,v 1.2 2002/07/12 20:03:35 rphillips Exp $
S="${WORKDIR}/jEdit"
DESCRIPTION="Programmer's editor written in Java"
HOMEPAGE="http://www.jedit.org"
+SRC_URI="http://unc.dl.sourceforge.net/sourceforge/jedit/jedit403source.tar.gz"
LICENSE="GPL-2"
-DEPEND=">=dev-java/ant-1.4.1 >=dev-java/jikes-1.15"
+SLOT="0"
+KEYWORDS="*"
+
RDEPEND=">=virtual/jdk-1.3"
-SRC_URI="http://unc.dl.sourceforge.net/sourceforge/jedit/jedit403source.tar.gz"
+DEPEND="${RDEPEND}
+ >=dev-java/ant-1.4.1
+ jikes? ( >=dev-java/jikes-1.15 )"
src_compile() {
- einfo "Please ignore the following compiler warnings."
- einfo "Jikes is just too pedantic..."
- ant -Dbuild.compiler=jikes || die "compile problem"
+ local antflags
+
+ antflags=""
+ if [ `use jikes` ] ; then
+ einfo "Please ignore the following compiler warnings."
+ einfo "Jikes is just too pedantic..."
+ antflags="${antflags} -Dbuild.compiler=jikes"
+ fi
+
+ ant ${antflags} || die "compile problem"
}
src_install () {
mkdir -m 755 -p ${D}/usr/share/jedit
mkdir -m 755 ${D}/usr/bin
- cp -R jedit.jar jars macros doc modes properties startup ${D}/usr/share/jedit
+ cp -R jedit.jar jars doc macros modes properties startup ${D}/usr/share/jedit
cd ${D}/usr/share/jedit
chmod -R u+rw,ug-s,go+u,go-w \
jedit.jar jars macros modes properties startup