summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-05-24 22:18:35 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-05-24 22:18:35 +0000
commitda4f780f335e1f29a968b497c4584f563dfa1b8d (patch)
tree985e89a69b5dc6c2b267cea7e07da392bf1a73d3 /app-editors
parentfixed gcc 4.5 compilation bug #321323 (diff)
downloadgentoo-2-da4f780f335e1f29a968b497c4584f563dfa1b8d.tar.gz
gentoo-2-da4f780f335e1f29a968b497c4584f563dfa1b8d.tar.bz2
gentoo-2-da4f780f335e1f29a968b497c4584f563dfa1b8d.zip
Fix build with GCC 4.5 wrt bug #320377
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/mlview/ChangeLog6
-rw-r--r--app-editors/mlview/files/mlview-0.9.0-gcc45.patch15
-rw-r--r--app-editors/mlview/mlview-0.9.0.ebuild5
3 files changed, 23 insertions, 3 deletions
diff --git a/app-editors/mlview/ChangeLog b/app-editors/mlview/ChangeLog
index 3a7f017cbbda..cc82aab7f274 100644
--- a/app-editors/mlview/ChangeLog
+++ b/app-editors/mlview/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/mlview
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/mlview/ChangeLog,v 1.25 2010/03/27 08:37:57 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mlview/ChangeLog,v 1.26 2010/05/24 22:18:35 xarthisius Exp $
+
+ 24 May 2010; Kacper Kowalik <xarthisius.kk@gmail.com> mlview-0.9.0.ebuild,
+ +files/mlview-0.9.0-gcc45.patch:
+ Fix build with GCC 4.5 wrt bug #320377
*mlview-0.9.0 (27 Mar 2010)
diff --git a/app-editors/mlview/files/mlview-0.9.0-gcc45.patch b/app-editors/mlview/files/mlview-0.9.0-gcc45.patch
new file mode 100644
index 000000000000..55b922bcac04
--- /dev/null
+++ b/app-editors/mlview/files/mlview-0.9.0-gcc45.patch
@@ -0,0 +1,15 @@
+Fix building with gcc 4.5
+
+http://bugs.gentoo.org/show_bug.cgi?id=320377
+
+--- src/mlview-ustring.cc
++++ src/mlview-ustring.cc
+@@ -59,7 +59,7 @@
+ UString::~UString ()
+ {}
+
+-UString::UString&
++UString&
+ UString::operator= (const char *a_cstr)
+ {
+ if (!a_cstr)
diff --git a/app-editors/mlview/mlview-0.9.0.ebuild b/app-editors/mlview/mlview-0.9.0.ebuild
index 0873bf1c9211..592e7296bf14 100644
--- a/app-editors/mlview/mlview-0.9.0.ebuild
+++ b/app-editors/mlview/mlview-0.9.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/mlview/mlview-0.9.0.ebuild,v 1.1 2010/03/27 08:37:57 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mlview/mlview-0.9.0.ebuild,v 1.2 2010/05/24 22:18:35 xarthisius Exp $
EAPI=2
inherit eutils gnome2
@@ -41,7 +41,8 @@ pkg_setup() {
src_prepare() {
epatch "${FILESDIR}"/${P}-desktop.patch \
- "${FILESDIR}"/${P}-gcc44.patch
+ "${FILESDIR}"/${P}-gcc44.patch \
+ "${FILESDIR}"/${P}-gcc45.patch
gnome2_src_prepare
}