summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-05-10 21:38:30 +0000
committerMike Frysinger <vapier@gentoo.org>2008-05-10 21:38:30 +0000
commitde1967a28f1038805478249b53c6b256c4448870 (patch)
tree1cb38e47c1835bfdf918a5ab8cae8d86eb7fc591 /app-editors
parentRedigest. (diff)
downloadgentoo-2-de1967a28f1038805478249b53c6b256c4448870.tar.gz
gentoo-2-de1967a28f1038805478249b53c6b256c4448870.tar.bz2
gentoo-2-de1967a28f1038805478249b53c6b256c4448870.zip
Fix building with USE=-spell #221219 by Jan.
(Portage version: 2.2_pre5)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/nano/ChangeLog7
-rw-r--r--app-editors/nano/files/nano-2.1.0-disable-speller.patch19
-rw-r--r--app-editors/nano/nano-2.1.0.ebuild3
-rw-r--r--app-editors/nano/nano-2.1.1-r1.ebuild3
-rw-r--r--app-editors/nano/nano-2.1.1.ebuild3
5 files changed, 31 insertions, 4 deletions
diff --git a/app-editors/nano/ChangeLog b/app-editors/nano/ChangeLog
index a1cab301d22d..cb0f4e0d3151 100644
--- a/app-editors/nano/ChangeLog
+++ b/app-editors/nano/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/nano
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/ChangeLog,v 1.188 2008/05/10 10:28:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/ChangeLog,v 1.189 2008/05/10 21:38:29 vapier Exp $
+
+ 10 May 2008; Mike Frysinger <vapier@gentoo.org>
+ +files/nano-2.1.0-disable-speller.patch, nano-2.1.0.ebuild,
+ nano-2.1.1.ebuild, nano-2.1.1-r1.ebuild:
+ Fix building with USE=-spell #221219 by Jan.
10 May 2008; Mike Frysinger <vapier@gentoo.org> nano-1.2.5.ebuild,
nano-1.3.12-r1.ebuild, nano-2.0.7.ebuild, nano-2.1.0.ebuild,
diff --git a/app-editors/nano/files/nano-2.1.0-disable-speller.patch b/app-editors/nano/files/nano-2.1.0-disable-speller.patch
new file mode 100644
index 000000000000..ed727d93b090
--- /dev/null
+++ b/app-editors/nano/files/nano-2.1.0-disable-speller.patch
@@ -0,0 +1,19 @@
+fix building with --disable-speller
+
+http://bugs.gentoo.org/221219
+https://savannah.gnu.org/bugs/index.php?23227
+
+--- src/global.c
++++ src/global.c
+@@ -1033,9 +1033,11 @@ void shortcut_init(bool unjustify)
+ add_to_sclist(MMAIN, "^C", do_cursorpos_void, 0, TRUE);
+ add_to_sclist(MMAIN, "F11", do_cursorpos_void, 0, TRUE);
+ #ifndef NANO_TINY
++#ifndef DISABLE_SPELLER
+ add_to_sclist(MMAIN, "^T", do_spell, 0, TRUE);
+ add_to_sclist(MMAIN, "F12", do_spell, 0, TRUE);
+ #endif
++#endif
+ add_to_sclist(MMAIN, "^_", do_gotolinecolumn_void, 0, TRUE);
+ add_to_sclist(MMAIN, "F13", do_gotolinecolumn_void, 0, TRUE);
+ add_to_sclist(MMAIN, "M-G", do_gotolinecolumn_void, 0, TRUE);
diff --git a/app-editors/nano/nano-2.1.0.ebuild b/app-editors/nano/nano-2.1.0.ebuild
index 9149a001a802..9db3f07514a6 100644
--- a/app-editors/nano/nano-2.1.0.ebuild
+++ b/app-editors/nano/nano-2.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-2.1.0.ebuild,v 1.3 2008/05/10 10:28:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-2.1.0.ebuild,v 1.4 2008/05/10 21:38:29 vapier Exp $
inherit eutils
if [[ ${PV} == "9999" ]] ; then
@@ -29,6 +29,7 @@ DEPEND=">=sys-libs/ncurses-5.2
src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}"/${P}-disable-speller.patch #221219
if [[ ! -e configure ]] ; then
./autogen.sh || die "autogen failed"
fi
diff --git a/app-editors/nano/nano-2.1.1-r1.ebuild b/app-editors/nano/nano-2.1.1-r1.ebuild
index 9cef26898a8f..5e49299a27f7 100644
--- a/app-editors/nano/nano-2.1.1-r1.ebuild
+++ b/app-editors/nano/nano-2.1.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-2.1.1-r1.ebuild,v 1.2 2008/05/10 10:28:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-2.1.1-r1.ebuild,v 1.3 2008/05/10 21:38:29 vapier Exp $
inherit eutils
if [[ ${PV} == "9999" ]] ; then
@@ -29,6 +29,7 @@ DEPEND=">=sys-libs/ncurses-5.2
src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.1.0-disable-speller.patch #221219
if [[ ! -e configure ]] ; then
./autogen.sh || die "autogen failed"
fi
diff --git a/app-editors/nano/nano-2.1.1.ebuild b/app-editors/nano/nano-2.1.1.ebuild
index e66974ca9ba5..516822f70542 100644
--- a/app-editors/nano/nano-2.1.1.ebuild
+++ b/app-editors/nano/nano-2.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-2.1.1.ebuild,v 1.4 2008/05/10 10:28:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-2.1.1.ebuild,v 1.5 2008/05/10 21:38:29 vapier Exp $
inherit eutils
if [[ ${PV} == "9999" ]] ; then
@@ -29,6 +29,7 @@ DEPEND=">=sys-libs/ncurses-5.2
src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.1.0-disable-speller.patch #221219
if [[ ! -e configure ]] ; then
./autogen.sh || die "autogen failed"
fi