summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-04-04 20:57:59 +0000
committerUlrich Müller <ulm@gentoo.org>2009-04-04 20:57:59 +0000
commitf3d965be00950c072ad9ada354172c1e7192dfb7 (patch)
treea156e1b90868463777feef205906f31d4fc07c3d /app-editors
parentVersion bumps (diff)
downloadgentoo-2-f3d965be00950c072ad9ada354172c1e7192dfb7.tar.gz
gentoo-2-f3d965be00950c072ad9ada354172c1e7192dfb7.tar.bz2
gentoo-2-f3d965be00950c072ad9ada354172c1e7192dfb7.zip
Fix build failure on SuperH, bug 262359.
(Portage version: 2.2_rc28/cvs/Linux i686)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/emacs-cvs/ChangeLog8
-rw-r--r--app-editors/emacs-cvs/emacs-cvs-23.0.92.ebuild10
-rw-r--r--app-editors/emacs-cvs/emacs-cvs-23.0.9999-r1.ebuild8
-rw-r--r--app-editors/emacs-cvs/files/emacs-23.0.92-sh.patch11
4 files changed, 32 insertions, 5 deletions
diff --git a/app-editors/emacs-cvs/ChangeLog b/app-editors/emacs-cvs/ChangeLog
index 3872850b7252..f25c99ca0b31 100644
--- a/app-editors/emacs-cvs/ChangeLog
+++ b/app-editors/emacs-cvs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/emacs-cvs
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/ChangeLog,v 1.240 2009/03/31 04:52:37 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/ChangeLog,v 1.241 2009/04/04 20:57:58 ulm Exp $
+
+ 04 Apr 2009; Ulrich Mueller <ulm@gentoo.org>
+ +files/emacs-23.0.92-sh.patch, emacs-cvs-23.0.92.ebuild,
+ emacs-cvs-23.0.9999-r1.ebuild:
+ Add __sh__ to the garbage collector conditional in gnu-linux.h. Turn off
+ optimisation on sh, in order to fix the build failure of bug 262359.
*emacs-cvs-23.0.92 (31 Mar 2009)
diff --git a/app-editors/emacs-cvs/emacs-cvs-23.0.92.ebuild b/app-editors/emacs-cvs/emacs-cvs-23.0.92.ebuild
index 43f2b3d10252..4f8cdfb446a1 100644
--- a/app-editors/emacs-cvs/emacs-cvs-23.0.92.ebuild
+++ b/app-editors/emacs-cvs/emacs-cvs-23.0.92.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-23.0.92.ebuild,v 1.1 2009/03/31 04:52:37 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-23.0.92.ebuild,v 1.2 2009/04/04 20:57:58 ulm Exp $
EAPI=2
@@ -93,6 +93,8 @@ src_prepare() {
echo
fi
+ epatch "${FILESDIR}/emacs-${PV}-sh.patch" #262359
+
sed -i -e "s:/usr/lib/crtbegin.o:$(`tc-getCC` -print-file-name=crtbegin.o):g" \
-e "s:/usr/lib/crtend.o:$(`tc-getCC` -print-file-name=crtend.o):g" \
"${S}"/src/s/freebsd.h || die "unable to sed freebsd.h settings"
@@ -118,7 +120,11 @@ src_configure() {
ALLOWED_FLAGS=""
strip-flags
#unset LDFLAGS
- replace-flags -O[3-9] -O2
+ if use sh; then
+ replace-flags -O[1-9] -O0 #262359
+ else
+ replace-flags -O[3-9] -O2
+ fi
local myconf
diff --git a/app-editors/emacs-cvs/emacs-cvs-23.0.9999-r1.ebuild b/app-editors/emacs-cvs/emacs-cvs-23.0.9999-r1.ebuild
index b11681faef28..651551a26ccf 100644
--- a/app-editors/emacs-cvs/emacs-cvs-23.0.9999-r1.ebuild
+++ b/app-editors/emacs-cvs/emacs-cvs-23.0.9999-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-23.0.9999-r1.ebuild,v 1.6 2009/03/26 20:25:00 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-23.0.9999-r1.ebuild,v 1.7 2009/04/04 20:57:58 ulm Exp $
EAPI=2
@@ -118,7 +118,11 @@ src_configure() {
ALLOWED_FLAGS=""
strip-flags
#unset LDFLAGS
- replace-flags -O[3-9] -O2
+ if use sh; then
+ replace-flags -O[1-9] -O0 #262359
+ else
+ replace-flags -O[3-9] -O2
+ fi
local myconf
diff --git a/app-editors/emacs-cvs/files/emacs-23.0.92-sh.patch b/app-editors/emacs-cvs/files/emacs-23.0.92-sh.patch
new file mode 100644
index 000000000000..d3f20fd8581d
--- /dev/null
+++ b/app-editors/emacs-cvs/files/emacs-23.0.92-sh.patch
@@ -0,0 +1,11 @@
+--- emacs-orig/src/s/gnu-linux.h
++++ emacs/src/s/gnu-linux.h
+@@ -258,7 +258,7 @@
+ #if defined __i386__ || defined __sparc__ || defined __mc68000__ \
+ || defined __alpha__ || defined __mips__ || defined __s390__ \
+ || defined __arm__ || defined __powerpc__ || defined __amd64__ \
+- || defined __ia64__
++ || defined __ia64__ || defined __sh__
+ #define GC_SETJMP_WORKS 1
+ #define GC_MARK_STACK GC_MAKE_GCPROS_NOOPS
+ #ifdef __mc68000__