summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2010-12-12 15:48:09 +0000
committerChristian Faulhammer <fauli@gentoo.org>2010-12-12 15:48:09 +0000
commitfb91d89f8d959433e8ec2d9f1d4be4940af70c0a (patch)
treef9ef4807c9071deb6219c77a28d281bb07b1b895 /app-emacs/apel/apel-10.8.ebuild
parentclean up (diff)
downloadgentoo-2-fb91d89f8d959433e8ec2d9f1d4be4940af70c0a.tar.gz
gentoo-2-fb91d89f8d959433e8ec2d9f1d4be4940af70c0a.tar.bz2
gentoo-2-fb91d89f8d959433e8ec2d9f1d4be4940af70c0a.zip
version bump
(Portage version: 2.1.9.24/cvs/Linux i686)
Diffstat (limited to 'app-emacs/apel/apel-10.8.ebuild')
-rw-r--r--app-emacs/apel/apel-10.8.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-emacs/apel/apel-10.8.ebuild b/app-emacs/apel/apel-10.8.ebuild
new file mode 100644
index 000000000000..8aff76a32e12
--- /dev/null
+++ b/app-emacs/apel/apel-10.8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/apel/apel-10.8.ebuild,v 1.1 2010/12/12 15:48:09 fauli Exp $
+
+EAPI=3
+
+inherit elisp
+
+DESCRIPTION="A Portable Emacs Library is a library for making portable Emacs Lisp programs."
+HOMEPAGE="http://cvs.m17n.org/elisp/APEL/"
+SRC_URI="ftp://ftp.jpl.org/pub/elisp/apel/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE=""
+
+src_prepare() {
+ cat <<-EOF >> APEL-CFG
+ (setq APEL_PREFIX "apel")
+ (setq EMU_PREFIX "apel")
+ EOF
+}
+
+src_compile() {
+ emake PREFIX="${ED}/usr" \
+ LISPDIR="${ED}/${SITELISP}" \
+ VERSION_SPECIFIC_LISPDIR="${ED}/${SITELISP}" || die
+}
+
+src_install() {
+ einstall PREFIX="${ED}/usr" \
+ LISPDIR="${ED}/${SITELISP}" \
+ VERSION_SPECIFIC_LISPDIR="${ED}/${SITELISP}" || die
+
+ elisp-site-file-install "${FILESDIR}/50apel-gentoo.el"
+
+ dodoc ChangeLog README*
+}
+
+pkg_postinst() {
+ elisp-site-regen
+
+ elog "See the README.en file in /usr/share/doc/${PF} for tips"
+ elog "on how to customize this package."
+ elog "And you need to rebuild packages depending on ${PN}."
+}