summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2005-02-08 11:06:40 +0000
committerMamoru Komachi <usata@gentoo.org>2005-02-08 11:06:40 +0000
commit36a1bfb2e4d9e93b3deac4524f9b3ac48d84d2b4 (patch)
tree9d28d67d0fe18e8a3a83c0a892c332914c0e6c2e /app-emacs/auctex/auctex-11.54.ebuild
parentLet EPATCH_EXCLUDE contain newlines. (diff)
downloadgentoo-2-36a1bfb2e4d9e93b3deac4524f9b3ac48d84d2b4.tar.gz
gentoo-2-36a1bfb2e4d9e93b3deac4524f9b3ac48d84d2b4.tar.bz2
gentoo-2-36a1bfb2e4d9e93b3deac4524f9b3ac48d84d2b4.zip
Version bumped. This closes bug #78738.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'app-emacs/auctex/auctex-11.54.ebuild')
-rw-r--r--app-emacs/auctex/auctex-11.54.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-emacs/auctex/auctex-11.54.ebuild b/app-emacs/auctex/auctex-11.54.ebuild
new file mode 100644
index 000000000000..0cbb799c02b1
--- /dev/null
+++ b/app-emacs/auctex/auctex-11.54.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/auctex/auctex-11.54.ebuild,v 1.1 2005/02/08 11:06:40 usata Exp $
+
+inherit elisp
+
+DESCRIPTION="AUCTeX is an extensible package that supports writing and formatting TeX files"
+HOMEPAGE="http://www.gnu.org/software/auctex"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64 ~sparc ~ppc-macos"
+IUSE=""
+
+DEPEND="virtual/tetex"
+
+src_compile() {
+ econf --with-auto-dir=${D}/var/lib/auctex \
+ --with-lispdir=${D}/usr/share/emacs/site-lisp \
+ --with-tex-input-dirs="/usr/share/texmf/tex/;/usr/share/texmf/bibtex/bst/" || die "econf failed"
+ emake || die
+
+ # bug #72637
+ elisp-comp *.el || die
+}
+
+src_install() {
+ einstall || die
+ elisp-install ${PN} bib-cite.el* tex-jp.el* || die
+ dosed ${SITELISP}/tex-site.el || die
+ elisp-site-file-install ${FILESDIR}/50auctex-gentoo.el
+ dodoc ChangeLog CHANGES README RELEASE TODO FAQ INSTALL*
+}