summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2011-01-17 08:13:53 +0000
committerUlrich Müller <ulm@gentoo.org>2011-01-17 08:13:53 +0000
commitd543f63ebeefef326e7b59e35b803b4586ba36ea (patch)
tree509a4bc20e3897af582b60017fe091df33715ef6 /app-emacs/auctex
parentCleanup (diff)
downloadgentoo-2-d543f63ebeefef326e7b59e35b803b4586ba36ea.tar.gz
gentoo-2-d543f63ebeefef326e7b59e35b803b4586ba36ea.tar.bz2
gentoo-2-d543f63ebeefef326e7b59e35b803b4586ba36ea.zip
Fix preview PNG generation with ghostscript-gpl-9.00, bug 351774.
(Portage version: 2.1.9.31/cvs/Linux x86_64)
Diffstat (limited to 'app-emacs/auctex')
-rw-r--r--app-emacs/auctex/ChangeLog10
-rw-r--r--app-emacs/auctex/auctex-11.86-r1.ebuild69
-rw-r--r--app-emacs/auctex/files/auctex-11.86-ghostscript9.patch42
3 files changed, 119 insertions, 2 deletions
diff --git a/app-emacs/auctex/ChangeLog b/app-emacs/auctex/ChangeLog
index 981c202d7795..91d281af1587 100644
--- a/app-emacs/auctex/ChangeLog
+++ b/app-emacs/auctex/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/auctex
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/auctex/ChangeLog,v 1.105 2010/12/12 15:43:51 fauli Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/auctex/ChangeLog,v 1.106 2011/01/17 08:13:52 ulm Exp $
+
+*auctex-11.86-r1 (17 Jan 2011)
+
+ 17 Jan 2011; Ulrich Mueller <ulm@gentoo.org> +auctex-11.86-r1.ebuild,
+ +files/auctex-11.86-ghostscript9.patch:
+ Fix preview PNG generation with ghostscript-gpl-9.00, bug 351774.
12 Dec 2010; Christian Faulhammer <fauli@gentoo.org> -auctex-11.85.ebuild:
clean up
diff --git a/app-emacs/auctex/auctex-11.86-r1.ebuild b/app-emacs/auctex/auctex-11.86-r1.ebuild
new file mode 100644
index 000000000000..acd0bffdbaad
--- /dev/null
+++ b/app-emacs/auctex/auctex-11.86-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/auctex/auctex-11.86-r1.ebuild,v 1.1 2011/01/17 08:13:52 ulm Exp $
+
+EAPI=3
+
+inherit elisp eutils latex-package
+
+DESCRIPTION="Extended support for writing, formatting and using (La)TeX, Texinfo and BibTeX files"
+HOMEPAGE="http://www.gnu.org/software/auctex/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3 FDL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE="preview-latex"
+
+DEPEND="virtual/latex-base
+ preview-latex? ( !dev-tex/preview-latex
+ app-text/dvipng
+ app-text/ghostscript-gpl )"
+RDEPEND="${DEPEND}"
+
+ELISP_PATCHES="${P}-ghostscript9.patch"
+TEXMF="/usr/share/texmf-site"
+
+src_prepare() {
+ elisp_src_prepare
+}
+
+src_configure() {
+ # Remove broken Info file (will be recreated by the build system)
+ rm doc/auctex.info*
+
+ EMACS_NAME=emacs EMACS_FLAVOUR=emacs econf --disable-build-dir-test \
+ --with-auto-dir="${EPREFIX}/var/lib/auctex" \
+ --with-lispdir="${EPREFIX}${SITELISP}/${PN}" \
+ --with-packagelispdir="${EPREFIX}${SITELISP}/${PN}" \
+ --with-packagedatadir="${EPREFIX}${SITEETC}/${PN}" \
+ --with-texmf-dir="${EPREFIX}${TEXMF}" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ $(use_enable preview-latex preview) || die "econf failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+ cd doc; emake tex-ref.pdf || die "creation of tex-ref.pdf failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+ elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el" || die
+ if use preview-latex; then
+ elisp-site-file-install "${FILESDIR}/60${PN}-gentoo.el" || die
+ fi
+ keepdir /var/lib/auctex
+ dodoc ChangeLog CHANGES README RELEASE TODO FAQ INSTALL*
+}
+
+pkg_postinst() {
+ # rebuild TeX-inputfiles-database
+ use preview-latex && latex-package_pkg_postinst
+ elisp-site-regen
+}
+
+pkg_postrm(){
+ use preview-latex && latex-package_pkg_postrm
+ elisp-site-regen
+}
diff --git a/app-emacs/auctex/files/auctex-11.86-ghostscript9.patch b/app-emacs/auctex/files/auctex-11.86-ghostscript9.patch
new file mode 100644
index 000000000000..e8ca32b183d8
--- /dev/null
+++ b/app-emacs/auctex/files/auctex-11.86-ghostscript9.patch
@@ -0,0 +1,42 @@
+http://bugs.gentoo.org/351774
+Patch from upstream CVS
+
+--- auctex-11.86-orig/preview/preview.el
++++ auctex-11.86/preview/preview.el
+@@ -355,7 +355,7 @@
+ :group 'preview-gs
+ :type 'string)
+
+-(defcustom preview-gs-options '("-q" "-dSAFER" "-dNOPAUSE"
++(defcustom preview-gs-options '("-q" "-dDELAYSAFER" "-dNOPAUSE"
+ "-DNOPLATFONTS" "-dPrinted"
+ "-dTextAlphaBits=4"
+ "-dGraphicsAlphaBits=4")
+@@ -1066,14 +1066,21 @@
+
+ (defun preview-prepare-fast-conversion ()
+ "This fixes up all parameters for fast conversion."
+- (let ((file (if (consp (car preview-ps-file))
+- (if (consp (caar preview-ps-file))
+- (car (last (caar preview-ps-file)))
+- (caar preview-ps-file))
+- (car preview-ps-file))))
++ (let* ((file (if (consp (car preview-ps-file))
++ (if (consp (caar preview-ps-file))
++ (car (last (caar preview-ps-file)))
++ (caar preview-ps-file))
++ (car preview-ps-file)))
++ (all-files (if (and (consp (car preview-ps-file))
++ (consp (caar preview-ps-file)))
++ (caar preview-ps-file)
++ (list file))))
+ (setq preview-gs-dsc (preview-dsc-parse file))
+ (setq preview-gs-init-string
+- (concat preview-gs-init-string
++ (concat (format "{<</PermitFileReading[%s]>> setuserparams \
++.locksafe} stopped pop "
++ (mapconcat 'preview-ps-quote-filename all-files ""))
++ preview-gs-init-string
+ (format "[%s(r)file]aload exch %s .runandhide aload pop "
+ (preview-ps-quote-filename file)
+ (preview-gs-dsc-cvx 0 preview-gs-dsc))))))