summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-04-25 16:56:26 +0000
committerMamoru Komachi <usata@gentoo.org>2004-04-25 16:56:26 +0000
commita0fa42f4bf1bed90b63391e6b967ab1b6386f64c (patch)
tree58e613e561c59740d268df57cdec2b65710ed170 /app-emacs/bbdb/bbdb-2.35_pre20040323.ebuild
parentClosing #39761 and #27087 + many other changes. (Manifest recommit) (diff)
downloadgentoo-2-a0fa42f4bf1bed90b63391e6b967ab1b6386f64c.tar.gz
gentoo-2-a0fa42f4bf1bed90b63391e6b967ab1b6386f64c.tar.bz2
gentoo-2-a0fa42f4bf1bed90b63391e6b967ab1b6386f64c.zip
Added CVS snapshot and decode-header fix patch. Thanks to Markus Knitting <makmaster@arcor.de> for submitting the ebuild. Closing bug #48345
Diffstat (limited to 'app-emacs/bbdb/bbdb-2.35_pre20040323.ebuild')
-rw-r--r--app-emacs/bbdb/bbdb-2.35_pre20040323.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/app-emacs/bbdb/bbdb-2.35_pre20040323.ebuild b/app-emacs/bbdb/bbdb-2.35_pre20040323.ebuild
new file mode 100644
index 000000000000..34a0c18d814c
--- /dev/null
+++ b/app-emacs/bbdb/bbdb-2.35_pre20040323.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/bbdb/bbdb-2.35_pre20040323.ebuild,v 1.1 2004/04/25 16:56:26 usata Exp $
+
+inherit elisp
+
+IUSE="crypt"
+
+DESCRIPTION="The Big Brother Database"
+HOMEPAGE="http://bbdb.sourceforge.net/"
+# taken from http://bbdb.sourceforge.net/${P}.tar.gz
+SRC_URI="mirror://gentoo/${P}.tar.gz
+ http://www.mit.edu/afs/athena/contrib/emacs-contrib/Fin/point-at.el
+ http://www.mit.edu/afs/athena/contrib/emacs-contrib/Fin/dates.el"
+LICENSE="GPL-2 as-is"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+DEPEND="virtual/emacs"
+RDEPEND="${DEPEND}
+ crypt? ( app-emacs/mailcrypt )"
+
+S="${WORKDIR}/${P/_pre*/}"
+
+src_unpack() {
+
+ unpack ${P}.tar.gz
+ cd ${S}
+ epatch ${FILESDIR}/bbdb-decode-header.diff
+ cd ${S}/bits
+ mv bbdb-mail-folders.el bbdb-mail-folders.txt
+ sed -e "0,/^--- bbdb-mail-folders.el ---$/d" \
+ -e "/^--- end ---$/,+4d" \
+ bbdb-mail-folders.txt > bbdb-mail-folders.el
+ mv bbdb-sort-mailrc.el bbdb-sort-mailrc.txt
+ sed -e "0,/^Bng$/d" \
+ bbdb-sort-mailrc.txt > bbdb-sort-mailrc.el
+ cp ${DISTDIR}/{dates,point-at}.el .
+
+ if [ -z "`use crypt`" ] ; then
+ rm ${S}/bits/bbdb-pgp.el
+ einfo "Excluding bits/bbdb-pgp.el because the \`crypt' USE flag was not"
+ einfo "specified."
+ fi
+
+}
+
+src_compile() {
+
+ econf --with-emacs=emacs || die "econf failed"
+ emake -j1 || die "emake failed"
+ cat >${T}/lp.el<<-EOF
+ (add-to-list 'load-path "${S}/bits")
+ (add-to-list 'load-path "${S}/lisp")
+ EOF
+ emacs -batch -q --no-site-file --no-init-file \
+ -l ${T}/lp.el -f batch-byte-compile bits/*.el \
+ || die "make bits failed"
+}
+
+src_install() {
+ elisp-install ${PN} lisp/*.el lisp/*.elc || die
+ elisp-install ${PN}/bits bits/*.el bits/*.elc || die
+ elisp-site-file-install ${FILESDIR}/50bbdb-gentoo.el || die
+
+ doinfo texinfo/*.info*
+ dodoc ChangeLog INSTALL README bits/*.txt
+ newdoc bits/README README.bits
+}