summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2011-07-10 06:27:12 +0000
committerNaohiro Aota <naota@gentoo.org>2011-07-10 06:27:12 +0000
commitf4ff6d68988e3f590556c783a86ddd011af21414 (patch)
tree2fed61209c5a60b4b7de8aaab9661fb4820b5a78 /app-emacs/calfw
parentVersion bump and remove old. (diff)
downloadgentoo-2-f4ff6d68988e3f590556c783a86ddd011af21414.tar.gz
gentoo-2-f4ff6d68988e3f590556c783a86ddd011af21414.tar.bz2
gentoo-2-f4ff6d68988e3f590556c783a86ddd011af21414.zip
Add fix for calfw.el
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'app-emacs/calfw')
-rw-r--r--app-emacs/calfw/ChangeLog6
-rw-r--r--app-emacs/calfw/calfw-1.1.ebuild3
-rw-r--r--app-emacs/calfw/files/calfw-1.1-calfwel.patch58
3 files changed, 65 insertions, 2 deletions
diff --git a/app-emacs/calfw/ChangeLog b/app-emacs/calfw/ChangeLog
index 380b65cec8e2..0b5f86b01bdc 100644
--- a/app-emacs/calfw/ChangeLog
+++ b/app-emacs/calfw/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emacs/calfw
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/calfw/ChangeLog,v 1.3 2011/07/10 03:16:06 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/calfw/ChangeLog,v 1.4 2011/07/10 06:27:12 naota Exp $
+
+ 10 Jul 2011; Naohiro Aota <naota@gentoo.org> calfw-1.1.ebuild,
+ +files/calfw-1.1-calfwel.patch:
+ Add fix for calfw.el
*calfw-1.1 (10 Jul 2011)
diff --git a/app-emacs/calfw/calfw-1.1.ebuild b/app-emacs/calfw/calfw-1.1.ebuild
index 1af737ceadce..88a6804d78fd 100644
--- a/app-emacs/calfw/calfw-1.1.ebuild
+++ b/app-emacs/calfw/calfw-1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/calfw/calfw-1.1.ebuild,v 1.1 2011/07/10 03:16:06 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/calfw/calfw-1.1.ebuild,v 1.2 2011/07/10 06:27:12 naota Exp $
EAPI=3
NEED_EMACS=22
@@ -27,5 +27,6 @@ src_unpack() {
}
src_prepare() {
+ epatch "${FILESDIR}"/${P}-calfwel.patch
use howm || rm -f calfw-howm.el
}
diff --git a/app-emacs/calfw/files/calfw-1.1-calfwel.patch b/app-emacs/calfw/files/calfw-1.1-calfwel.patch
new file mode 100644
index 000000000000..cc2658cd9850
--- /dev/null
+++ b/app-emacs/calfw/files/calfw-1.1-calfwel.patch
@@ -0,0 +1,58 @@
+diff --git a/calfw.el b/calfw.el
+index 5a72627..2fa2f9e 100644
+--- a/calfw.el
++++ b/calfw.el
+@@ -984,13 +984,16 @@ calling functions `cfw:annotations-functions'."
+ (t
+ (loop for s in sources
+ for f = (cfw:source-data s)
+- for cnt = (funcall f begin end)
++ for cnts = (funcall f begin end)
+ with annotations = nil
+- for prv = (cfw:contents-get-internal d annotations)
+- if prv
+- do (set-cdr prv (concat (cdr prv) "/" (cdr cnt)))
+- else
+- do (push (copy-sequence cnt) annotations)
++ do
++ (loop for c in cnts
++ for (d . line) = c
++ for prv = (cfw:contents-get-internal d annotations)
++ if prv
++ do (setcdr prv (concat (cdr prv) "/" line))
++ else
++ do (push (cons d line) annotations))
+ finally return annotations))))
+
+
+@@ -2380,7 +2383,7 @@ DATE is initial focus date. If it is nil, today is selected initially."
+ ((1 14 2011) (1 15 2011) "Stack")
+ ((1 29 2011) (1 31 2011) "PERIOD W"))
+ ))))
+- (asource
++ (asource1
+ (make-cfw:source
+ :name "Moon"
+ :data
+@@ -2390,10 +2393,20 @@ DATE is initial focus date. If it is nil, today is selected initially."
+ ((1 20 2011) . "Full Moon")
+ ((1 26 2011) . "Waning Moon")
+ ))))
++ (asource2
++ (make-cfw:source
++ :name "Moon"
++ :data
++ (lambda (b e)
++ '(((1 5 2011) . "AN1")
++ ((1 13 2011) . "AN2")
++ ((1 20 2011) . "AN3")
++ ((1 28 2011) . "AN4")
++ ))))
+ (cp (cfw:create-calendar-component-buffer
+ :view 'month
+ :contents-sources (list source1 source2)
+- :annotation-sources (list asource))))
++ :annotation-sources (list asource1 asource2))))
+ (cfw:cp-add-update-hook cp (lambda () (message "CFW: UPDATE HOOK")))
+ (cfw:cp-add-click-hook cp (lambda () (message "CFW: CLICK HOOK %S" (cfw:cursor-to-nearest-date))))
+ (cfw:cp-add-selection-change-hook cp (lambda () (message "CFW: SELECT %S" (cfw:cursor-to-nearest-date))))